E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 191 votes, 5.00 average. Display Modes
Old 02-12-2014, 04:45 PM   #441
Lucky1505
Registered User
 
Join Date: Feb 2014
Location: Sierra Vista, AZ
Posts: 10
My Ride: 2006 330Ci conv
Quote:
Originally Posted by Furior View Post
You have to buy an extension cable ( https://avinusa.com/6-meter-navigati...ion-cable.html ) which you route from trunk (radio module harness) to AVIN unit.
You are referring to the (required, in my case) extension cable for the 6 pin and 3 pin cd changer harness located in the trunk, I was referring to the two 12 pin bundles that connect the head unit to the vehicle, located in the dash.
Lucky1505 is offline   Reply With Quote
Old 02-12-2014, 07:21 PM   #442
JuanPa
Registered User
 
Join Date: Sep 2011
Location: Costa Rica
Posts: 6
My Ride: 2003 BMW 320i
Quote:
Originally Posted by Lucky1505 View Post
Does anyone know if the Avin supports the exFat SDXC card format?
No, it doesn't. Tested with Sandisk Ultra 64GB MicroSDXC. The one of 32GB does work.
JuanPa is offline   Reply With Quote
Old 02-12-2014, 07:29 PM   #443
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
In context of the last post: Alternative Media-Players for uSD?
Mine takes always ages - even after 5m Standby at the gas-station - reading the uSD and even then doesn't resume where it was playing last..
That's really annoying..

Michael
Makki is offline   Reply With Quote
Old 02-12-2014, 09:43 PM   #444
tommy@avinusa.com
AKA: M3Evolution
 
tommy@avinusa.com's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 188
My Ride: 2003 M3 SMG
Quote:
Originally Posted by Makki View Post
In context of the last post: Alternative Media-Players for uSD?
Mine takes always ages - even after 5m Standby at the gas-station - reading the uSD and even then doesn't resume where it was playing last..
That's really annoying..

Michael
Have you tried other apps like PowerAmp? You might need to configure the setting in those app to point to the correct folder on the sdcard or usb flash drive though.

We are still working on the software update but the new update should make it possible to change tracks in PowerAmp just like in the E39 models.
tommy@avinusa.com is offline   Reply With Quote
Old 02-12-2014, 09:47 PM   #445
tommy@avinusa.com
AKA: M3Evolution
 
tommy@avinusa.com's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 188
My Ride: 2003 M3 SMG
Quote:
Originally Posted by Kattlikzm View Post
Yeah Iīve been struggling to find out waht the problem was until I asked a friend of mine who has Dynavin. He said it could be some issues with the canbus box thingy.
Thats when i realized that I never got a canbus. Instead I connected the white connector that goes to the canbus behind Avin.

So there we have it! Everything works now I just need a canbus box from Tommy. canīt wait to put everything where it belongs. My car has been standing in the driveway with all interior removed for a month now haha. Havenīt driven my car for a month! So i just cannot wait to get my car on the road again!
Sorry about the missing canbus box. A brand new one will be shipped out to you asap!
tommy@avinusa.com is offline   Reply With Quote
Old 02-13-2014, 09:32 AM   #446
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
Tried PowerAmp today:
- Volume is way lower than "normal", Sound is disorted
- No SWC/Buttons/right knob - so simply unusable while driving

As I'd prefer OSS anyway, tried some other from F-Driod today:
- Apollo (doesn't get the second SD-Card)
- andLess: this is very close to what I need: no fancy Album-covers etc - just browse directorys and play MP3s
But still no SWC, buttons: maybe this could be implemented: any hints on any docs or OSS-Code how this works together?

Michael
Makki is offline   Reply With Quote
Old 02-13-2014, 09:40 AM   #447
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
Swap

Is there a guide on how to enable swap?
I got both, the included 8G and 32G uSD from Avin but there doesn't seem to be a swap-partition active on them..
As there are some ~348MB total mem according to the console (where is the remainder to 512MB gone?) and Background-Apps already got killed while playing with GMaps and OsmAnd in parallel, it might make sense..
I could resize/create the partion under Ubuntu, no problem, just want to get the "right way"

Michael
Makki is offline   Reply With Quote
Old 02-13-2014, 09:58 AM   #448
Ironman273
Registered User
 
Join Date: Aug 2005
Location: Pembroke Pines, FL
Posts: 43
My Ride: 2003 BMW 530i
Quote:
Originally Posted by Makki View Post
Tried PowerAmp today:
- Volume is way lower than "normal", Sound is disorted
- No SWC/Buttons/right knob - so simply unusable while driving

As I'd prefer OSS anyway, tried some other from F-Driod today:
- Apollo (doesn't get the second SD-Card)
- andLess: this is very close to what I need: no fancy Album-covers etc - just browse directorys and play MP3s
But still no SWC, buttons: maybe this could be implemented: any hints on any docs or OSS-Code how this works together?

Michael
There is a checkbox for "Direct Volume Control" under Advanced Audio settings in PowerAmp. Disable that and the volume should return to normal.


As for SWC, they've always worked for me on PowerAmp but not for other users, not sure why. I posted a video of it working for me earlier in the thread.
Ironman273 is offline   Reply With Quote
Old 02-13-2014, 10:41 AM   #449
jeffb325@NavigationSolutions
J&T Distributing
 
jeffb325@NavigationSolutions's Avatar
 
Join Date: Jun 2010
Location: Fresno, CA
Posts: 2,697
My Ride: BMW
Quote:
Originally Posted by Ironman273 View Post
There is a checkbox for "Direct Volume Control" under Advanced Audio settings in PowerAmp. Disable that and the volume should return to normal.


As for SWC, they've always worked for me on PowerAmp but not for other users, not sure why. I posted a video of it working for me earlier in the thread.
I was just about to post this about poweramp.....that "direct volume control" setting had me scratching my head for a while before I figured it out.
__________________
USE COUPON CODE FANATICS AT CHECKOUT TO GET A $50 FORUM DISCOUNT ON THE NEW DYNAVIN N6 UNITS!



LATEST DYNAVIN INFO: http://forum.e46fanatics.com/showthread.php?t=1044105
DYNAVIN FAQ:http://www.jandtdistributing.com/pages/faq-links
///AVIN INFO: http://forum.e46fanatics.com/showthread.php?t=1015704
TO BUY http://jandtdistributing.com
jeffb325@NavigationSolutions is offline   Reply With Quote
Old 02-14-2014, 07:41 AM   #450
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
Thank you, this checkbox for "Direct Volume control" indeed resolves this!
Still, it's a nice gimmick-player for the tablet at home, without SWC/Buttons it's IMHO not operable while driving..

Still any hints (technical) on the interaction between SWC, Hard-buttons/knob and the play appreciated

Michael
Makki is offline   Reply With Quote
Old 02-15-2014, 01:46 PM   #451
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
Had two rides today of about 3-5km: the SD-Player is ununsable as it takes the time to startup/index the SD
Without changing the uSD at all, just to mention..

With givin out some more detailed informations on how (control) things works internally, it should be easy to adopt this to OSS-Mediaplayers..

Michael
Makki is offline   Reply With Quote
Old 02-15-2014, 09:19 PM   #452
Kattlikzm
Registered User
 
Join Date: Mar 2013
Location: Norway
Posts: 19
My Ride: 2000 E46 320Ci
Just a quick question about spotify:
Im downloading my spotify playlists, which have about 600 songs in total.
The downloading prossess however is SUPER SLOW. Iīve let the unit download songs for more than 28 hours now, and about 60% has been done. Why is it that slow?
My wifi is super strong, and my router is having no problems. I can download about 600 spotify songs in about 2 hours from my phone, while Avin downloads about 5-8 songs.
__________________
Kattlikzm is offline   Reply With Quote
Old 02-15-2014, 09:19 PM   #453
Kattlikzm
Registered User
 
Join Date: Mar 2013
Location: Norway
Posts: 19
My Ride: 2000 E46 320Ci
Just a quick question about spotify:
Im downloading my spotify playlists, which have about 600 songs in total.
The downloading prossess however is SUPER SLOW. Iīve let the unit download songs for more than 28 hours now, and about 60% has been done. Why is it that slow?
My wifi is super strong, and my router is having no problems. I can download about 600 spotify songs in about 2 hours from my phone, while Avin downloads about 5-8 songs.
__________________
Kattlikzm is offline   Reply With Quote
Old 02-16-2014, 01:06 AM   #454
Slamurai
Registered User
 
Join Date: Jun 2012
Location: Calgary
Posts: 37
My Ride: 2003 330i ZHP
Just finished installing mine today and here to share some comments and questions.

After installation my airbag light is on, anyone have any ideas? Can I get this reset at a mechanic and see if it comes back?

Check engine light is on, not too worried but happened.

I can not tether internet from my LTE phone through USB? Doesn't seem to pick up internet that way.

I can not get youtube running at an acceptable level.
Downloaded the app but the videos are so choppy is not useable and that was the main reason for buying this. I was connected via WiFI to my phone which had full bars of LTE. The Wireless signal on the AVIN was full too.

Any ideas on the youtube issue?

I know the hardware spec are much better than Dynavin but its still not enough for a power user. Its tough to satisfy people with technology thats 5 years old already.

4.0..... Would love to get that on the AVIN
Slamurai is offline   Reply With Quote
Old 02-16-2014, 06:52 AM   #455
tommy@avinusa.com
AKA: M3Evolution
 
tommy@avinusa.com's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 188
My Ride: 2003 M3 SMG
Quote:
Originally Posted by Makki View Post
Is there a guide on how to enable swap?
I got both, the included 8G and 32G uSD from Avin but there doesn't seem to be a swap-partition active on them..
As there are some ~348MB total mem according to the console (where is the remainder to 512MB gone?) and Background-Apps already got killed while playing with GMaps and OsmAnd in parallel, it might make sense..
I could resize/create the partion under Ubuntu, no problem, just want to get the "right way"

Michael
SWAP is activated at boot and the system will check if there is a sdcard with SWAP partition then. If you inserted the sdcard with SWAP partition while the unit was powered on you will need to reboot the system (note: I do not mean factory restore the system only a regular reboot)

To check SWAP status you will need to install a terminal app and type the words "busybox free" without the quotes. That will show you how much memory and SWAP is being used.
tommy@avinusa.com is offline   Reply With Quote
Old 02-16-2014, 06:56 AM   #456
tommy@avinusa.com
AKA: M3Evolution
 
tommy@avinusa.com's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 188
My Ride: 2003 M3 SMG
Quote:
Originally Posted by Makki View Post
Thank you, this checkbox for "Direct Volume control" indeed resolves this!
Still, it's a nice gimmick-player for the tablet at home, without SWC/Buttons it's IMHO not operable while driving..

Still any hints (technical) on the interaction between SWC, Hard-buttons/knob and the play appreciated

Michael
The new software update that we are working on for the E46 should be able to address the SWC so that it can also control other apps like PowerAmp.

We are hoping to have the software update ready by next weekend. This software update is only to address bugs and not a major change and not a new OS version.
tommy@avinusa.com is offline   Reply With Quote
Old 02-16-2014, 07:02 AM   #457
tommy@avinusa.com
AKA: M3Evolution
 
tommy@avinusa.com's Avatar
 
Join Date: Nov 2013
Location: California
Posts: 188
My Ride: 2003 M3 SMG
Quote:
Originally Posted by Slamurai View Post
Just finished installing mine today and here to share some comments and questions.

After installation my airbag light is on, anyone have any ideas? Can I get this reset at a mechanic and see if it comes back?

Check engine light is on, not too worried but happened.

I can not tether internet from my LTE phone through USB? Doesn't seem to pick up internet that way.

I can not get youtube running at an acceptable level.
Downloaded the app but the videos are so choppy is not useable and that was the main reason for buying this. I was connected via WiFI to my phone which had full bars of LTE. The Wireless signal on the AVIN was full too.

Any ideas on the youtube issue?

I know the hardware spec are much better than Dynavin but its still not enough for a power user. Its tough to satisfy people with technology thats 5 years old already.

4.0..... Would love to get that on the AVIN
For the wifi issue try to unplug the wifi adapter and plug it in the other USB port and vice versa making sure its secure tight connection.

Installation of the AVIN unit should not have any effect on your Airbags or check engine lights. You might want to check the fuses inside the glove boxes making sure none are out.

USB tethering will depend on the phone and also the service provider. It is usually free to use but some service provider block this feature or try to charge customers extra for using it.
tommy@avinusa.com is offline   Reply With Quote
Old 02-16-2014, 01:17 PM   #458
Slamurai
Registered User
 
Join Date: Jun 2012
Location: Calgary
Posts: 37
My Ride: 2003 330i ZHP
Hey Tommy,

Thanks for the quick reply.

I got chance to do some more testing last night and all apps using the internet are extremely slow to respond.

Downloaded speedtest.net and I'm getting 1100ms ping + 0.46mbps down 0.5mbps up.

After that I do the same speed test on my phone thats providing the wifi hotshot and I get 10mbps down and 15 mbps up @ 94ms.

If the Avin had this type of Internet connection I'd be extremely happy.

I did get my corporate email working which is a bonus.

For some reason facebook app doesn't fill the screen, its takes up a 1/4 of it so its no really useable.

Torque, are there any instructions on pairing the OBDII to the AVIN. The bluetooth option just says scanning and never finds the bluetooth OBDII.

I'm in the middle of download music movies etc for more testing. I will come back and repost.

Tethering on my phone and carrier is allowed I do it to PC's all the time. Unfortunately never tried it on another android device. When I do this nothing happens on the AVIN. It doesn't pick up a connection. Is there something I need to do. To diagnose these internet speed issues better I would like to try another connection source to see if the problem still exists. Am I able to try a different WIFI USB adapter or tdoes the AVIN have drivers for this one installed?


Should I be able to tether through bluetooth as well?

Last edited by Slamurai; 02-16-2014 at 01:20 PM.
Slamurai is offline   Reply With Quote
Old 02-16-2014, 05:06 PM   #459
Makki
Registered User
 
Join Date: Jan 2014
Location: Munich, Germany
Posts: 25
My Ride: E46 330Ci
Quote:
Originally Posted by tommy@avinusa.com View Post
SWAP is activated at boot ..
Thanks, worked fine using either the first or second uSD!
I just was confused as I'm pretty well fine deeply in Linux - but Android isn't Linux obviously
Theres no swap mounted but "busybox free" (which is just "free" or /proc/meminfo in "real" Linux) shows both swap-partitions mounted/used.
Just a "check" on this point, fine..

Michael
Makki is offline   Reply With Quote
Old 02-18-2014, 05:21 PM   #460
Slamurai
Registered User
 
Join Date: Jun 2012
Location: Calgary
Posts: 37
My Ride: 2003 330i ZHP
Hello Folks,

I've been playing with the AVIN for a few days now trying to get it functioning properly and wanted to reach out to other users for suggestions.

I'm having issues with a few apps.


Apps

Facebook - Takes up a quarter of the screen in the middle. also facebook won't let you change menu's. For example I see that a Facebook message comes up, I click on it and Facebook comes up as this tiny application (1/4) screen. I can respond to the message but them when I want to look at the news feed it just stays on the message screen. can't navigate around facebook within the app.

Youtube

The first search I do works fine and I can play the video but then when I go to search for the next song it brings me back to my first/previous search result. I have go back to the home screen and then go back to youtube to enter an new search.

Soundcloud

This app doesn't work at all when you try to play music it just keeps trying to load forever.

Any insight would be great
Slamurai is offline   Reply With Quote
Reply

Tags
android, avant, avin, dynavin, eonon, m3evolution

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use