E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-12-2013, 12:28 AM   #1
clinton902295
Registered User
 
Join Date: Nov 2013
Location: connecticut
Posts: 4
My Ride: e46 330xi
2001 330xi instrumnt cluster issue.

So what happened was, i changed the blower resistor on my car but had the battery unplugged, wasn't sure so as safety, when i replugged in after the job and started the car the cluster wasn't working. But an ABS light came on, nothing else, my rpm, temp, speedometer, the digital nothing works but when the car starts up abs come one stays and the airbag light goes on then off. Does anyone know or have any idea of what could be the cause? I checked the fuses they are all set im just lost.
clinton902295 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-15-2013, 08:14 AM   #2
basketthis
Registered User
 
Join Date: Jan 2011
Location: East Coast
Posts: 299
My Ride: state to state
Re: 2001 330xi instrumnt cluster issue.

Quote:
Originally Posted by clinton902295 View Post
So what happened was, i changed the blower resistor on my car but had the battery unplugged, wasn't sure so as safety, when i replugged in after the job and started the car the cluster wasn't working. But an ABS light came on, nothing else, my rpm, temp, speedometer, the digital nothing works but when the car starts up abs come one stays and the airbag light goes on then off. Does anyone know or have any idea of what could be the cause? I checked the fuses they are all set im just lost.
"see, what had happened was... "

I've never removed the cluster personally. I know there is communication between it and the computer and other components. Even when the car is off. Not sure why you are having an issue when the battery was unhooked.
My suggestion is to call BMW, talk to a technician (if that's possible), or call a local BMW-specific shop, talk to someone knowledgeable and get your answer. Those guys mess with that stuff all the time. Not to take anything from anyone, but most of us here are regular and preventative maintenance guys.
basketthis is online now   Reply With Quote
Old 11-17-2013, 02:46 PM   #3
tomoyer
Registered User
 
Join Date: Aug 2011
Location: Reading, Pennsylvania
Posts: 799
My Ride: 03 325xi, 03 330xi
Send a message via Yahoo to tomoyer
Just a silly question at this point; you "unplugged the battery"? Which cable did you remove?
tomoyer is offline   Reply With Quote
Old 11-17-2013, 07:06 PM   #4
clinton902295
Registered User
 
Join Date: Nov 2013
Location: connecticut
Posts: 4
My Ride: e46 330xi
i called the dealer they havent herd of this issue but want, 300 to reprogram the system including diagnostic cost
clinton902295 is offline   Reply With Quote
Old 11-17-2013, 07:08 PM   #5
clinton902295
Registered User
 
Join Date: Nov 2013
Location: connecticut
Posts: 4
My Ride: e46 330xi
To the otther guy im not sure but i usually unplug the negative first, what are affects of unplugging positive first? @ tomoyer
clinton902295 is offline   Reply With Quote
Old 11-17-2013, 08:52 PM   #6
tomoyer
Registered User
 
Join Date: Aug 2011
Location: Reading, Pennsylvania
Posts: 799
My Ride: 03 325xi, 03 330xi
Send a message via Yahoo to tomoyer
All you should have to do is remove the Ground/Negative cable from the battery post and isolate it so that it can not contact any metal part of the body. As long the Negative Cable is completely isolated from the body and battery, you have an "open circuit". Sounds as though you had a surge of power to the Central Control Module thru which all things on the dash and a few other systems, such as interior lights, trunk lights and others runs thru. Depending on how bad it is, they may be able to re-program the car, maybe not, diagnostics will tell them if the Module is bad or partly toasted. If the Module needs to be replaced, it alone costs about $400.00 plus the hour to install and about 2 hours of programming.
tomoyer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use