E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 14 votes, 5.00 average. Display Modes
Old 03-04-2014, 06:35 AM   #181
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by WOLFN8TR View Post
RESET
Close error message (might need to close several error messages) once closed push the reset button next to the GPS slot, system will reboot.

READ THIS:
http://forum.e46fanatics.com/showthr...003890&page=24

I just did the firmware update on a D5150 and it works fine. I now have the GM 5150 UI and functionality. I got the files from here:
http://www.e46zone.com/forum/topic/4...upgrade/page-3

I downloaded firmware from the following:
GM5150 Firmware

The download is a .RAR file. Once I unzipped it I placed the "NWD_703" folder onto a micro SD card and put that in the GPS port. Turned the ignition on and the unit did the rest. I had to calibrate the screen and then scroll down to change the language.

My unit is back to being excellent. It may have also fixed an error I had with the clock repeatedly changing the time even when GPS sync was unchecked.

Originally Posted by EononCarDVD
I saw your post that the head unit run the Launch exe error.
Could you kindly confirm you have the D5150/GM5150 with the BMW UI? If yes, then, here is the software for your reference
http://www.sbo2.com/cs_serial//BMW_A...146-140219.rar
Instructions:
1. Copied the folder of files to the SD card.
2. Turned key to position one and turned on head unit
3. Inserted SD card and left the Eonon head unit on.
Turn key off, waited 10 seconds, turn key back to position one and head unit powered back on and read the SD card.
4. It went through about four steps, then restarted and please calibrate the touch screen per the instructions.
5. Remove the SD card and hit reset. If you forget to take out the SD card, it reloads again

Hope it will help you
Please kindly let us k now the testing result then. Thanks

Regards
Carlos
eonon.com
well the links seem to be broken to the rar files

GM5150 Firmware

but this one seems to work. also the broken english instructions are a little confusing.

if i'm reading it right

load the files and folder from the rar onto the SD card.

insert card into unit

turn unit on. (magic happens)

turn unit off and turn back on.

re-calibrate
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 01:29 AM   #182
Parvaz
Registered User
 
Join Date: Feb 2014
Location: Vancouver- Canada
Posts: 17
My Ride: 2004 bmw 330 ci
Help! Was wondering with either GM5150 or D5150 do I still need that extended wiring harness..!??? Please. I have 04 330ci...!!!
Parvaz is offline   Reply With Quote
Old 03-05-2014, 02:07 AM   #183
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by Parvaz View Post
Help! Was wondering with either GM5150 or D5150 do I still need that extended wiring harness..!??? Please. I have 04 330ci...!!!
I have a 02 325xi and had a stock business cd player. No extentions needed. If I read right you only need one if you have a stock navi installed

Sent from BimmerApp mobile app
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 04:21 PM   #184
VKnid
Registered User
 
Join Date: Sep 2013
Location: SC
Posts: 75
My Ride: 2002 330i
I'm Back

Well. After being delayed by Chinese New Year and two snow storms, I finally got a replacement GM5150. Installed it Monday night, and everything seems to be working fine. I don't think I have the latest firmware or software (general is still misspelled), but I'm not touching anything until I have a problem. The cool thing was they sent me a completely new unit with all of the wires, canbus, remote, etc., so now I have extras. Definitely pleased with the customer service.

This whole thing started with trying to "fix" the auto connect and play of Bluetooth music streaming on start up. I know Wacuna found an Android app that fixes the issue on the phone side instead of the unit. Anyone found anything similar for an iPhone?
VKnid is offline   Reply With Quote
Old 03-05-2014, 04:27 PM   #185
semcoinc
Registered User
 
Join Date: Feb 2014
Location: Dallas, Texas
Posts: 126
My Ride: 330Xi/335Xi/E53-X5
Quote:
Originally Posted by Parvaz View Post
Help! Was wondering with either GM5150 or D5150 do I still need that extended wiring harness..!??? Please. I have 04 330ci...!!!
You only need the long FAKRA extension harness if you have a Factory NAV. The connector for speakers and power and canbus on factory NAV units is in the driver side (left in the USA) rear just behind the shock tower down in the side between the outer quarterpanel and the trunk floor.

The FAKRA extensions are on Eonon's web site I believe. I got mine about a week or so ago and could only find it on eBay. There is a decision to make based on the year of your vehicle which extension to get. There is a so-called 17 pin and a so-called 40 pin harness. The 17 pin I believe has round pin connectors and the 40 pin (like for my 2003 330Xi) has flat male pins on the extension harness.

Mike
__________________

Mike C.
DFW/ATW
E46/330Xi, E90/335Xi, E53/X5 4.4i

Last edited by semcoinc; 03-05-2014 at 04:30 PM.
semcoinc is offline   Reply With Quote
Old 03-05-2014, 05:20 PM   #186
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 436
My Ride: 05 330CI ZHP
Quote:
Originally Posted by VKnid View Post
Well. After being delayed by Chinese New Year and two snow storms, I finally got a replacement GM5150. Installed it Monday night, and everything seems to be working fine. I don't think I have the latest firmware or software (general is still misspelled), but I'm not touching anything until I have a problem. The cool thing was they sent me a completely new unit with all of the wires, canbus, remote, etc., so now I have extras. Definitely pleased with the customer service.

This whole thing started with trying to "fix" the auto connect and play of Bluetooth music streaming on start up. I know Wacuna found an Android app that fixes the issue on the phone side instead of the unit. Anyone found anything similar for an iPhone?
Sweet, good to hear Eonon took care of ya!

Quote:
Originally Posted by northwestsupra View Post
well the links seem to be broken to the rar files.
http://www.sbo2.com/cs_serial//BMW_A...146-140219.rar
Quote:
Originally Posted by Nunzio View Post
FYI, I just went back to the previous version (BMW_APP_TW_4049-405F-0709-L146-131209) as it seemed more stable than the (BMW_APP_TW_4049-405F-0709-L146-140219) firmware.

I'm still getting the Launch.exe warning. It only seems to happen when I have the NAV and iPod (using iPhone 5s) running while switching back and forth with the NAV button.

http://www.sbo2.com/cs_serial//BMW_A...146-131209.rar (what I'm using currently)

http://www.sbo2.com/cs_serial//BMW_A...146-140219.rar (crashes still with Launch.exe warning)
Try these, you have the second one listed above which appears to cause some issues. Try the first one listed.

I will contact Carlos and see if we can get detailed Instructions on how to properly update the firmware and post it on the first page.
WOLFN8TR is online now   Reply With Quote
Old 03-05-2014, 07:13 PM   #187
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by WOLFN8TR View Post
Sweet, good to hear Eonon took care of ya!





Try these, you have the second one listed above which appears to cause some issues. Try the first one listed.

I will contact Carlos and see if we can get detailed Instructions on how to properly update the firmware and post it on the first page.
he sent me this in a message

Quote:
Originally Posted by EononCarDVD
Dear northwestsupra
Good day
I am Carlos and i am writing to you for the issues you mentioned about Eonon GM5150.
I suggest you update the head unit with the following software.
http://www.sbo2.com/cs_serial//BMW_A...146-140219.rar
Instructions:
1.Copied the folder of files to the SD card.
2. Turned key to position one and turned on head unit
3. Inserted SD card and left the Eonon head unit on.
Turned key off, waited 10 seconds, turned key back to position one and head unit powered back on and read the SD card.
4.It went through about four steps, then restarted and please calibrate the touch screen per the instructions.
5. Remove the SD card and hit reset. If you forget to take out the SD card, it reloads again

Sorry for the inconvenience and please kindly let us know the testing result then. Thank you
Hope to hear from you soon
Regards
Carlos
eonon.com
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 07:19 PM   #188
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
i tell you what, i'll make a tutorial and post it here
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 07:47 PM   #189
semcoinc
Registered User
 
Join Date: Feb 2014
Location: Dallas, Texas
Posts: 126
My Ride: 330Xi/335Xi/E53-X5
That is great Northwest!

We need a step by step tutorial on Post-Install set up to address all these bugs.

1. Launch.exe firmware fix with step by step details on loading the firmware

2. Lighting settings. Resolving the lights flickering issues that have been reported.

3. Clock settings fix (set what things to what, initialize what and in what order to get the clock to keep proper time)

4. Handbrake setting :bang head: In settings page 6 of Eonon manual, the Manual simply says "Handbrake: With on/off Brake detect"

I can appreciate that English is not their native tongue, I get that. But someone with English as a 1st language needs to help them EXPLAIN what these settings DO! What will handbrake ON do? What will handbrake OFF do? Explain the consequences of each of these settings. Another example is page 7 Steering Wheel control function settings. They start talking about wheel control cables Key 1, Key 2. Finding the ground cable of the car and connect it to the host. What???? What is the "host"?

So you see what I mean....:bang head: :bang head: Rant mode off.....

I'm about to embark on this GM5150 install on Friday and would simply like to do all the proper set up and tricks right after my install, instead of battling with them after the install on a trip while driving.

Whatever you can put together Northwest, I'm sure would be appreciated by all who follow.

Thanks,

Mike
__________________

Mike C.
DFW/ATW
E46/330Xi, E90/335Xi, E53/X5 4.4i
semcoinc is offline   Reply With Quote
Old 03-05-2014, 08:07 PM   #190
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by semcoinc View Post
That is great Northwest!

We need a step by step tutorial on Post-Install set up to address all these bugs.

1. Launch.exe firmware fix with step by step details on loading the firmware

2. Lighting settings. Resolving the lights flickering issues that have been reported.

3. Clock settings fix (set what things to what, initialize what and in what order to get the clock to keep proper time)

4. Handbrake setting :bang head: In settings page 6 of Eonon manual, the Manual simply says "Handbrake: With on/off Brake detect"

I can appreciate that English is not their native tongue, I get that. But someone with English as a 1st language needs to help them EXPLAIN what these settings DO! What will handbrake ON do? What will handbrake OFF do? Explain the consequences of each of these settings. Another example is page 7 Steering Wheel control function settings. They start talking about wheel control cables Key 1, Key 2. Finding the ground cable of the car and connect it to the host. What???? What is the "host"?

So you see what I mean....:bang head: :bang head: Rant mode off.....

I'm about to embark on this GM5150 install on Friday and would simply like to do all the proper set up and tricks right after my install, instead of battling with them after the install on a trip while driving.

Whatever you can put together Northwest, I'm sure would be appreciated by all who follow.

Thanks,

Mike
well i can tell you the hand brake is for automatic detection of the hand brake, so like i turned mine off since i didnt have it hooked up to the hand brake, if it was the option was on it wouldnt let me use any video features screen mirror/camera/DLNA, its just a safety feature that they made easier to bypass
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 08:30 PM   #191
semcoinc
Registered User
 
Join Date: Feb 2014
Location: Dallas, Texas
Posts: 126
My Ride: 330Xi/335Xi/E53-X5
Thanks Northwest.

That's the kind of thing that needs to be given expanded detail in the manual.

Mike
__________________

Mike C.
DFW/ATW
E46/330Xi, E90/335Xi, E53/X5 4.4i
semcoinc is offline   Reply With Quote
Old 03-05-2014, 08:50 PM   #192
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by semcoinc View Post
Thanks Northwest.

That's the kind of thing that needs to be given expanded detail in the manual.

Mike
No problem okay well i just did the update, recorded the entire thing. will be a 3 part video, copying it from my phone to computer, then i'll upload it to youtube. Honestly was super easy, I also did a thing on setting the time, and going to do a video on setting the GPS path
northwestsupra is offline   Reply With Quote
Old 03-05-2014, 09:52 PM   #193
semcoinc
Registered User
 
Join Date: Feb 2014
Location: Dallas, Texas
Posts: 126
My Ride: 330Xi/335Xi/E53-X5
Thanks Northwest!

That will be my go to video right after my install.

Mike
__________________

Mike C.
DFW/ATW
E46/330Xi, E90/335Xi, E53/X5 4.4i
semcoinc is offline   Reply With Quote
Old 03-05-2014, 10:08 PM   #194
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Glad I could help the community I am trying my best. Videos are still uploading

Sent from BimmerApp mobile app
northwestsupra is offline   Reply With Quote
Old 03-06-2014, 06:21 AM   #195
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Firmware updates
There are two different types to choose from one might work better for you
BMW_APP_TW_4049-405F-0709-L146-131209 (another one recommended by WOLFN8TR)
and
BMW_APP_TW_4049-405F-0709-L146-140219 ( this was used in video)

So the proces was easy
1.Copy the NWD_703 folder in the firmware update to your GPS SD card (make a backup of your current GPS software and maps) So now the only thing on you SD card should be the NWD_703 folder.

2.turn unit on without sd card till it fully boots (dont worry if you are getting a launch.exe error right after starting your unit, this doesnt seem to effect it)

3. turn the unit off but turning your key to the off position for 10 seconds

4.place your sd card into the gps card slot and turn the key to the acc position. You should see a Eonon logo and the unit should start auto updating itself.

5. once completed the unit will have you re-calibrate

6. after calibration go to settings and select the option just under GPS and select your language (settings wont look set until you hit the home button)

7. after confirming you have the correct language set, then turn your key to the off position again and take out the sd card (if you forget it will just do the process all over again)

8.turn key back to the acc position and let the unit start fully.

9. once the unit has started, find a sharp object and hit the restart button above the GPS card slot to further confirm no issues.

10. load all your GPS software back onto the sd card and remove the NWD_703 folder YOUR DONE!!! congrats

Video of the process






How to set your Clock


How to set your GPS software path


hopefully this helps some people out with their issues, I personally was having Launch.exe issues and the clock issue which for the 10 minutes I've gotten to test seems to be fixed, i can confirm however the clock has held its time after 30 minutes of being turned off.
northwestsupra is offline   Reply With Quote
Old 03-06-2014, 07:19 AM   #196
semcoinc
Registered User
 
Join Date: Feb 2014
Location: Dallas, Texas
Posts: 126
My Ride: 330Xi/335Xi/E53-X5
Thanks Northwest!

That helps immensely to show how to deal with most of the known problems.]]

Mike

PS: Your links in the post are inop, but the ones in the email I received about your new post to my subscribed thread came through fine.
__________________

Mike C.
DFW/ATW
E46/330Xi, E90/335Xi, E53/X5 4.4i
semcoinc is offline   Reply With Quote
Old 03-06-2014, 07:28 AM   #197
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Originally Posted by semcoinc View Post
Thanks Northwest!

That helps immensely to show how to deal with most of the known problems.]]

Mike

PS: Your links in the post are inop, but the ones in the email I received about your new post to my subscribed thread came through fine.
Glad I could help out. If anyone needs assistance or has questions I'll do my best to answer. Now if Carlos would release a open source version I could see this thing become even more amazing. I'm sure we have someone on the forums who know how to code

Sent from BimmerApp mobile app
northwestsupra is offline   Reply With Quote
Old 03-06-2014, 04:58 PM   #198
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 436
My Ride: 05 330CI ZHP
Quote:
Originally Posted by northwestsupra View Post
Firmware updates
There are two different types to choose from one might work better for you
BMW_APP_TW_4049-405F-0709-L146-131209 (another one recommended by WOLFN8TR)
and
BMW_APP_TW_4049-405F-0709-L146-140219 ( this was used in video)

So the proces was easy
1.Copy the NWD_703 folder in the firmware update to your GPS SD card (make a backup of your current GPS software and maps) So now the only thing on you SD card should be the NWD_703 folder.
2. Turn unit on without sd card till it fully boots (dont worry if you are getting a launch.exe error right after starting your unit, this doesnt seem to effect it)
3. Turn the unit off but turning your key to the off position for 10 seconds
4. Place your sd card into the gps card slot and turn the key to the acc position. You should see a Eonon logo and the unit should start auto updating itself.
5. Once completed the unit will have you re-calibrate
6. After calibration go to settings and select the option just under GPS and select your language (settings wont look set until you hit the home button)
7. After confirming you have the correct language set, then turn your key to the off position again and take out the sd card (if you forget it will just do the process all over again)
8. Turn key back to the acc position and let the unit start fully.
9. Once the unit has started, find a sharp object and hit the restart button above the GPS card slot to further confirm no issues.
10. Load all your GPS software back onto the sd card and remove the NWD_703 folder YOUR DONE!!! congrats

Hopefully this helps some people out with their issues, I personally was having Launch.exe issues and the clock issue which for the 10 minutes I've gotten to test seems to be fixed, i can confirm however the clock has held its time after 30 minutes of being turned off.
Good Job.

Here is what Carlos sent me in regards to the Launch.exe issue.

Hi WOLFN8TR
Thank you for contact.
I am sorry for the error issue.
We have the software for fix it. Here it is!

http://www.sbo2.com/cs_serial//BMW_A...146-140219.rar
Instructions:
1. Copy the folder of files to the SD card.
2. Turned key to position one and turned on head unit
3. Inserted SD card and left the Eonon head unit on.
Turned key off, waited 10 seconds, turned key back to position one and head unit powered back on and read the SD card.
4. It goes through about four steps, then restarts, please calibrate the touch screen per the instructions.
5. Remove the SD card and hit reset. If you forget to take out the SD card, it reloads again.

(Once we determine which firmware works consistently I will post the info on the first page.)

Last edited by WOLFN8TR; 03-06-2014 at 05:28 PM.
WOLFN8TR is online now   Reply With Quote
Old 03-06-2014, 05:39 PM   #199
WOLFN8TR
OEM ///Member
 
WOLFN8TR's Avatar
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 436
My Ride: 05 330CI ZHP









Last edited by WOLFN8TR; 03-07-2014 at 06:33 PM.
WOLFN8TR is online now   Reply With Quote
Old 03-06-2014, 06:04 PM   #200
northwestsupra
Registered User
 
Join Date: Mar 2014
Location: Arlington Wa
Posts: 56
My Ride: 2002 325XI sedan
Quote:
Where's the fix

Sent from BimmerApp mobile app
northwestsupra is offline   Reply With Quote
Reply

Tags
bluetooth, dvd, e46, navigation, touch screen

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use