E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-10-2014, 12:12 AM   #1
airycsillest916
Registered User
 
Join Date: Apr 2014
Location: Nor Cal
Posts: 3
My Ride: 330CI
CEL Check Engine Light Problem

Okay so i had a CEL come up a week or so ago. I got it cleared so i could smog and have driven 350 miles since the code was cleared but when i take it to the smog shop the computer still shows that the code was recently cleared. In my experience in all of my other cars driving for 50-100 miles clears the ECU that a code was cleared recently. Any info would be great because my cars tags are way out of date and i need a smog.
airycsillest916 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-10-2014, 12:26 AM   #2
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 4,538
My Ride: 328i, XC70
Clearing the codes won't get the car ready for smog, fixing the problem that caused the light does.
What were the codes?

Even though the light isn't back, there are some emission related problems, that's why it shows not ready.
__________________
lszlszx is offline   Reply With Quote
Old 04-10-2014, 02:28 AM   #3
airycsillest916
Registered User
 
Join Date: Apr 2014
Location: Nor Cal
Posts: 3
My Ride: 330CI
it was a code for the torque converter. when i take it in to smog the code doesnt come up it just shows that codes were recently cleared.
airycsillest916 is offline   Reply With Quote
Old 04-10-2014, 09:33 AM   #4
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 4,538
My Ride: 328i, XC70
See if your scanner reads the readiness monitors. Then you'll know what system isn't ready yet and what to focus on.
__________________
lszlszx is offline   Reply With Quote
Old 04-10-2014, 10:52 AM   #5
jcns
Registered User
 
Join Date: Oct 2008
Location: California
Posts: 1,524
My Ride: California
350 miles in a week leads me to believe it's mostly fwy.
you also have to do a mixture of driving; city, fwy, stop and go, different speeds.
I am not sure how much, but other threads here have discussed it.
jcns is offline   Reply With Quote
Old 04-10-2014, 07:08 PM   #6
airycsillest916
Registered User
 
Join Date: Apr 2014
Location: Nor Cal
Posts: 3
My Ride: 330CI
It was all city driving but it just passed smog today.
airycsillest916 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use