E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 57 votes, 5.00 average. Display Modes
Old 06-20-2005, 08:45 PM   #61
SSYHARATH
Registered User
 
Join Date: Jun 2004
Location: Orange County, CA
Posts: 3
My Ride: 00 323CI
It reset my oil service but now car won't start. According to the gauge, the car is in S. Please help
SSYHARATH is offline   Reply With Quote
Old 06-21-2005, 01:23 PM   #62
dillard
Registered User
 
Join Date: Aug 2002
Location: Houston Texas
Posts: 768
My Ride: 2004 M3 Cabrio
Quote:
Originally Posted by SSYHARATH
It reset my oil service but now car won't start. According to the gauge, the car is in S. Please help
Very strange. Try disconnecting the battery.
__________________
Proud owner of '04 M3 Convertible:
dillard is offline   Reply With Quote
Old 06-21-2005, 10:23 PM   #63
Cobra
Registered User
 
Join Date: Jan 2005
Location: New York\City
Posts: 3,156
My Ride: '00 328i & '06 R6S
thanks, this is really helpful
__________________
Cobra is offline   Reply With Quote
Old 06-22-2005, 12:54 AM   #64
SSYHARATH
Registered User
 
Join Date: Jun 2004
Location: Orange County, CA
Posts: 3
My Ride: 00 323CI
Quote:
Originally Posted by dillard
Very strange. Try disconnecting the battery.

I disconnected the battery and waited till the next morning and it still won't start. Radio, power window, lights, AC all works. The car is in Park but the gauge reads S, even when I put in R or N. I got it towed to a local BMW repair shop this afternoon.
SSYHARATH is offline   Reply With Quote
Old 07-19-2005, 06:30 PM   #65
Cobra
Registered User
 
Join Date: Jan 2005
Location: New York\City
Posts: 3,156
My Ride: '00 328i & '06 R6S
Quote:
Originally Posted by darkmanlfe
yes that is correct. pin 19 is ground.
so you can either short pin 7 and pin 19 with a paper clip or ground pin 7.
what do you mean by ground pin 7 only? what does grounding mean?
__________________
Cobra is offline   Reply With Quote
Old 07-27-2005, 01:46 AM   #66
monchhichi
Registered User
 
monchhichi's Avatar
 
Join Date: Jul 2005
Location: San Francisco
Posts: 14
My Ride: 2003 330i
Send a message via ICQ to monchhichi Send a message via MSN to monchhichi
Smile How to reset Servise engine light on 2003 330i

I have a 2003 330i..I can't locate the data link connector inside the hook....and I want to know how to reset the servise engine soon light. Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!
monchhichi is offline   Reply With Quote
Old 07-27-2005, 02:02 AM   #67
Cobra
Registered User
 
Join Date: Jan 2005
Location: New York\City
Posts: 3,156
My Ride: '00 328i & '06 R6S
Quote:
Originally Posted by monchhichi
I have a 2003 330i..I can't locate the data link connector inside the hook....and I want to know how to reset the servise engine soon light. Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!
dude, the data link connector is only for 99-00 models. for your '03, theres a completely different method to reset the light;

B. After Mid-2000: You should not have the 20-pin DLC connector. You only need to hold the left odometer reset button while turning the key to position 1 (Accessory). Keep holding the button for 5 or so seconds until any of the following shows in the display: OIL SERVICE or INSPECTION with RESET or RE. Release the button and press it again for another 5 or so seconds until RESET or RE flash. While the display flashes, press the button one more time briefly. If done correctly, END SIA should show up for a few seconds. All done.
__________________
Cobra is offline   Reply With Quote
Old 07-27-2005, 11:14 AM   #68
monchhichi
Registered User
 
monchhichi's Avatar
 
Join Date: Jul 2005
Location: San Francisco
Posts: 14
My Ride: 2003 330i
Send a message via ICQ to monchhichi Send a message via MSN to monchhichi
Thumbs Up

Quote:
Originally Posted by Cobra
dude, the data link connector is only for 99-00 models. for your '03, theres a completely different method to reset the light;

B. After Mid-2000: You should not have the 20-pin DLC connector. You only need to hold the left odometer reset button while turning the key to position 1 (Accessory). Keep holding the button for 5 or so seconds until any of the following shows in the display: OIL SERVICE or INSPECTION with RESET or RE. Release the button and press it again for another 5 or so seconds until RESET or RE flash. While the display flashes, press the button one more time briefly. If done correctly, END SIA should show up for a few seconds. All done.
COOL... It does reset my oil service but the service engine soon light still on..
Thank you very much!!!
monchhichi is offline   Reply With Quote
Old 07-27-2005, 11:38 AM   #69
Cobra
Registered User
 
Join Date: Jan 2005
Location: New York\City
Posts: 3,156
My Ride: '00 328i & '06 R6S
Quote:
Originally Posted by monchhichi
COOL... It does reset my oil service but the service engine soon light still on..
Thank you very much!!!
whoops, i missed that. i'm not sure if you can even reset the service engine soon light yourself, you need to have that checked out, somethings probably wrong. take it to autozone and have them scan the error code.
__________________
Cobra is offline   Reply With Quote
Old 07-27-2005, 05:07 PM   #70
kevmo
Registered User
 
kevmo's Avatar
 
Join Date: Jun 2003
Location: MD (Ft. Meade)/MA
Posts: 13,478
My Ride: vDubDizzle
Send a message via AIM to kevmo
i just ddi it... worked on first try!!


now does anyone kno how to get rid of the airbag light?
__________________


kevmo is offline   Reply With Quote
Old 08-02-2005, 06:28 PM   #71
djpennin
Registered User
 
Join Date: May 2005
Location: texas
Posts: 10
My Ride: 00 323Ci SP/HK
Pin7 to GROUND works (19 didnt work for me)

I kept trying over and over again 7 to 19 with no luck. Finally I went from 7 to GROUND (on of the strut tower screws/bolts thats about 4 inches away)

and voila! it reset
djpennin is offline   Reply With Quote
Old 08-03-2005, 11:52 AM   #72
Lone
Registered User
 
Join Date: Jan 2004
Location: boston
Posts: 68
My Ride: 2000 328i
do you have to wear rubber gloves or anything? just paraniod that im might get electrocuted
Lone is offline   Reply With Quote
Old 08-03-2005, 12:25 PM   #73
kevmo
Registered User
 
kevmo's Avatar
 
Join Date: Jun 2003
Location: MD (Ft. Meade)/MA
Posts: 13,478
My Ride: vDubDizzle
Send a message via AIM to kevmo
no gloves required... use 2 paper clips.. one to connect 7 and 19.. and the other to touch the bolt right next to it to ground it... ur done
__________________


kevmo is offline   Reply With Quote
Old 08-12-2005, 04:54 PM   #74
cancell
Registered User
 
Join Date: Oct 2003
Location: arlington, texas
Posts: 585
My Ride: 2000 323i
Send a message via AIM to cancell Send a message via MSN to cancell
my 2000 323i doesn't have the datalink connector... and that "empty box" has something that looks like an abs/dsc controller or w/e..

I don't have a current pic of that "empty area" but there should be pix of it on the photoalbum i made when i first got the car HERE

DISREGARD MY POST, i just read COBRA's post..
__________________


The lesser we know...the more they fabricate...the easier it is to sell souls
There is a new price on freedom, so buy into it while supplies last.
We've unified over who to kill, so until I find more relevant scripture to quote...
remember, our god is bigger, stronger, smarter, and much wealthier.
So wave those flags with pride... It's the makeshift patriot.
cancell is offline   Reply With Quote
Old 09-22-2005, 11:21 PM   #75
tblue3cibm
Registered User
 
Join Date: Dec 2004
Location: Brooklyn, N.Y.C.
Posts: 6,380
My Ride: allroad / Hayabusa
I just happened upon this post and would like to it for a fanatic that might need it.
__________________
tblue3cibm is offline   Reply With Quote
Old 09-24-2005, 06:56 PM   #76
RockerGuy
Registered User
 
Join Date: Aug 2005
Location: Timbuktu
Posts: 402
My Ride: Not a BMW
Oh Gosh I finally got it to work. I spent like 2 hrs going between this computer and the car. I must have shhort every single pin in that DLC, I figured that I was shorting pin 20 instead of 19. I was about to give up but I think I read Jak's reply and he said to connect 7, 19 + Ground and it works. Thank God! U are the man Jak, I dont know how u figure it out.

I am soo friggin proud of myself now.

There is however, one concern. How is it that it says 25,000km inspection and not 25,000km oil service??

But anyway big thanks to those who contribute, u guys are the best
RockerGuy is offline   Reply With Quote
Old 09-24-2005, 10:24 PM   #77
SD 328I
Registered User
 
Join Date: Jul 2004
Location: San Diego, CA
Posts: 2,847
My Ride: S197, E90, and 1125R
Quote:
Originally Posted by RockerGuy
Oh Gosh I finally got it to work. I spent like 2 hrs going between this computer and the car. I must have shhort every single pin in that DLC, I figured that I was shorting pin 20 instead of 19. I was about to give up but I think I read Jak's reply and he said to connect 7, 19 + Ground and it works. Thank God! U are the man Jak, I dont know how u figure it out.

I am soo friggin proud of myself now.

There is however, one concern. How is it that it says 25,000km inspection and not 25,000km oil service??

But anyway big thanks to those who contribute, u guys are the best
Because you go from oil and inspection intervals. If you want it to say oil service, you can short it again. It really doesn't matter though, just think of it as a service countdown no matter what it says.

BTW - How many miles do you actual go thru from "15,500 to 0" on the maintenance counter? I get a little over 8,000 miles by the time my counter reads zero from 15K.
__________________
SD 328I is offline   Reply With Quote
Old 10-05-2005, 10:26 PM   #78
markl951
Registered User
 
Join Date: Aug 2005
Location: Seattle, WA
Posts: 2
My Ride: 323Ci
Having trouble resetting the oil service indicator even though I've tried every variation of the instructions throughout this post. As you can see, this is my first post to this forum so be easy on me...

There must be more detail to the process such as;

turn the key to position 1 or 2, short pin 7 and 19 for 5 seconds, unshort 7 & 19, turn off key, ect. Does it matter if you short pins 7 & 19 first and then turn the key? I've tried all different combinations and it still won't reset.

I also noticed that I don't have as many pins on the DLC as that shown at the top of the post but I definately do have 7 & 19.

BTW, pin 19 has continuity to chassis ground so all this talk about shorting 7, 19, and chassis ground together with a paperclip makes no sense to me at all. Against my electrical engineering judgement, I tried it anyway. Still no luck.

The car is a 2000 323Ci convertible.
markl951 is offline   Reply With Quote
Old 10-06-2005, 10:55 PM   #79
miclo82
Registered User
 
Join Date: Oct 2005
Location: dallas, TX
Posts: 3
My Ride: 99 bmw 323i
airbag?

thanks man, but any luck with reseting the air bag light?
miclo82 is offline   Reply With Quote
Old 10-11-2005, 06:10 PM   #80
acouet
Registered User
 
Join Date: Oct 2005
Location: Ottawa
Posts: 21
My Ride: 2000 323I
Talking This is great!!

I'm new at the forum and was looking at a way to reset the stupid inspection light which was now at -4,200Km. I'm in Canada and the timer was in French. Didn't want to buy the tool or pay to get it reset after I did my own oil change, filter and spark plugs. After a few failed attempts...Bingo...25,000Km now showing.

COOL!!!
acouet is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use