E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-14-2004, 10:50 AM   #1
BlueBimmer
Registered User
 
Join Date: Feb 2003
Location: San Diego
Posts: 831
My Ride: A4 Avant 2.0T
Newb needs help with JL Stealth and Amp Install

Hi I want to install the JL Audio stealthboxes and an Alpine MRV-100M amp in my coupe without HK, I know very little to nothing about audio stuff. The amp is supposed to have speaker level inputs, so do I still need a line output converter? Also could someone please tell how I should go about hooking these things up?? Thanks!
__________________
BlueBimmer is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-14-2004, 11:12 AM   #2
sfh
Registered User
 
Join Date: Apr 2004
Location: norway
Posts: 8
My Ride: bmw
if theres high-level input on the amp, you simply connect the speaker-cables from HU into the amp..
i suppose there a plug that fits the amp...with wires on to the speaker-wires..
if there is, you dont need a converter.. if you got the manual of the amp, read it
sfh is offline   Reply With Quote
Old 04-14-2004, 11:37 AM   #3
BlueBimmer
Registered User
 
Join Date: Feb 2003
Location: San Diego
Posts: 831
My Ride: A4 Avant 2.0T
There's speaker input leads the amp is old and I don't have the plug that plugs into there, should I use this instead of the LOC? Also do they sell the plug for the speaker input anywhere, it just looks like it would be a square plug divided into four? Thanks for your input!
__________________
BlueBimmer is offline   Reply With Quote
Old 04-14-2004, 01:09 PM   #4
Clem
Alpha Male
 
Clem's Avatar
 
Join Date: Dec 1969
Location: Edmonton, AB Canada
Posts: 310
My Ride: Twin Turbo'd Beast


this has been covered IN DETAIL in many threads.
Clem is offline   Reply With Quote
Old 04-14-2004, 01:39 PM   #5
BlueBimmer
Registered User
 
Join Date: Feb 2003
Location: San Diego
Posts: 831
My Ride: A4 Avant 2.0T
Quote:
Originally Posted by Clem


this has been covered IN DETAIL in many threads.
Can you please point me to one or which words to search for??
__________________
BlueBimmer is offline   Reply With Quote
Old 04-14-2004, 02:00 PM   #6
sdbimmer
Registered User
 
Join Date: Aug 2003
Location: San Diego
Posts: 561
My Ride: 2004 325Ci
that Alpine MRV-100m has an input level up to 11 volts. It might work without an LOC. Although it doesn't say anything about balance input level. Try it without an LOC, but if you start getting a lot of noise, then get an LOC to correct the noise problem.
sdbimmer is offline   Reply With Quote
Old 04-14-2004, 02:01 PM   #7
sdbimmer
Registered User
 
Join Date: Aug 2003
Location: San Diego
Posts: 561
My Ride: 2004 325Ci
oh, and where did you get your JL Stealth from and how much?
sdbimmer is offline   Reply With Quote
Old 04-14-2004, 02:17 PM   #8
BlueBimmer
Registered User
 
Join Date: Feb 2003
Location: San Diego
Posts: 831
My Ride: A4 Avant 2.0T
Got it for $250 shipped in the for sale section. Sent you a PM, thanks for the help!
__________________
BlueBimmer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use