E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-25-2004, 07:40 AM   #21
ca1242
Registered User
 
Join Date: Aug 2003
Location: Burke, VA
Posts: 7,633
My Ride: 2003 330i
Quote:
Originally Posted by bigjae1976
Rockford might be good since you can get them dirt cheap off of ebay.

Don't expect much of the newer versions of the punch amps...they actually kind of suck. My Power 551s shuts down after about 30 minutes of hard pounding. Its running my fronts and 1 4 ohm sub in mixed mono. The older ones would have never shut down, the newer ones suck...what can you expect when they sell this stuff at Best Buy. I will hopefully upgrade to a US Amps in the future because I am very disaapointed with my RF amp.
If you go by the ratings, you are over-stressing the amp. a 4-ohm woofer AND the speakers on each channel have a total load of less than 4 ohms (minimum for that amp is, I believe four ohms). But you are right, an older amp would have not shut down, I have head of people running 2-ohms bridged, when the amps were rated at 4. Maybe add a fan?
__________________
ca1242 is offline   Reply With Quote
Old 04-25-2004, 02:58 PM   #22
learthworml
mod-er-at-or-er
 
Join Date: Jul 2002
Location: Dallas, TX
Posts: 1,188
My Ride: 2011 Tundra Crewmax
Quote:
Originally Posted by RadBMW
I would deff like to see those pics. Post them up! I've opened a few amps before, but i didn't think that audiobahn had a amp board that was that ****ty.
Here ya go. Look at the pos. I bet it cost them a dollar to make the board and like 10 to make the outside look all bling and have cool blue lights.

This is suppose to be a 420 watt amp at 4 ohms. lol I think it measured at like 300 or so.
Attached Thumbnails
Click image for larger version

Name:	a1.JPG
Views:	62
Size:	96.2 KB
ID:	75314  
__________________
mods
Kore Fox coilovers w/ 2.5" front lift , Fox Rear piggy backs w/ 1" rear lift, 305/65 18 BFG at/ko, TRD front Skid plate, console vault

SQ sound system
Seas Nextel Mids, Focal Utopia Mids, Focal BE tweeters, JL Audio 13tw5, Alpine PDX-4.150, Alpine PDX-1.600, Audison Bit One processor, Pioneer z150 hu
learthworml is offline   Reply With Quote
Old 04-25-2004, 03:21 PM   #23
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,467
My Ride: A car
Send a message via MSN to bigjae1976
Quote:
Originally Posted by ca1242
If you go by the ratings, you are over-stressing the amp. a 4-ohm woofer AND the speakers on each channel have a total load of less than 4 ohms (minimum for that amp is, I believe four ohms). But you are right, an older amp would have not shut down, I have head of people running 2-ohms bridged, when the amps were rated at 4. Maybe add a fan?
If you run the amp in mixed mono, its not overloading it. I hooked up the fronts up to the left and right. And then hooked the sub up to the right + and left -. It states that the amp can do this on the website and in the owner's manual.

Yes, I had my old punch 200's bridged running a 2 ohm load plus my fronts and rears in mixed mono and never shut down....it did get hot in the summer.
bigjae1976 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use