E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-26-2002, 10:43 AM   #1
JAG
Registered User
 
Join Date: Dec 1969
Location: Chicago, IL
Posts: 64
My Ride: 2000 323i
Arrow Service Engine light?

Hello all,

I have '00 E46 323i. The "Service Engine Soon" light stayed on today on my way to work. I am at least 10K miles to Service 1/an Oil Change.

What needs to be done?

Thanks very much in advance for any help sent my way!
JAG is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-26-2002, 11:03 AM   #2
///ACS330Ci
Artist formerly k/a Steve
 
Join Date: Dec 1969
Location: Arizona
Posts: 2,861
My Ride: ACS/M-Technik 330Ci
Send a message via ICQ to ///ACS330Ci Send a message via AIM to ///ACS330Ci
That symptom can be caused by a lose gas cap. Try tightening and driving for awhile.

I had the engine check light come on not long after I got my car and had to have the dealer reset it. It had an O2 sensor fault, but it has never repeated.
__________________
  • Checkout Project HyperWorksMCS HERE
  • View My Other Automotive Project HERE
///ACS330Ci is offline   Reply With Quote
Old 04-26-2002, 02:47 PM   #3
Conrad
Modelrater
 
Join Date: Dec 1969
Location: Hoffman Estates, Il
Posts: 744
My Ride: 2000 323ci
Send a message via AIM to Conrad
Yep could be the gas cap, it happened to me before. Also, mine kept going on and off. I decided to check the coolant and sure enough it was fairly low. Just head over to Patricks and they'll top it off for ya.

Hey, come on over, I got Behind Enemy Lines. Plus I got new subs for the home theater since last time since the last time you were over. Dude, you gotta hear U-571. WOW!
__________________
Conrad is offline   Reply With Quote
Old 04-26-2002, 03:36 PM   #4
mmtr 328i
Registered User
 
Join Date: Dec 1969
Location: KS
Posts: 181
My Ride: 328I,07Expy
I had mine come on one cold morning. It was on every time I started the car. The next day I was going to stop by the dealer ship and that morning it went off. Has not been on since ????
__________________
<img src=http://www.bhrscpas.com/troy/cars.jpg border=0 alt= />
mmtr 328i is offline   Reply With Quote
Old 04-26-2002, 03:51 PM   #5
JAG
Registered User
 
Join Date: Dec 1969
Location: Chicago, IL
Posts: 64
My Ride: 2000 323i
Arrow Thanks!

Thanks for the help guys!

Conrad: I'm planning to bring the car in to Barrington Motorwerks next week just to have it checked out. I'm sure it's something minor.

Sure man, I'll drive over to check out your updated home theatre system! I get jealous though, every time I see it, cause it's just so good!

JAG is offline   Reply With Quote
Old 04-26-2002, 03:57 PM   #6
Conrad
Modelrater
 
Join Date: Dec 1969
Location: Hoffman Estates, Il
Posts: 744
My Ride: 2000 323ci
Send a message via AIM to Conrad
Re: Thanks!

Quote:
Originally posted by JAG
Thanks for the help guys!

Conrad: I'm planning to bring the car in to Barrington Motorwerks next week just to have it checked out. I'm sure it's something minor.

Sure man, I'll drive over to check out your updated home theatre system! I get jealous though, every time I see it, cause it's just so good!


hehehe...dude, I keep going to the home theater forums and I get super jealous there. Mine is nothing compare to the nuts there!
__________________
Conrad is offline   Reply With Quote
Old 04-27-2002, 07:20 PM   #7
rvnvet
Registered User
 
Join Date: Dec 1969
Location: Long Island, NY
Posts: 409
My Ride: 2000 323i Sport
I have a 00 323i sport that had the same problem with the engine light. It was caused by a bad thermostat, which is a common problem on 2000 3 series cars.... I also just received a recall letter from BMW today saying that the crankcase ventilation hose must be replaced on 1999 & 2000 cars with the M52TU engine. The problem is that the hose could fail prematurely which would cause the engine to run rough and the Check Enging lamp to illuminate..
:sad:
rvnvet is offline   Reply With Quote
Old 04-27-2002, 08:15 PM   #8
emi323i
E46 Pioneer
 
Join Date: Dec 1969
Location: nowhere
Posts: 388
My Ride: none
mine came on a while ago... it was a d-vanos failure...

dealer reset it and never came on again.
emi323i is offline   Reply With Quote
Old 04-29-2002, 05:05 PM   #9
JAG
Registered User
 
Join Date: Dec 1969
Location: Chicago, IL
Posts: 64
My Ride: 2000 323i
Talking

Got my car back from the dealer. Turns out, it was the gas cap. They did need to do a reset though to turn the light off.

Also, the dealer did the crankcase ventilation hose replacement that rvnvet was talking about. I am still under warranty, so they did it for free.

Cool!

Thanks again for all the help, guys!
JAG is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use