E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 6 votes, 5.00 average. Display Modes
Old 11-29-2005, 03:14 PM   #1
quazyboi
Registered User
 
Join Date: Sep 2005
Location: Sacramento, CA
Posts: 27
My Ride: 00 328Ci steel grey
RPM idle is dancing???

Hi fellow e46 fanatics, I recently purchased a 00 328Ci, and everything is great. Found this website to be the best so far for learning new things about my car and i love the DIY section. Well my problem just started as winter is coming in. Now that the morning temp. is in the 40's, i some times have trouble with my idle staying constant. Seems like when its cold the idle jumps from 800 down to aournd 300 or 400 hundred then pops back up. Its like the car is SHIVERING...lolz But the other day, i started it up and then went back inside to get my coat, then when i came back out, the engine was off. I'm guessin the idle dropped too low and it shut. I tried changing the Sparks, but that didn't work....n e help would really help guys. Don't really want to take it to BMW itself, cuz thats gonna probably put a nice hole in my pocket. =( By the way, the car is totally fine after it is warmed up...no problems
quazyboi is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-29-2005, 03:24 PM   #2
mikemartin9
Registered User
 
Join Date: Dec 2002
Location: Saugus, CA
Posts: 155
My Ride: 2000 328i
Idle issues on cold start

This can be intake cam the Vannos Solenoid, parts 2,3 &4 in the diagram, around 100 bucks at the dealer.
Attached Thumbnails
Click image for larger version

Name:	15.png
Views:	2098
Size:	20.1 KB
ID:	155511  
mikemartin9 is offline   Reply With Quote
Old 11-29-2005, 03:55 PM   #3
KrzyBum420
Registered User
 
Join Date: Apr 2004
Location: Diamond Bar, CA
Posts: 573
My Ride: E92 M3
Send a message via AIM to KrzyBum420
i got the exact same problem. also when im in reverse the rpms drop below 500 and the car just dies
KrzyBum420 is offline   Reply With Quote
Old 11-30-2005, 10:27 AM   #4
hal88
Registered User
 
Join Date: Apr 2005
Location: San Diego
Posts: 379
My Ride: e90 330i
Your problem is not isolated, many of us here have the same exact same problem, i have the same car u have and guess what? mine does the same thing when is cold out, I took mine to the local auto zone for a scan read and it came back with a intake crankshaft sensor code and a vanos stuck code, i have not changed either one of them for lack of time. I read some posts where guys just live with the problem, they just warm up the car and that's it......do a search on cold idle issues and you'll find a few posts. Keep us posted please.
__________________
00 328ci, X5 4.4
hal88 is offline   Reply With Quote
Old 11-30-2005, 10:50 AM   #5
driftinsequence
Registered User
 
Join Date: Mar 2005
Location: LC
Posts: 3,680
My Ride: waiting to be modded
Send a message via AIM to driftinsequence
intake/exhaust camshaft sensors?
driftinsequence is offline   Reply With Quote
Old 02-18-2006, 04:42 PM   #6
bimmer88
Registered User
 
Join Date: Apr 2003
Location: Sacramento, CA
Posts: 938
My Ride: 06 Lexus GS430
Send a message via AIM to bimmer88
yeah.. same problem here.. just been living with it for the past few months...
__________________
bimmer88 is offline   Reply With Quote
Old 02-18-2006, 05:06 PM   #7
sheefo2k
OEM ///Member
 
sheefo2k's Avatar
 
Join Date: May 2003
Location: Home - Minnesota
Posts: 9,233
My Ride: vrm psh - 02 325ci
Quote:
Originally Posted by bimmer88
yeah.. same problem here.. just been living with it for the past few months...
youi live with a lot of problem
__________________

Performance BMW car
Sponsored by :
www.euro-spec.net
www.bimmian.com
BMW Motorwerks

support:

www.vmwerks.com
www.esstuning.com
www.my330i.com
sheefo2k is offline   Reply With Quote
Old 02-18-2006, 05:30 PM   #8
bimmer88
Registered User
 
Join Date: Apr 2003
Location: Sacramento, CA
Posts: 938
My Ride: 06 Lexus GS430
Send a message via AIM to bimmer88
Quote:
Originally Posted by sheefo2k
youi live with a lot of problem
yup! looks like you're having your share also...hehehhe..
__________________
bimmer88 is offline   Reply With Quote
Old 02-18-2006, 07:06 PM   #9
sheefo2k
OEM ///Member
 
sheefo2k's Avatar
 
Join Date: May 2003
Location: Home - Minnesota
Posts: 9,233
My Ride: vrm psh - 02 325ci
loool shut up that hurts
__________________

Performance BMW car
Sponsored by :
www.euro-spec.net
www.bimmian.com
BMW Motorwerks

support:

www.vmwerks.com
www.esstuning.com
www.my330i.com
sheefo2k is offline   Reply With Quote
Old 02-18-2006, 10:21 PM   #10
328I99E46
Registered User
 
Join Date: Feb 2006
Location: NEW JERSEY
Posts: 73
My Ride: BMW
Hi i have the same problem with my car 328i 1999 e46 damn its pisssing me off so bad i did check icv,intake,plugs,voltage regulator itc ... been to dealer and nutting no code anything like that and it cant be vanos i had that done too it used to stall when it was cold out i reallyy dont know whats the deal !!!!! i am going to change one more think even if i dont see any code there it will be intake camshaft sensor and see from there if there is any change ..... If anyone find it out please let me know !!!!!! lol thanx
328I99E46 is offline   Reply With Quote
Old 02-19-2006, 12:05 AM   #11
hal88
Registered User
 
Join Date: Apr 2005
Location: San Diego
Posts: 379
My Ride: e90 330i
Quote:
Originally Posted by 328I99E46
Hi i have the same problem with my car 328i 1999 e46 damn its pisssing me off so bad i did check icv,intake,plugs,voltage regulator itc ... been to dealer and nutting no code anything like that and it cant be vanos i had that done too it used to stall when it was cold out i reallyy dont know whats the deal !!!!! i am going to change one more think even if i dont see any code there it will be intake camshaft sensor and see from there if there is any change ..... If anyone find it out please let me know !!!!!! lol thanx
I changed intake camshaft sensor and no help, I have a fault code which says it's my crankshaft sensor, but havent changed that yet. Take it to autozone for a code read.
__________________
00 328ci, X5 4.4
hal88 is offline   Reply With Quote
Old 02-19-2006, 12:45 AM   #12
RedBarron
Registered User
 
Join Date: Apr 2004
Location: Tallahassee, FL
Posts: 958
My Ride: Lexus LS
Send a message via AIM to RedBarron
My car has the idle drop no matter how hot or cold it is. The BMW tec said I sould replace my idle control valve and he said it seemed that my DISA was sucked in and pre 2002 have prob with it.
__________________
RedBarron is offline   Reply With Quote
Old 02-19-2006, 03:08 AM   #13
spyder
Registered User
 
Join Date: Oct 2003
Location: NYC
Posts: 1,163
My Ride: S54 Sedan, IB 328i
Send a message via AIM to spyder
Have the same problem, idle would go up and down when its really cold, after 3-4 minutes the car warms up and its fine. Sometimes it will stall out though.
spyder is offline   Reply With Quote
Old 02-19-2006, 08:24 AM   #14
328I99E46
Registered User
 
Join Date: Feb 2006
Location: NEW JERSEY
Posts: 73
My Ride: BMW
My idle go up and down within 900 to 500 when i change gear from N to D or P to R itc thats when it jumps all over and it wasnt like that before i have this car for almost 4 years now and dealer actually trying to tell me thats how they work bs... ok i know myself something is not right and i do check codes myself almost everyday and nothing ...
328I99E46 is offline   Reply With Quote
Old 02-23-2006, 09:25 PM   #15
BMW04E46
Registered User
 
Join Date: Jun 2004
Location: Palm Beach, Florida
Posts: 326
My Ride: 2004 325Ci SMG
I got a 04 325Ci and when stopped at a stop light, usually during the night, my idles fluctuates from around 800 rpm down to almost 400 rpm and back up and down, but no check engine light. If I take it to the dealer with no light on do you guys think they can find out what the problem is??

Steven
BMW04E46 is offline   Reply With Quote
Old 02-24-2006, 12:44 AM   #16
bigboy4074
Registered User
 
Join Date: Sep 2005
Location: SoCal - UCR
Posts: 53
My Ride: 323Ci
Send a message via AIM to bigboy4074 Send a message via MSN to bigboy4074
I had a similar problem with mine around new years. Jumpy idle then one night went out to drive back to school car would start then just die. Idle control valve was the part that died on mine.
bigboy4074 is offline   Reply With Quote
Old 02-24-2006, 12:52 AM   #17
UnBreakable
Registered User
 
Join Date: Dec 2005
Location: NY
Posts: 444
My Ride: OB E46 328i
Many of us have this problem and here they talk about it, read up: http://forum.e46fanatics.com/showthread.php?t=340572
UnBreakable is offline   Reply With Quote
Old 11-26-2007, 04:53 AM   #18
Martin Benca
Registered User
 
Join Date: Nov 2007
Location: Germany
Posts: 4
My Ride: BMW 325ci E46
Hmm, as this year's winter arrived I had the very same problem with my E46 325ci (M54B25 engine), though my engine at least didn't die (yet) and if I pressed gas a bit it usually returned back to normal. Nevertheless since it happens only rarely and engine service LED doesn't go on I think it doesn't even make sense to go to the repair with it since I'm pretty sure according to Murphy's law everything would work flawlessly there and break right after again.

For the time being I think I'll just live with it unless it gets worse but any advice would appreciated. Fortunatelly it really seems to happen only when engine is not fully warmed up.

It happens rarely for me (and seemingly only in cold weather plus it is "fixable" by pressing gas shortly) so it is not a big problem but I worry that ignoring it might affect also performance or longevity of the engine.

Last edited by Martin Benca; 11-26-2007 at 04:57 AM.
Martin Benca is offline   Reply With Quote
Old 11-26-2007, 08:18 AM   #19
mechanic_101
Registered User
 
Join Date: Aug 2007
Location: Bay City
Posts: 722
My Ride: 2005 325I
I don't have any idle problem with my BMW. But in the past I had worked on many vehicles, and 90% turned out to be the idle control valve. During idle, the control valve is the only source supplying air, if not enough air the RPM will drop. The reason it is difficult to diagnose cuz it does not set code...I'd gamble on this part.

Note: I don't know whether BMW idle control air set code, but big 3 vehicles do not set codes.
mechanic_101 is offline   Reply With Quote
Old 11-26-2007, 09:57 AM   #20
tripalthreat
Registered User
 
Join Date: Oct 2007
Location: Boston, MA
Posts: 126
My Ride: 2005 300xi
Do you ALWAYS run premium gas in your car? If so, drop a 50% tank of regular in once a month. It causes the computer to recalculate the octane - it gets "lazy" if you always use premium, so any imperfections in the gas mess up the idle.

My dad had this problem with his Cooper S and was told it's an issue with BMW computers. I've tried it and it works, as dumb as it sounds.
__________________
2005 330xi
6-speed | Sapphire Black Metallic | Beige Leather
M3 Lip Spoiler | BMW Aluminum Pedals | Valentine 1 | TomTom GO 720
Summer: 17" Type 137 | Winter: 17" Type 73 w/ WinterSport 3D
Coming soon: Full OEM clears

tripalthreat is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use