E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-05-2006, 07:51 PM   #1
tanev
Registered User
 
Join Date: May 2005
Location: Houston, TX
Posts: 61
My Ride: 2005 BMW 325i
Question Oil light comes on after oil change?

Hi,
I recently changed my oil using the posted DYI here as well as the info in my Bentley manual. I drained the old oil and added 6 qt of new BMW 5W-30 Synthetic oil. I also changed the oil filter, gaskets as described. I don't have any oil leak after the change. My oil level is close to the full line (should have added 5.5 qts) but not above it. The problem that I have now is that now and then AFTER I turn the ignition swith off and remove the key my oil warning light comes on for few seconds and then dissapears. No warning light comes when I trun the ignition on or while driving. Does anybody knows what causes this?
Thanks,
Peter
__________________
2005 BMW 325i, ZPP, ZSP, Retrofits: M3 SMG Steering wheel with paddleshift, OEM Bi-xenons +High beam+ Autoleveling, Predator Chromium, OEM (16:9/MKIV) Navigation, OEM TV/Video Module/Option, Assist/Bluetooth+ Voice Input Control, Universal Tranceiver, OEM Alarm, Alpine CHA-634 6CD/MP3 Changer, OEM Rear Side and Manually Retractable Rear Window Sunshades, Myrtle Wood emergency brake handle, OEM rear lip spoiler.
tanev is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-05-2006, 08:29 PM   #2
KevinB
Registered User
 
Join Date: Dec 2005
Location: Salisbury, NC
Posts: 18
My Ride: Silver 2002 330i
I have a 330i and the engine requires closer to 7 qts of oil. Does yours only take 6, or was that the mistake? Just my 2 cents
KevinB is offline   Reply With Quote
Old 01-05-2006, 09:03 PM   #3
rooneym
Registered User
 
Join Date: Dec 2004
Location: College Station, TX Gig'em Aggies!
Posts: 477
My Ride: 2001 E46 325I
Send a message via AIM to rooneym
Yellow oil light means the oil level is low. However, if you do have enough oil in the pan and the light still comes on, the oil level sensor is probably broken
rooneym is offline   Reply With Quote
Old 01-06-2006, 10:04 AM   #4
tanev
Registered User
 
Join Date: May 2005
Location: Houston, TX
Posts: 61
My Ride: 2005 BMW 325i
there is some residual oil left in the system when you darin it6. Therefore, it is not uncommon to add between 5.5- 7.0 qts during oil change. My oil level is close to the full mark.
The kick is that the light comes only sometimes after Iturn the ignition switch off and stays for few seconds and then goes off?
__________________
2005 BMW 325i, ZPP, ZSP, Retrofits: M3 SMG Steering wheel with paddleshift, OEM Bi-xenons +High beam+ Autoleveling, Predator Chromium, OEM (16:9/MKIV) Navigation, OEM TV/Video Module/Option, Assist/Bluetooth+ Voice Input Control, Universal Tranceiver, OEM Alarm, Alpine CHA-634 6CD/MP3 Changer, OEM Rear Side and Manually Retractable Rear Window Sunshades, Myrtle Wood emergency brake handle, OEM rear lip spoiler.
tanev is offline   Reply With Quote
Old 01-06-2006, 02:38 PM   #5
Dev
PSHOPWERKS
 
Join Date: Dec 1969
Location: E46Fanatics.com
Posts: 4,530
My Ride: Yellow Porsche GT2
Same issue here.
__________________
PSHOPWERKS
Mods: 1 Inch Nail in Tire | Purple painted calipers (you know you like Purple calipers)

Current Hate Level: 10 | Previous Hate Level: 9
The hatin' level on the E46Fanatics.com board.
Dev is offline   Reply With Quote
Old 01-09-2006, 11:22 PM   #6
KingCC
Registered User
 
Join Date: Oct 2005
Location: scarborough, On CAN
Posts: 12
My Ride: 1999 328i
I just purchased my car and i'm having the same problem.... i recently changed the oil.. The yellow oil light will come on and then back off again within a few seconds. I asked the dealer why this happens and he told me that its waiting for the oil to warm up, but for some reason i really don't believe that.
KingCC is offline   Reply With Quote
Old 01-10-2006, 10:24 AM   #7
deletedpenguin
Registered User
 
deletedpenguin's Avatar
 
Join Date: Jun 2004
Location: Sydney, Australia
Posts: 14,097
My Ride: is gone!
Send a message via Skype™ to deletedpenguin
Mine has been coming on for a few seconds as well. I have an oil sensor that needs replacing. $150 or so.
__________________
Stefan | American by birth, Swedish by heritage, Australian by choice.
My current photo galleries.
deletedpenguin is offline   Reply With Quote
Old 01-10-2006, 10:55 AM   #8
EIAlfonso
Registered User
 
Join Date: Mar 2004
Location: McKinney,TX
Posts: 897
My Ride: 2011 535xi M Sport
Quote:
Originally Posted by KingCC
I just purchased my car and i'm having the same problem.... i recently changed the oil.. The yellow oil light will come on and then back off again within a few seconds. I asked the dealer why this happens and he told me that its waiting for the oil to warm up, but for some reason i really don't believe that.
Maybe he thinks you own an M3, the tach lights yellow until the oil is warmed up, another stealer genius.

It's probably the low oil level sensor, $100 for the part and if you can get underneath your car it would be an easy DIY on your next oil change.
EIAlfonso is offline   Reply With Quote
Old 01-10-2006, 11:19 AM   #9
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
Could also be a faulty dip stick. Don't laugh, it's happened.
Fill the engine with the proper number of quarts and then look at the dip stick to see if it's reading correctly.
hummer is offline   Reply With Quote
Old 01-10-2006, 10:30 PM   #10
tanev
Registered User
 
Join Date: May 2005
Location: Houston, TX
Posts: 61
My Ride: 2005 BMW 325i
Thank you. I will be taking it to stealership soon for other items and would ask them to address this one.
Will let you know what explanation/remedy they offer for the problem.
Peter
__________________
2005 BMW 325i, ZPP, ZSP, Retrofits: M3 SMG Steering wheel with paddleshift, OEM Bi-xenons +High beam+ Autoleveling, Predator Chromium, OEM (16:9/MKIV) Navigation, OEM TV/Video Module/Option, Assist/Bluetooth+ Voice Input Control, Universal Tranceiver, OEM Alarm, Alpine CHA-634 6CD/MP3 Changer, OEM Rear Side and Manually Retractable Rear Window Sunshades, Myrtle Wood emergency brake handle, OEM rear lip spoiler.
tanev is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use