E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > Australia

Australia
Check out other E46Fanatics members rides in the Enthusist Directory!

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 08-01-2009, 12:47 AM   #1
BMW//Blonde
Registered User
 
Join Date: Jul 2009
Location: Melbs
Posts: 940
My Ride: 330ci
Has anyone else here had the famous BMW shuddering/idle/vibration problems?

My e36 seemed to have it worse where you would pull up at the lights and the whole car would practically start shuddering. Took it to about 5 mechnics and after a year or two of uncomfortable driving gave up on it and traded.

Nearly died when my e46 started showing signs of a similar prob but thankfully to a far lesser extent to the point where most people thought i was imagining it.

Had an oil leak from the Vanos pipe fixed and turns out the fuel filter was completely blocked and air filter very dirty. Its a much smoother ride now im praying it stays like this!
BMW//Blonde is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-01-2009, 12:49 AM   #2
bobz
Registered User
 
Join Date: Jul 2005
Location: Melbourne Australia
Posts: 1,451
My Ride: 0 BMW's
Quote:
Originally Posted by BMW//Blonde View Post
My e36 seemed to have it worse where you would pull up at the lights and the whole car would practically start shuddering. Took it to about 5 mechnics and after a year or two of uncomfortable driving gave up on it and traded.

Nearly died when my e46 started showing signs of a similar prob but thankfully to a far lesser extent to the point where most people thought i was imagining it.

Had an oik leak from the Vanos pipe fixed and turns out the fuel filter was completely blocked and air filter very dirty. Its a much smoother ride now im praying it stays like this!
In order of likely causes,

ICV
plugs
coils
TPS
water temp sensor

BobZ
__________________
"Little knowledge is Very Dangerous"
bobz is offline   Reply With Quote
Old 08-01-2009, 12:53 AM   #3
BMW//Blonde
Registered User
 
Join Date: Jul 2009
Location: Melbs
Posts: 940
My Ride: 330ci
i think its fixed now but yeah ill try those things if it comes back.

There are so many things it could be, in the old ride i had the injectors replaced, fuel pump replaced, air filters cleaned, ECU even replaced and it still persisted.
BMW//Blonde is offline   Reply With Quote
Old 08-01-2009, 12:58 AM   #4
BMW //MPOWER
Registered User
 
Join Date: May 2007
Location: Singapore
Posts: 1,918
My Ride: The bus...
Quote:
Originally Posted by BMW//Blonde View Post
i think its fixed now but yeah ill try those things if it comes back.

There are so many things it could be, in the old ride i had the injectors replaced, fuel pump replaced, air filters cleaned, ECU even replaced and it still persisted.
Engine mounts?
__________________

BMW 325Ci MY2004 Individual //M Clubsport Edition, //M Clubsport package, //M Sport 18"s, Manual //M Short Shift, Carbon Black, Black Aluminium Cube Interior.
BMW //MPOWER is offline   Reply With Quote
Old 08-01-2009, 04:15 AM   #5
///Pulo
Registered User
 
Join Date: Apr 2009
Location: Essendon, Melbourne, Victoria, Australia
Posts: 3,482
My Ride: 330CI///M individual
turn off the airconditioner??? jokes lol...

hopefully it doesent start happening again !
__________________
6s MT E46 BMW 330CIC Convertible M-Sport Individual Phoenix Yellow
///Pulo is offline   Reply With Quote
Old 08-01-2009, 04:17 AM   #6
BMW//Blonde
Registered User
 
Join Date: Jul 2009
Location: Melbs
Posts: 940
My Ride: 330ci
thats actually not that funny pulo coz as blonde as it sounds the e36 had a button which would fix the shudder, the recerculative? air button. My aunty said just push the button again in this car to stop it but the e46 doesn't have that button lol or it might and it looks different.
BMW//Blonde is offline   Reply With Quote
Old 08-01-2009, 04:19 AM   #7
///Pulo
Registered User
 
Join Date: Apr 2009
Location: Essendon, Melbourne, Victoria, Australia
Posts: 3,482
My Ride: 330CI///M individual
wow im so confused lol
__________________
6s MT E46 BMW 330CIC Convertible M-Sport Individual Phoenix Yellow
///Pulo is offline   Reply With Quote
Old 08-01-2009, 04:34 AM   #8
DIMSIM
Registered User
 
DIMSIM's Avatar
 
Join Date: Jul 2008
Location: Hong Kong
Posts: 1,534
My Ride: 2015 F22 M235i
Quote:
Originally Posted by pulo View Post
turn off the airconditioner??? jokes lol...

hopefully it doesent start happening again !
__________________
 photo 5aa36fca-6690-4fd2-a191-55a2bd36a488_zpsjfnilbiv.jpg
DIMSIM is offline   Reply With Quote
Old 08-01-2009, 04:40 AM   #9
Sherweeeny
Registered User
 
Join Date: Oct 2007
Location: Sydney
Posts: 4,621
My Ride: BMW Civic
Quote:
Originally Posted by BMW//Blonde View Post
thats actually not that funny pulo coz as blonde as it sounds the e36 had a button which would fix the shudder, the recerculative? air button. My aunty said just push the button again in this car to stop it but the e46 doesn't have that button lol or it might and it looks different.
where the display is on the climate control, to its right is a button with recirculation pics on it, one with an A (for automatic) in the middle and so forth, however this buttons function is different as i remember when u clicked it on the E36, the aircon would also automatically come on.
__________________
Sherweeeny is offline   Reply With Quote
Old 08-02-2009, 11:22 PM   #10
BADMAN330
Registered User
 
Join Date: Jun 2009
Location: Melbourne
Posts: 295
My Ride: MY01 330 Coupe
Apparentlty a cause of poor idle and vibrations can come from worn seals in ur vanos unit.
http://beisansystems.com/index.html
__________________
BADMAN330 is offline   Reply With Quote
Old 08-03-2009, 12:08 AM   #11
bobz
Registered User
 
Join Date: Jul 2005
Location: Melbourne Australia
Posts: 1,451
My Ride: 0 BMW's
Quote:
Originally Posted by BMW//Blonde View Post
thats actually not that funny pulo coz as blonde as it sounds the e36 had a button which would fix the shudder, the recerculative? air button. My aunty said just push the button again in this car to stop it but the e46 doesn't have that button lol or it might and it looks different.
So the fast idle was at fault, either becuse the ICV was buggered or the switch was faulty.

BobZ
__________________
"Little knowledge is Very Dangerous"
bobz is offline   Reply With Quote
Old 08-03-2009, 12:29 AM   #12
BMW//Blonde
Registered User
 
Join Date: Jul 2009
Location: Melbs
Posts: 940
My Ride: 330ci
thanx Badman thats an interesting read.

BobZ ICV was the most obvious that came to mind but none of the mechanics could fault that. Still a mystery to me what happened with that car. One workshop told me may as well get rid of it as the engine was on the way out. Someone elses prob now though thank god.
BMW//Blonde is offline   Reply With Quote
Old 08-03-2009, 01:51 AM   #13
tonee
Registered User
 
Join Date: Mar 2008
Location: Melbourne, Australia
Posts: 1,290
My Ride: BMW 320Ci, GSX-R1000
I get the vibs at idle too, i thought it was just my retarded engine

Quote:
Originally Posted by BADMAN330 View Post
Apparentlty a cause of poor idle and vibrations can come from worn seals in ur vanos unit.
http://beisansystems.com/index.html
"Double vanos cars with the M52TU engine (98/99-00) experience cold weather cold start idle jolts and possible stall"

i get that sometimes
__________________
tonee is offline   Reply With Quote
Old 08-03-2009, 01:56 AM   #14
E46 Coupe
Registered User
 
E46 Coupe's Avatar
 
Join Date: May 2008
Location: Australia
Posts: 5,262
My Ride: Rules1 & 2: S T F U!
Quote:
Originally Posted by tonee View Post
I get the vibs at idle too, i thought it was just my retarded engine



"Double vanos cars with the M52TU engine (98/99-00) experience cold weather cold start idle jolts and possible stall"

i get that sometimes
.. in your M54? :|
__________________

Last edited by E46 Coupe; 08-03-2009 at 02:15 AM.
E46 Coupe is offline   Reply With Quote
Old 08-03-2009, 02:02 AM   #15
Connections
Registered User
 
Join Date: Jun 2008
Location: Sydney
Posts: 1,107
My Ride: 2001 320i e46
Quote:
Originally Posted by BADMAN330 View Post
Apparentlty a cause of poor idle and vibrations can come from worn seals in ur vanos unit.
http://beisansystems.com/index.html
Yeah I had this problem when the car is cold too and I still have it, Just havnt had to time to fix it yet..

I even purchased the Vanos seals from that site and was going to install them, but then I took my car to these e46 specialists for something else and they came up with the diagnosis of "Rough Idle PCV valve partly blocked"..

When I drive the car for like 3 mins the rough idling stops so its quite weird.
__________________
Connections is offline   Reply With Quote
Old 08-03-2009, 03:16 AM   #16
kai-
Registered User
 
Join Date: Apr 2008
Location: Australia
Posts: 660
My Ride: three two slow
Quote:
Originally Posted by bobz View Post
In order of likely causes,

ICV
plugs
coils
TPS
water temp sensor

BobZ
What is TPS? And what is a PCV, is that just another name for ICV?

Had a similar vibration problem, it was the plugs. 700 bucks later, the engine was smooth as... But the engine still idled a little high when it was cold.

So I swapped out the VANOS seals, added a little bit of extra power, and smoothed out the engine a bit.

Hardly a wonder fix, but it bugged me that the seals were worn in there!
kai- is offline   Reply With Quote
Old 08-03-2009, 03:19 AM   #17
bobz
Registered User
 
Join Date: Jul 2005
Location: Melbourne Australia
Posts: 1,451
My Ride: 0 BMW's
ICV - Idle Control Valave
TPS - Throttle position sensor
PCV - Positive crankcase ventilation

BobZ
__________________
"Little knowledge is Very Dangerous"
bobz is offline   Reply With Quote
Old 02-09-2011, 12:45 AM   #19
dancendan
Registered User
 
Join Date: Jul 2009
Location: Phoenix
Posts: 3
My Ride: 2001 325i
Guys, I've been having a vibration for the past year. The idle did not throw any codes, my idle was not sporadic, the car would just vibrate and shake while stopped. It happened in both gear and in neutral or park. My car has 93,000 and I replaced the plugs, coils, oil separator, cleaned ICV several times, removed, replaced fuel filter, performed the famous sea foam through the intake, and checked for air leaks EVERYWHERE. I'm very mechanical (did all the work above myself) and was so upset with not being able to fix this vibration. I had read a lot about the engine mounts, but mine appeared to be fine (at least by looking at them) and it just didn't make sense to me that the vibrations would only be felt at idle if it was truly the mounts. Anyways, I finally ordered the two mounts from azautohaus and installed them in about two hours. PROBLEM FINALLY FIXED!!! Smooth as a baby's butt now. I couldn't believe it. I don't regret doing all the other work that didn't cure the problem (it would have needed to be done sooner or later with the miles on the car). I hope this helps. It's $95 for parts, one of the cheaper fixes before you get into coils, vanos, oil seperator, or something else. Good luck!
dancendan is offline   Reply With Quote
Old 06-30-2011, 09:25 AM   #20
association16
Registered User
 
Join Date: Jun 2011
Location: Oasis, UT, USA
Posts: 101
My Ride: 2003 BMW 330xi
Quote:
Originally Posted by bobz View Post
In order of likely causes,

ICV
plugs
coils
TPS
water temp sensor

BobZ
What is TPS?
association16 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use