E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Closed Thread
 
Thread Tools Search this Thread Rating: Thread Rating: 5 votes, 5.00 average.
Old 07-13-2006, 11:24 AM   #41
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by Eduardo1971
Tom, is there an office where I can take my automobile for installation? How much do you charge? What's the warranty?
We can come either to your home or office for installation, warranty 1 year from date of purchase. Feel free to contact me directly for details and to make an appointment.

Quote:
Originally Posted by Eduardo1971
Another question: how is it that videos can be played on the navigation screen but album art cannot be displayed? Are photos able to be displayed on the navigation screen?

Cheers!
You may be confusing the DICE kits with our VSM module. The VSM (Video Source Module) allows for video content to be displayed on the NAV screen - but the iPod itself will not transmit Album Art even in TV mode.
tom @ eas is offline  
Old 07-17-2006, 08:23 AM   #42
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
TOM:

Both my IceLink Plus and my DICE give a whinning nosie while on. I re-ran my trunk cable to a different route, and the noise is still there. My local car stereo shop suggested a ground loop isolator or something, but they didn't know how you'd use one since there were no RCA inputs... Any suggestions? The noise is driving me nuts... I just plugged my ipod into my OEM AUX input adapter (no noise then).

Thanks,
Steve
sna77 is offline  
Old 07-17-2006, 12:49 PM   #43
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by sna77
TOM:

Both my IceLink Plus and my DICE give a whinning nosie while on. I re-ran my trunk cable to a different route, and the noise is still there. My local car stereo shop suggested a ground loop isolator or something, but they didn't know how you'd use one since there were no RCA inputs... Any suggestions? The noise is driving me nuts... I just plugged my ipod into my OEM AUX input adapter (no noise then).

Thanks,
Steve
Steve,

We have a tap-in version on the website:

12 Amp Power Noise Filter
http://www.europeanautosource.com/pr...roducts_id=309

You should be able to pick up a similiar model locally, or order one from us if you can't seem to find one.
tom @ eas is offline  
Old 07-17-2006, 01:54 PM   #44
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
Quote:
Originally Posted by tom @ eas
Steve,

We have a tap-in version on the website:

12 Amp Power Noise Filter
http://www.europeanautosource.com/pr...roducts_id=309

You should be able to pick up a similiar model locally, or order one from us if you can't seem to find one.

Perfect. Any install instuctions for that?
sna77 is offline  
Old 07-17-2006, 01:55 PM   #45
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by sna77
Perfect. Any install instuctions for that?
Sure thing - email me directly and I will reply with a copy.
tom @ eas is offline  
Old 07-25-2006, 11:31 AM   #46
ginzop
Registered User
 
Join Date: Dec 2005
Location: Bay Area
Posts: 60
My Ride: 2004 330cic
Dice - Bluetooth cooperation?

Tom - First off, let me say that this device is great. It's the first time I've been able to integrate a COTS item into my car. I just have a couple of questions and comments about the DICE unit.

1. While I'm listening to the IPOD and I want to use my phone - I press the R/T button to put it in "phone" mode and I get a loud "POP" through the stereo and then the audio mutes. My display changes to my phonebook and all is good , however, when I finish my call, the display goes back to "TR-xx", my IPOD is still playing BUT no sound through the stereo. I have to stop, turn the key "off" and back "on" (I tried just just cycling power on the radio but no joy). Basically, I have to re-init the DICE unit. Has anyone else run accross this?

2. I can't seem to browse albums. Is this just albums within a playlist?

3. Also, I find that whenever I do lose the text display i.e. reverts back to just track [TR-xx], I have to again re-init the audio trio [DICE/IPOD/Radio]. I've had this happen by switching back and forth between the car controls and IPOD touch wheel.

Any info would help me further understand the communication between these devices.
ginzop is offline  
Old 07-25-2006, 03:32 PM   #47
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by ginzop
Tom - First off, let me say that this device is great. It's the first time I've been able to integrate a COTS item into my car. I just have a couple of questions and comments about the DICE unit.

1. While I'm listening to the IPOD and I want to use my phone - I press the R/T button to put it in "phone" mode and I get a loud "POP" through the stereo and then the audio mutes. My display changes to my phonebook and all is good , however, when I finish my call, the display goes back to "TR-xx", my IPOD is still playing BUT no sound through the stereo. I have to stop, turn the key "off" and back "on" (I tried just just cycling power on the radio but no joy). Basically, I have to re-init the DICE unit. Has anyone else run accross this?
What model year is your 325i?

Quote:
Originally Posted by ginzop
2. I can't seem to browse albums. Is this just albums within a playlist?
Pressing CD #3 and the up or down arrows should browse the albums, pressing CD #1 thereafter will browse the songs within that album.

Quote:
Originally Posted by ginzop
3. Also, I find that whenever I do lose the text display i.e. reverts back to just track [TR-xx], I have to again re-init the audio trio [DICE/IPOD/Radio]. I've had this happen by switching back and forth between the car controls and IPOD touch wheel.

Any info would help me further understand the communication between these devices.
Let's get your specific model year and we can troubleshoot from there. I will also need to know if you have Business CD or Navigation.
tom @ eas is offline  
Old 07-25-2006, 06:05 PM   #48
tyroneshoe
Registered User
 
Join Date: Jul 2006
Location: Cleveland
Posts: 5
My Ride: 2004 325xi
Hi Tom,

I've been really disappointed with my DICE unit so far. The controls and everything work great but I have had massive problems with background noise both while in ipod mode and while in aux mode with my satellite unit. I never had any problems with my old BMW ipod interface.

The problem was much worse with the satellite so I installed a ground loop isolator between the DICE unit and the stereo mini-jack for my satellite (I am using shielded cables too). While this helped with *some* of the alternator whine, it still did not completely fix it. I also get the alternator whine when in iPod mode and when there is nothing plugged into the AUX port as well. The other really annoying thing is this "dit-dit-dit" sound which is relatively faint however, I tend to crank up my stereo a lot and it really ruins a lot of songs as it is quite audible at higher volumes.

I tried a few experiments and here were the results:
1) Unplugged the sat radio unit from power and unplugged the aux port on the DICE unit: still heard background noise and "dit-dit" sound while the DICE unit was in aux mode. Worse when revving engine, of course.
2) Killed engine and listened in both AUX and iPod mode: no whine but still hearing the "dit dit" sound.
3) Paused iPod while in iPod mode: more whine and the annoying dit sound.

I saw you had another power isolator on your site that you mentioned previously. Will this completely eliminate the alternator whine? If so, why doesn't DICE ship the unit with one integrated into the cable? Also, do you have any instructions on how to integrate that isolator into my installation (where, how, etc)? Will this also help with the "dit-dit-dit" sound?

Any help would be greatly appreciated.

--Matt

2004 325xi
Business CD

Last edited by tyroneshoe; 07-25-2006 at 06:07 PM.
tyroneshoe is offline  
Old 07-25-2006, 06:11 PM   #49
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by tyroneshoe
Hi Tom,

I've been really disappointed with my DICE unit so far. The controls and everything work great but I have had massive problems with background noise both while in ipod mode and while in aux mode with my satellite unit. I never had any problems with my old BMW ipod interface.

The problem was much worse with the satellite so I installed a ground loop isolator between the DICE unit and the stereo mini-jack for my satellite (I am using shielded cables too). While this helped with *some* of the alternator whine, it still did not completely fix it. I also get the alternator whine when in iPod mode and when there is nothing plugged into the AUX port as well. The other really annoying thing is this "dit-dit-dit" sound which is relatively faint however, I tend to crank up my stereo a lot and it really ruins a lot of songs as it is quite audible at higher volumes.

I tried a few experiments and here were the results:
1) Unplugged the sat radio unit from power and unplugged the aux port on the DICE unit: still heard background noise and "dit-dit" sound while the DICE unit was in aux mode. Worse when revving engine, of course.
2) Killed engine and listened in both AUX and iPod mode: no whine but still hearing the "dit dit" sound.
3) Paused iPod while in iPod mode: more whine and the annoying dit sound.

I saw you had another power isolator on your site that you mentioned previously. Will this completely eliminate the alternator whine? If so, why doesn't DICE ship the unit with one integrated into the cable? Also, do you have any instructions on how to integrate that isolator into my installation (where, how, etc)? Will this also help with the "dit-dit-dit" sound?

Any help would be greatly appreciated.

--Matt

2004 325xi
Business CD
Matt,

It's because it's hardly ever needed. The DICE kits rarely exhibit any type of engine whine. You could be picking up inteference from other devices in the vehicle. Try relocating the wire to see if the noise diminishes or goes completely away.

See if relocating the cable (away from other wiring or battery cables) helps first - then we can use the noise filter if needed.
tom @ eas is offline  
Old 07-25-2006, 06:15 PM   #50
ginzop
Registered User
 
Join Date: Dec 2005
Location: Bay Area
Posts: 60
My Ride: 2004 330cic
I have a 2005 325ci. Business CD, Blitzsafe/XMDirect kit. The XM kit plugs in to the CD changer 3/6 pin connectors and has pass-thru 3/6 pin connectors. I had a OEM changer plugged in to the XM pass-thru and everything was ace. I pulled the changer out and put the DICE in. Since my last post I tried it again. If I switch modes to FM or XM or CD prior to using the BT function, everything is fine. But if I'm in CDC mode and press the RT button on the Steering Wheel - I get a "pop" thru the speakers - I can use the phone - but when I end the call the display comes back without sound or song text. This time I just turned the radio (power) "off" and then back "on" and the audio came back. It still has a problem bringing the test back though untill I re-init the DICE/IPOD.

I apologize if this is still unclear.
ginzop is offline  
Old 07-25-2006, 07:16 PM   #51
gyoung_06
Registered User
 
Join Date: Apr 2006
Location: Dallas, TX
Posts: 75
My Ride: 02 330Ci
Quote:
Originally Posted by tyroneshoe
The other really annoying thing is this "dit-dit-dit" sound which is relatively faint however, I tend to crank up my stereo a lot and it really ruins a lot of songs as it is quite audible at higher volumes.
Tom,

Okay, so I figured out I had an old battery, DICE didnt kill it, time did... but I've got the same issues as a few others with the background clicking noise. It's there when changing songs and all the way through the next ones. And I know it's not the alternator cause I don't get any whine, and CD's play fine... it still does this noise in acc position. Any thoughts on this? You've replaced my unit once already, and this seems like it could be solved with some sort of fw upgrade (custom eq settings maybe?) Anyways, just adding my two cents... aside from the clicking, its a great product, made my life much easier.
gyoung_06 is offline  
Old 07-25-2006, 10:36 PM   #52
CynicalWry
Doesn't like PMs...Email me
 
CynicalWry's Avatar
 
Join Date: Feb 2003
Location: Gaithersburg, Maryland
Posts: 2,803
My Ride: 00 323i-05 cbr600rr
Send a message via AIM to CynicalWry
another thread that deserves a sticky
__________________
is your friend

Authorized Umnitza.com installer
301-825-5871
http://www.robinsNestChildCare.com - - - - - http://www.tntTint.net

CynicalWry is offline  
Old 07-29-2006, 10:19 AM   #53
DMXtremeZHP
Registered User
 
DMXtremeZHP's Avatar
 
Join Date: May 2004
Location: Ridgewood NJ, Long Branch NJ, NYC, Boston, MA, Edgewater NJ
Posts: 2,667
My Ride: 04 330i ZHP & 13 S4
Send a message via AIM to DMXtremeZHP
Hey Tom, just wondering if the video cradle has been released yet? If not - is it possible later on to add this on, or the VSM to allow video to play? Getting ready to make the switch to DICE and gonna sell the CD changer.. Are most of these glitches/problems common?
Thanks -
Billy 2004 330i w/NAVI
__________________
William

Modified* 2004 Silver Gray BMW 330i ZHP
Rogue Engineering|aFe|H&R|Hotchkis|Dinan|Shark|JL|DICE|etc.

FOR SALE!!! PM OR EMAIL ME: wjn126@gmail.com


Garage:
2013 Audi S4|2014 Jeep Grand Cherokee Summit|2008 Mercedes-Benz ML550|2008 BMW X5 3.0si|2011 Mercedes-Benz SL550
DMXtremeZHP is offline  
Old 07-29-2006, 12:57 PM   #54
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by DMXtremeZHP
Hey Tom, just wondering if the video cradle has been released yet? If not - is it possible later on to add this on, or the VSM to allow video to play? Getting ready to make the switch to DICE and gonna sell the CD changer.. Are most of these glitches/problems common?
Thanks -
Billy 2004 330i w/NAVI
We've had the cradles in stock since the beginning of the month.

There are a few people running the VSM/DICE Cradle setup, no problems to report.
tom @ eas is offline  
Old 07-29-2006, 05:46 PM   #55
DMXtremeZHP
Registered User
 
DMXtremeZHP's Avatar
 
Join Date: May 2004
Location: Ridgewood NJ, Long Branch NJ, NYC, Boston, MA, Edgewater NJ
Posts: 2,667
My Ride: 04 330i ZHP & 13 S4
Send a message via AIM to DMXtremeZHP
ah sorry, didn't see it on the website yet. But for now most importantly is that I get my ipod's music working in the car. Do I need the video cradle now if I'm not getting the VSM yet? I don't want to spend over $500 just yet, maybe down the line. That's why I was asking if these are possible to add-on later?

In other words, what do I get from getting the video cradle along with the DICE? Does it allow it to play videos on the ipod when it's hooked up, with the option of connecting monitors to it? Good chance I will get the VSM to get it to play on the navi screen, just not yet
__________________
William

Modified* 2004 Silver Gray BMW 330i ZHP
Rogue Engineering|aFe|H&R|Hotchkis|Dinan|Shark|JL|DICE|etc.

FOR SALE!!! PM OR EMAIL ME: wjn126@gmail.com


Garage:
2013 Audi S4|2014 Jeep Grand Cherokee Summit|2008 Mercedes-Benz ML550|2008 BMW X5 3.0si|2011 Mercedes-Benz SL550

Last edited by DMXtremeZHP; 07-29-2006 at 05:49 PM.
DMXtremeZHP is offline  
Old 07-29-2006, 05:50 PM   #56
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by DMXtremeZHP
ah sorry, didn't see it on the website yet. But for now most importantly is that I get my ipod's music working in the car. Do I need the video cradle now if I'm not getting the VSM yet? I don't want to spend over $500 just yet, maybe down the line. That's why I was asking if these are possible to add-on later?
Sure - you can add the cradle at any time.

Quote:
Originally Posted by DMXtremeZHP
In other words, what do I get from getting the video cradle along with the DICE? Does it allow it to play videos on the ipod when it's hooked up, with the option of connecting monitors to it? Good chance I will get the VSM to get it to play on the navi screen, just not yet :-)
You get a secure holder for your iPod, which allows a video-out signal from the docking connector port on your iPod (preferred over the headphone jack). This signal can be fed to external monitors, or to the VSM if you wish to have the video appear on your NAV screen.
tom @ eas is offline  
Old 07-30-2006, 11:18 AM   #57
ginzop
Registered User
 
Join Date: Dec 2005
Location: Bay Area
Posts: 60
My Ride: 2004 330cic
Tom-
Any more info on the BT integration issues?
ginzop is offline  
Old 07-30-2006, 05:22 PM   #58
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by ginzop
Tom-
Any more info on the BT integration issues?
Yes! Contact me via email and we'll make arrangements to correct your issue.
tom @ eas is offline  
Old 07-30-2006, 06:19 PM   #59
ginzop
Registered User
 
Join Date: Dec 2005
Location: Bay Area
Posts: 60
My Ride: 2004 330cic
E-Mail sent. Thanks for the quick response.
ginzop is offline  
Old 07-30-2006, 10:08 PM   #60
tom @ eas
european auto source
 
tom @ eas's Avatar
 
Join Date: Jun 2004
Location: SoCal
Posts: 12,584
My Ride: e92 S/C M3
Quote:
Originally Posted by sna77
My wish list (not that DICE cares or anything)

1. Get rid of the damn * and use a - . Not sure why this drives me crazy, but it does. Think I was just used to the IceLink

2. Add browse by artist. Most important feature obviously. Ax the books on tape crap on there if they need space.

3. Fix it so that I can scroll my address book on my BT phone while the ipod is playing. Also you can't really adjust the audio tones etc while the DICE is active. When the screen flashes to display the text, it takes over whatever you are doing on the display (i.e using the address book, adjusting the bass etc)
1. Suggestion noted.

2. This is currently in development at this time. Right now, this feature is not possible without locking the iPod's clickwheel - which we do not want happening.

3. If you have NAV - use track #6 on the text selector (disc 6), this will solve the phonebook overwriting issue.
tom @ eas is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use