E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Other BMW Models > General BMW Model Discussion

General BMW Model Discussion
All non E46 BMW model questions in here. Look below for E36, E90 and F30 specific forum. For additional model specific forums check out bimmerfest.com!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-13-2006, 02:07 AM   #1
AS007
Registered User
 
Join Date: Nov 2004
Location: Clearwater, Florida
Posts: 821
My Ride: 328Ci
Send a message via AIM to AS007
Problems starting the X5.....

Today I went into this store came out about 30 minutes later tried to start my bro's 2001 X5 4.4i and when I turned the key it would just "tick" over and over. I tried to jump start it but same thing, the battery has power all the lights flicker when it "ticks". So I left the car in the parking lot and got a ride home any idea what is wrong with it??
AS007 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-13-2006, 02:35 AM   #2
Gir
Registered User
 
Join Date: Feb 2004
Location: .
Posts: 2,210
My Ride: .
If the battery is 5 years old and it's getting colder outside I would expect a weak battery. You can have all your lights and stereo come on but not enough juice to turn the engine.

I'm thinking the jump was unsuccessful due to poor luck in getting a good connection/other car not able to put out.
Gir is offline   Reply With Quote
Old 10-13-2006, 03:15 AM   #3
Hey-G
Registered User
 
Join Date: Sep 2003
Location: Montreal
Posts: 1,209
My Ride: E46's
Quote:
Originally Posted by Gir View Post
If the battery is 5 years old and it's getting colder outside I would expect a weak battery. You can have all your lights and stereo come on but not enough juice to turn the engine.

I'm thinking the jump was unsuccessful due to poor luck in getting a good connection/other car not able to put out.
Ya, sounds exactly like a low battery. Stereo and lights will still work, but not enough juice to wake the beast.
__________________

-=It's all about style=-
Hey-G is offline   Reply With Quote
Old 10-13-2006, 04:36 AM   #4
goowatchi
Registered User
 
Join Date: Jan 2004
Location: bay area, ca
Posts: 650
My Ride: tiag step 330ci
Send a message via AIM to goowatchi
Sometimes, an old/generic set of jumper cables would not hold enough juice to jumpstart your dead battery.
__________________
goowatchi is offline   Reply With Quote
Old 10-13-2006, 10:20 AM   #5
joedaddy
Registered User
 
Join Date: Mar 2004
Location: Newport Beach, CA
Posts: 1,368
My Ride: OCTA
isn't "click click", the starter?
__________________
joedaddy is offline   Reply With Quote
Old 10-13-2006, 04:41 PM   #6
yayopwr
Registered User
 
Join Date: Jul 2004
Location: location
Posts: 966
My Ride: yeah
nope click click is the battery happened in the with my car a month ago i thought it was the starter also
yayopwr is offline   Reply With Quote
Old 10-13-2006, 08:13 PM   #7
2001BMW330xi
revolt1112@msn.com
 
Join Date: Oct 2003
Location: Detroit, MI
Posts: 5,163
My Ride: Jeep
Send a message via AIM to 2001BMW330xi
bad alternator?
__________________
-Ratnesh
2001BMW330xi is offline   Reply With Quote
Old 10-14-2006, 09:25 AM   #8
m3racing
Registered User
 
Join Date: Nov 2004
Location: Cumberland MD
Posts: 4,202
My Ride: Yamaha R6
Send a message via AIM to m3racing
battery
__________________
Cuong- PS3- AUKTANE6

m3racing is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use