E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 85 votes, 5.00 average. Display Modes
Old 10-13-2008, 10:28 PM   #181
bobcat
Registered User
 
Join Date: Aug 2007
Location: Australia
Posts: 28
My Ride: e92 & e46
Just 2 questions -
1.
Back on p5 of this thread Tom mentioned the only way to eliminate the group loop problem was with the gli (ie. when i plug the iphone charger into the cigarette lighter to charge, aux doesn't worK); Is it possible to ground the diy aux cable to somewhere else to charge and play via aux at the same time?
2.
Since I'm using the iPhone, with the diy aux cable, all phone calls are now played via the car stereo speakers, but microphone of the phone itself is still being used (which can be inconvienient since the phone is hidden inside the sunglasses compartment); Is it possible (and how) to tap into the oem microphone above the rear view mirror (I'm assuming it'll have to be done with the harness hidden inside the centre console?)?
bobcat is offline   Reply With Quote
Old 10-14-2008, 12:28 PM   #182
toffa
Registered User
 
Join Date: Sep 2008
Location: Milan, I
Posts: 43
My Ride: 320ci
Send a message via MSN to toffa
Quote:
Originally Posted by Leon_s View Post
Do you have more info or pics of where the resistor should be installed?
Does it work?
This is the picture I made during the realization of my cable.
At the moment I'm using it

toffa is offline   Reply With Quote
Old 10-14-2008, 09:17 PM   #183
andryxa
Registered User
 
Join Date: Apr 2008
Location: nor-cal
Posts: 149
My Ride: 2002 m3 vert- Sold
k i tried doing this today and when take out the stereo i cant take out the plug. i lift it up and then what do i do?
the links to the other sites didnt really help me. once i lift the main plug with a screw driver do i just pull it off or how does that work?
andryxa is offline   Reply With Quote
Old 10-15-2008, 02:28 AM   #184
rorschach
Registered User
 
Join Date: Apr 2008
Location: Tallinn, Estonia
Posts: 833
My Ride: '01 318i
Pull it up very hard and the whole connector will pop off.
rorschach is offline   Reply With Quote
Old 10-15-2008, 05:13 AM   #185
toffa
Registered User
 
Join Date: Sep 2008
Location: Milan, I
Posts: 43
My Ride: 320ci
Send a message via MSN to toffa
Quote:
Originally Posted by andryxa View Post
k i tried doing this today and when take out the stereo i cant take out the plug. i lift it up and then what do i do?
the links to the other sites didnt really help me. once i lift the main plug with a screw driver do i just pull it off or how does that work?
pull up!
toffa is offline   Reply With Quote
Old 10-15-2008, 04:53 PM   #186
adrianpl
Registered User
 
Join Date: Jun 2006
Location: New York
Posts: 615
My Ride: 01 330ci
http://www.geekmatica.com/modules.ph...article&sid=23
adrianpl is offline   Reply With Quote
Old 11-08-2008, 01:02 AM   #187
Burger888
Registered User
 
Join Date: Sep 2008
Location: Australia
Posts: 43
My Ride: 03 325i M Sport Pack
I completed this DIY today and its work superbly. I mounted a 3.5mm stereo jack socket at the back of the sunglasses case as described here http://forum.e46fanatics.com/showthread.php?t=547723.

Couple of observations from my experience

1) Mine worked fine with the straight cable without any capacitors or resistors. I used LED/switch wires from an old PC as suggested and just soldered 'em straight up to the 3.5'' jack. The AUX input is detected by the head unit as soon as your iPod is connected, this obviously provides a load that the head unit can detect.

2) Pulling the sunglasses holder out was impossible from the front! I read plenty of threads about how to get it out and I couldn't do it! I managed to get it out easily in the end by popping out the aircon control panel which allowed me to reach in behind and push the sunglasses holder out from the back. Worked a treat.

I gotta say, it sounds wicked!
Burger888 is offline   Reply With Quote
Old 01-14-2009, 08:58 PM   #188
kkeddy
Registered User
 
Join Date: Oct 2008
Location: Toronto
Posts: 145
My Ride: 325i
just did it today! AWSOME diy. thanks saved 100$ (in canada) the kit is mad expensive. lol. the

the deck needs to reeive signal from both LEFT AND RIGHT in order to have the aux mode if anyones questioning about aux mode.
__________________
kkeddy.
03 325i
2010 Civic SI
2001 m3
kkeddy is offline   Reply With Quote
Old 01-29-2009, 12:17 AM   #189
blackbeam05
Registered User
 
Join Date: Aug 2006
Location: My House
Posts: 549
My Ride: 2004 325i
i know this is a stupid question but can someone lead me to where i can find this pc cord or something similar please? also...maybe this link will help me and you find the part..thanks
http://www.google.com/products?hl=en...+pin&scoring=p
__________________
blackbeam05 is offline   Reply With Quote
Old 02-01-2009, 03:51 PM   #190
blackbeam05
Registered User
 
Join Date: Aug 2006
Location: My House
Posts: 549
My Ride: 2004 325i
anyone??..please...
__________________
blackbeam05 is offline   Reply With Quote
Old 02-01-2009, 04:41 PM   #191
kkeddy
Registered User
 
Join Date: Oct 2008
Location: Toronto
Posts: 145
My Ride: 325i
its a really small plug that connects to the led indicator/power/reset switch to the motherboard
__________________
kkeddy.
03 325i
2010 Civic SI
2001 m3
kkeddy is offline   Reply With Quote
Old 02-14-2009, 10:42 AM   #192
Atlas
Registered User
 
Join Date: Aug 2002
Location: Melbourne, Australia
Posts: 1,245
My Ride: 320i
Send a message via ICQ to Atlas
Would something like this (http://cgi.ebay.com.au/Ground-Loop-I...3A1|240%3A1318) work to allow charging from the cigarette lighter whilst using AUX input?
Atlas is offline   Reply With Quote
Old 02-28-2009, 08:18 PM   #193
jdmtyteeeyo
Registered User
 
Join Date: Mar 2007
Location: wi
Posts: 302
My Ride: 2004 325ci
Send a message via AIM to jdmtyteeeyo
hmmm i did this and i am having a whistling noise comming from my speakers whever i plug it in .. and when i switch songs it makes a weird noise too... thinking its a bad connection???
__________________
jdmtyteeeyo is offline   Reply With Quote
Old 04-13-2009, 03:08 PM   #194
elbutio
Registered User
 
Join Date: Mar 2007
Location: United Kingdom
Posts: 2
My Ride: 05 320D and 99 323
Hi folks, followed this post today and made a cable exactly as described. I have connected it to my BMW business cd/radio but can't get it to work, it won't enter aux mode. I have the mode button and my car is an 05 320d so a later model Business cd that also plays mp3 cds.

Do i need to install resistors for this to work?? Any help or information would be greatly appreciated.
elbutio is offline   Reply With Quote
Old 04-13-2009, 03:35 PM   #195
rorschach
Registered User
 
Join Date: Apr 2008
Location: Tallinn, Estonia
Posts: 833
My Ride: '01 318i
It will only enable AUX if you have a working music player connected.
rorschach is offline   Reply With Quote
Old 04-13-2009, 04:53 PM   #196
elbutio
Registered User
 
Join Date: Mar 2007
Location: United Kingdom
Posts: 2
My Ride: 05 320D and 99 323
Thanks for the reply -forgot to say my mp3 player was connected, also tried laptop via headphone socket to be sure.

If any use my cd player says BMWRCD109-04 on the top.
elbutio is offline   Reply With Quote
Old 04-16-2009, 04:35 AM   #197
JacksonY
Registered User
 
Join Date: Oct 2008
Location: Hong Kong
Posts: 75
My Ride: BMW 330Ci (2004 E46)
I have a 2004 330Ci, my car has OEM CD Changer... can I still do this since it seems to use different pins?
__________________
2004 BMW 330Ci - Sapphire Metalic Black
http://www.conceptfury.com/
JacksonY is offline   Reply With Quote
Old 04-16-2009, 09:56 AM   #198
--Ice--
Registered User
 
Join Date: Sep 2008
Location: Estonia
Posts: 3
My Ride: E46 320Td Compact
Any ideas?
Without the resistor and condensors aux worked about 5sec and then changed back to radio.
Ok, then i bought resistor and condensors, added them to the cable and.... Nothing!
What's wrong, i'm starting to loose my mind.
For testing i have an mp3 and cd player.
--Ice-- is offline   Reply With Quote
Old 04-16-2009, 01:51 PM   #199
--Ice--
Registered User
 
Join Date: Sep 2008
Location: Estonia
Posts: 3
My Ride: E46 320Td Compact
Everything's ok now. I connected the condensors wrong.
Thanks for the DIY
--Ice-- is offline   Reply With Quote
Old 04-19-2009, 03:22 AM   #200
a_n9ne
Registered User
 
Join Date: Jan 2009
Posts: 225
SV 20-02 41
FUUUUUUUUUUU
__________________
-Aleks


*large annoying gif removed*

a_n9ne is offline   Reply With Quote
Reply

Tags
bmw aux in, diy aux input, input cable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use