E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum

Forced Induction Forum
Discuss supercharging, turbocharging and even nitrous and water injection here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-23-2016, 05:19 PM   #1
AMG-ETR
Registered User
 
Join Date: Mar 2006
Location: Toronto
Posts: 2,278
My Ride: S54B32 On Boost
Send a message via MSN to AMG-ETR
Arrow AEM boost gauge reading a lot higher than supposed to

My boost gauge is reading a lot higher than it's supposed to. Around 4K RPM its reading around 11 PSI.

Also when the car is turned off and I leave the key to position II, it reads anywhere from 4-6 PSI.

Usually it just reads 0.

Any ideas?
__________________



Last edited by AMG-ETR; 03-23-2016 at 05:22 PM.
AMG-ETR is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-23-2016, 05:39 PM   #2
Commanderwiggin
Registered User
 
Join Date: Jun 2010
Location: Calgary, Canada
Posts: 4,001
My Ride: 900rwhp Turbo M3
Bad sensor; time for a new one.
__________________
900+RWHP, PT6870 w/ Custom FSR Turbo Kit, AEM Infinity, Lab22 Motor
Commanderwiggin is online now   Reply With Quote
Old 03-28-2016, 11:16 AM   #3
AMG-ETR
Registered User
 
Join Date: Mar 2006
Location: Toronto
Posts: 2,278
My Ride: S54B32 On Boost
Send a message via MSN to AMG-ETR
Thanks! Do you know where I can order the sensor alone?
__________________


AMG-ETR is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use