E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 11 votes, 5.00 average. Display Modes
Old 08-03-2007, 01:13 PM   #1
kinderstod
Registered User
 
Join Date: Jun 2007
Location: Leesburg, Virginia
Posts: 29
My Ride: 2003 BMW 330Ci
Evap + Cat won't reset for Emission Test

I'm having the damndest problem, again, out of my 330Ci

After dropping about $4,000 for the transmission repair, the computer was reset. All the modules reset except for the Evap and the Cat. After 6 trips to the testing station, and driving the drive cycle for over 500 miles, those two STILL haven't reset.

My tags have been dead since June 1st, and DMV won't issue new ones to me until the car passes emissions. It's never failed, it just won't reset those last two modules.

What the hell can I do? I have a pinky sized hole in the lower intake boot, I have the part and am installing it today, will that fix this?

Anybody else have problems getting the car to reset after a repair?
kinderstod is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-03-2007, 01:15 PM   #2
kinderstod
Registered User
 
Join Date: Jun 2007
Location: Leesburg, Virginia
Posts: 29
My Ride: 2003 BMW 330Ci
Oh yeah, and I don't have any CEL codes being thrown, the damn things just won't reset
kinderstod is offline   Reply With Quote
Old 08-03-2007, 01:53 PM   #3
kinderstod
Registered User
 
Join Date: Jun 2007
Location: Leesburg, Virginia
Posts: 29
My Ride: 2003 BMW 330Ci
Hm, I got an appointment with an imports place here close to work, the general thought is that there is a code stuck in Pending, so they're going to hook it up to the BMW licensed computer equipment and clear the entire computer out
kinderstod is offline   Reply With Quote
Old 08-03-2007, 02:25 PM   #4
Turbopilot
Registered User
 
Join Date: May 2007
Location: Atlanta
Posts: 202
My Ride: 2004 330Ci
You spent $4,000 and you can't get an exemption? I know you want to fix it and get the codes reset but if you got an exemption at least you could get a tag and buy yourself a year to work on it. If four grand won't do it VA must be crazy strict.

Have you tried just pulling the battery and grounding the car to itself for about 15 minutes?
__________________
Turbopilot is offline   Reply With Quote
Old 08-03-2007, 04:58 PM   #5
kinderstod
Registered User
 
Join Date: Jun 2007
Location: Leesburg, Virginia
Posts: 29
My Ride: 2003 BMW 330Ci
Quote:
Originally Posted by Turbopilot View Post
You spent $4,000 and you can't get an exemption? I know you want to fix it and get the codes reset but if you got an exemption at least you could get a tag and buy yourself a year to work on it. If four grand won't do it VA must be crazy strict.

Have you tried just pulling the battery and grounding the car to itself for about 15 minutes?
I'm actually not sure how the exemptions work, all I know is VA refuses to give me another 30 day extension. I'm thinking about taking the paperwork in on Monday and just saying "Hey, look at this ****, I'm driving around in an unregistered car, give me the ****ing tags so I can stop dodging cops".

Only, you know, a little bit nicer.
kinderstod is offline   Reply With Quote
Old 08-07-2007, 08:29 PM   #6
kinderstod
Registered User
 
Join Date: Jun 2007
Location: Leesburg, Virginia
Posts: 29
My Ride: 2003 BMW 330Ci
Ah, I FINALLY passed emissions and got my tags today, after 3 months, 2 tickets, and a $4,000 tranny repair.

Basically, that damn whistle you guys sometimes have, with the hole in the lower intake boot? That was tripping the computer up from resetting the Evap+Cat modules, and screwing up the emission test ( basically coming back "Not ready" 6 times in a row.

I replaced the lower boot over the weekend ( $15 for the boot, and about 2 hours of work because I'm a noob ), drove home, got a ticket, but it finally reset. Passed emissions today, no more whistle, gas mileage is better, and the car is running better.

Oh yeah, and THANK YOU to everyone on this forum, I've searched through hundreds of posts, posted a few things, and have gotten great help from everyone on this forum. You all have saved me about $500 so far in diagnostic crap and fixes. I'll have to throw a BMW Get Drunk Party or something to pay some of you back

Last edited by kinderstod; 08-07-2007 at 08:30 PM. Reason: Thanks
kinderstod is offline   Reply With Quote
Old 04-02-2009, 12:16 PM   #7
sugarandspider
Registered User
 
Join Date: Nov 2006
Location: Virginia
Posts: 1
My Ride: 01' 330i
I had the exact same issue and also live in VA. I needed an emissions inspection but my SES light came on with a P0174 code. I cleaned the MAF sensor and the light went off, but the code still remained. I reset the SES light and drove about 50 miles, went to take emissions test but the EVAP monitor never became ready. I had it tested 4 times and drove over 200 miles with no luck, still not ready. This is what solved my problem: You have to make sure you car sets overnight or cools down considerably before driving, then drive on the highway OVER 55 for atleast 3 minutes and your EVAP will become ready to test. Good luck!
sugarandspider is offline   Reply With Quote
Old 04-02-2009, 01:46 PM   #8
330ciandr6
Registered User
 
Join Date: May 2007
Location: .
Posts: 6,605
My Ride: .
Send a message via AIM to 330ciandr6 Send a message via Yahoo to 330ciandr6
wow ancient bump
__________________
Have a oil or coolant leak? Click here!:http://forum.e46fanatics.com/showthr...732&highlight=
ABS/DSC/Brake/Airbag light on?? Click here!:http://forum.e46fanatics.com/showthr...648&highlight=
330ciandr6 is offline   Reply With Quote
Old 10-01-2009, 11:42 AM   #9
newbiecruiser
Registered User
 
Join Date: Sep 2009
Location: Queens NY
Posts: 3
My Ride: 2002 325ci
NOOB here, got a 02 325ci , have the same "whistle" , sounds almost like a turbo< ,, can't pass inspection, went through 10 drive cycles, at least 300 miles I've driven. I'm very glad I stumbled onto this thread, gonna have lower intake boot checked/replaced. thanks in advance to kinderstod if this works.
newbiecruiser is offline   Reply With Quote
Old 10-01-2009, 02:52 PM   #10
Jim Murphy
Registered User
 
Join Date: Mar 2009
Location: Atlanta (Dunwoody), GA
Posts: 457
My Ride: 2006 E46 330Ci ZHP
Mine also would not reset so I went back to the dealer and they gave me instructions to drive the car at 55 mph (without varying) for about 15 minutes along with some other speeds in a very specific sequence and time frames (IIRC). If you break the sequence or vary from the speed anywhere then you have to start all over again. The only way to go constantly at 55mph for 15 minutes in the Atlanta area is to get on the interstate in the far right lane with the blinkers on and keep my eyes on my mirrors as everyone else zoomed by me. That fixed my reset and I passed emissions. Later, a friend of mine told me about a computer program that the emissions people can use to run the car on the rollers for about 20 minutes while the program repeatedly asks: "Are you reset yet?".
This costs money to do, of course.

Jim
Jim Murphy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use