E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 04-16-2008, 09:41 AM   #1
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
P1397

Ok guys i know this has been discused to death and yes I did do a SEARCH but I just want to make sure. I have an ses light, Went to Auto Zone to get the code read and it came back P1397. So I know that this is a code for the Camshaft Position sensor. My question is which one? I know there is an intake and an exhaust side. I think from what i read that I have to change the exhaust side. Again I just want to make sure. Can some one please post a pic or give me a link that shows the exact sensor that needs to be changed. From what i have read correctly the intake sensor is on the front of the motor and the exhaust sensor is on the side. Behind a small cylinder which I believe is the Vanos selinoide and ight next to the oil filter housing. Please someone just confirm this. Also need a part number, thanks Guys!
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-17-2008, 04:12 PM   #2
EurosportAMG
Registered User
 
Join Date: Sep 2004
Location: around the world
Posts: 244
My Ride: bm mb
yes this is the exhaust one (easier to change too)
part number 12141438082
realoem is your friend ;p
look under engine=cylinder head=cylinder head vanos for the exact pic and location

only thing about cam sensors they tend to both go out at about the same mileage, due to failing orings, so you might have the other one go out as well within next 5k miles...
EurosportAMG is offline   Reply With Quote
Old 04-20-2008, 08:34 PM   #3
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
Thanks for the feedback, good looking out. Looks to me like I will be doing this repair quite soon. The SES light went from intermitant to always on! LOL
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Old 04-30-2008, 01:02 PM   #4
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
Just did the sensor swap and it was very easy, SES light is off. The car seems to run smoother now to which is cool. I wonder what the stealership would charge to do a job like this $500! HAHAHAHAH Sensore cost me $60 shipped from Brav Auto. Awsome, I love this forum!
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Old 05-02-2008, 01:05 PM   #5
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
OK, I had a feeling this would happpen, SES light came back on. Car still runs fine with no hesitaion, loss of power, or rough idle. Went AZ and had the codes read .......again

Camshaft Sensor A bank 1
P0340
p1397

So im going to assume that is the intake side since i just changed my eaxhaust side (duh) but wouldnt the p1397 code clear and i would just get the p0340 code. Or is it normal to get both codes? Also, how would I know if the sensor that I just purchased is bad?
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Old 05-04-2008, 07:43 PM   #6
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Old 05-04-2008, 08:38 PM   #7
Ivegotissues666
Registered User
 
Join Date: Jul 2004
Location: Boston, MA
Posts: 1,015
My Ride: 88' BMW E30 SETA
Send a message via AIM to Ivegotissues666
If you didnt clear the P1397 after you installed the last cam sensor, even though the light went away. The code was still stored in memory and thats why you still see it. If you install the intake sensor which is Sensor A and clear the lights with a scan tool and P1397 still comes back you more than likely have a Vanos Seal issue.

Jared
Ivegotissues666 is offline   Reply With Quote
Old 05-05-2008, 04:14 PM   #8
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
Ok Good to know, I did not clear the code after I did the exhaust side. The car runs fine though. If i had the vanos seal issue wouldnt my car have the issues that are associated with it? Hard starting, loss of power, hesitation, rough idle.........
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Old 06-12-2009, 12:48 PM   #9
auteck
Registered User
 
Join Date: Nov 2006
Location: Cary, NC
Posts: 46
My Ride: 330i
Please update us ont this, thanks.
auteck is offline   Reply With Quote
Old 06-16-2009, 01:01 PM   #10
raptorman5174
Registered User
 
Join Date: Dec 2006
Location: Central New Jersey
Posts: 804
My Ride: 330i ZHP
I had a faulty exhaust cam shaft sensor, had to replace it twice, haven't seen SES light since, Car runs great. My sugestion to all you guys with this problem. Run to the dealer and pony up for the OEM sensors. Yes they are more expensive but like the old saying goes.....

"You get what you pay for"
__________________

18 VMR CSL's
Koni FSD's
Eibach Sport Spring's
UUC Power Pullies
Sprint Booster
CCV Delete
raptorman5174 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use