E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-29-2008, 09:10 AM   #1
jhall1957
Registered User
 
Join Date: May 2006
Location: WS,NC
Posts: 57
My Ride: 01 330ci & 00 M road
Please read, I need help figuring this out!

I have a great 04 330i ZHP car, love it! One small problem is that every other time or so, when I get in the car to drive it, the dash computer tells me I have a right rear light out. I have checked it and no blubs burned out?

The worst part is that sometimes as I drive, the warning just turns off. Is this some secret warning or a bad sensor or something?

I have changed all the blubs and it still happens.

Any ideas or suggestions would be great!

Jeff
jhall1957 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-29-2008, 09:50 AM   #2
M0nk3y
Banned
 
Join Date: Nov 2007
Location: Cleveland, Ohio
Posts: 2,065
My Ride: 2002 325xi
This can be caused by two things......Either you have corrosion in the bulb socket. Or you have a bad ground that is fried in your connector.........

First check corrosion in the socket. Just remove the bulb and clean it.......

If that doesn't work, then take apart the two connectors in your taillight. Check the male plug, and see if anything is fried, burnt, melted.....etc.......

If it is, then all you need is a new plug from the dealership. You can either DIY and replace the plug (and add a new ground to the taillight), or have the dealership do it......


This happened to me also. But it happened in both connectors. Thankfully, my car was under warrenty, and they did it for free
M0nk3y is offline   Reply With Quote
Old 07-29-2008, 02:25 PM   #3
Kenny@JleviSW
Past Site Sponsor
 
Join Date: Aug 2007
Location: Santa Clara
Posts: 611
My Ride: JB E90 335
Send a message via AIM to Kenny@JleviSW
It could just be a loose wire. Another member had the same problem recently and it turned out to be a loose wire.
Kenny@JleviSW is offline   Reply With Quote
Old 07-29-2008, 02:37 PM   #4
glovesoff
Registered User
 
Join Date: Apr 2008
Location: Indiana
Posts: 551
My Ride: 1999 328i
I had the same problem. I had someone stand back and check my brake/turn lights while I was in the car and they said everything worked. so I tried the "bad ground fix", and still no results.

then I realized it was my license plate bulb that went out. all along, that's all it was. so make sure you check that.
__________________
glovesoff is offline   Reply With Quote
Old 07-31-2008, 01:02 PM   #5
umnitza
8774866489
 
umnitza's Avatar
 
Join Date: Aug 2002
Location: East Bay, CA
Posts: 16,655
My Ride: E39M5, Sequoia
Send a message via Yahoo to umnitza
one of the filaments on the bulb could be bad or what Monkey said.
__________________
umnitza is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use