E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-04-2008, 09:50 PM   #1
Blackwidow330CI
Registered User
 
Join Date: Aug 2008
Location: Montreal
Posts: 9
My Ride: 330CI& 2003M3project
Codes p0172 and p0175.running rich...Help please

2001 330CI .codes p0172 and p0175. Could this be the MAF,o2 sensor, OR EVEN a blocked catalytic converter. What I have done do far. Injectors are good, new air filter, plugs good, NEW ELBOW to the TB. Cleaned the ICV valve today, Cleaned the DISA,(air flap in the intake) Cleaned the MAF. Changed the 02 sensor for the 2nd bank(cylindr 4 to 6) The thing is the car runs good.....it lacks power though. Then out of the blue the idle just go's to hell,when this happens i give it gas and it like hesitates like a blocked cat.....BUT then I turn off the car restart it right away and it runs fine....idles around 700. If it was the MAF or 02.....Then why isn't the DME reading faults for those units. Can the DME read a blocked catalytic? I realize that there are 2 02 sensors after the cat! Thanks in advance....
Blackwidow330CI is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-14-2008, 12:35 AM   #2
MikeyV89
Registered User
 
Join Date: Apr 2008
Location: Virginia
Posts: 34
My Ride: 2001 330i
if you have an intake and its an oiled intake filter, then you are getting the maf dirty everytime. also check your OS sensors, as well as a stock bmw, even most modified ones cannot run on fuel MORE then 95 octane, and that shitty octane booster can really fuck up our engines, i have a 2001 330i and ran into similar problems, i even drained my fuel tank. also you might need to have your ecu wiped after you fix it.
__________________
MikeyV89 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 05:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use