E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-08-2008, 12:40 PM   #1
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
Possible Xenon Ignitor Issue

I have this issue with my Xenon Headlight, on the drivers side, where it won't turn on right away, it sometimes takes a while longer to turn on. It'll turn on by itself after a little bit, sometimes a few seconds, sometimes a few minutes. Sometimes if I turn the switch on and off a couple of times, the light will then turn on.

I posted this question on Maxbimmer, and someone suggested that it was the ignitor that needed replacing.

http://www.maxbimmer.com/forums/showthread.php?t=107403

Any thoughts?... Does anyone know a place where I can get an OEM ignitor for my xenon headlight?
Alizay is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-11-2008, 02:19 AM   #2
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
anybody out there?
Alizay is offline   Reply With Quote
Old 08-11-2008, 02:34 AM   #3
paraklas
OEM ///Member
 
paraklas's Avatar
 
Join Date: Jan 2006
Location: Cyprus
Posts: 5,961
My Ride: ESS TS2 320ci
You can check the cheap/free to fix causes first such as the connectors from the car to the ballast for arcing signs, corrosion, not seated properly etc.
__________________
http://www.argyrides.eu/makeyourownsig.jpg
paraklas is offline   Reply With Quote
Old 08-19-2008, 04:12 PM   #4
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
How do Xenon bulbs work anyway... how do u know when they are failing?
__________________


---My Ride---
2003 BMW 330i M-Package (E46)


FOR SALE:
1992 BMW 325i - 4dr, 5spd, (E36) - Asking $2500 obo
(Great for a beater or project car)
LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 08-26-2008, 04:17 PM   #5
hkbruin
Registered User
 
Join Date: Nov 2006
Location: Los Angeles
Posts: 27
My Ride: 2003 E46 4dr
I'm having the same issue, on colder nights it won't start up immediately.. On warm nights, no problem.... Did you find a fix for this?
hkbruin is offline   Reply With Quote
Old 08-26-2008, 04:22 PM   #6
BMWTCU
Registered User
 
Join Date: Aug 2008
Location: Fort Worth
Posts: 11
My Ride: 325i
I have one xenon (passenger side) that actually turned a little purple in color after it warms up. Dealer said since it was changed not too long ago that the color will not adjust until 11,000 hours. Has anyone heard of this?
BMWTCU is offline   Reply With Quote
Old 09-10-2008, 11:46 AM   #7
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
Quote:
Originally Posted by hkbruin View Post
I'm having the same issue, on colder nights it won't start up immediately.. On warm nights, no problem.... Did you find a fix for this?
No I haven't fixed it yet, haven't even swapped the bulbs yet...
__________________


---My Ride---
2003 BMW 330i M-Package (E46)


FOR SALE:
1992 BMW 325i - 4dr, 5spd, (E36) - Asking $2500 obo
(Great for a beater or project car)
LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 09-17-2008, 09:12 AM   #8
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
get this... yesterday, my passenger side would not turn on at all. Same deal today.

The drivers side is still intermittent too, it'll turn on after a bit. I'm thinking, change both bulbs at once, and then change the ballast on the drivers side... what do you guys think?
__________________


---My Ride---
2003 BMW 330i M-Package (E46)


FOR SALE:
1992 BMW 325i - 4dr, 5spd, (E36) - Asking $2500 obo
(Great for a beater or project car)
LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 09-17-2008, 10:22 AM   #9
AlwayzUnce
Registered User
 
Join Date: Aug 2007
Location: Wayne, NJ
Posts: 2,139
My Ride: 128i
Send a message via AIM to AlwayzUnce
having the same problem.... definitely dont want to throw 300 down at the stealership if i dont have to
AlwayzUnce is offline   Reply With Quote
Old 09-17-2008, 11:05 AM   #10
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
I know... tell me about it
__________________


---My Ride---
2003 BMW 330i M-Package (E46)


FOR SALE:
1992 BMW 325i - 4dr, 5spd, (E36) - Asking $2500 obo
(Great for a beater or project car)
LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 09-18-2008, 07:36 PM   #11
q0192837465
Registered User
 
Join Date: Nov 2004
Location: Vancouver
Posts: 1,112
My Ride: 99.4 A4, 03 330xi
Send a message via ICQ to q0192837465
lol, i'm w/ u guys. It's my passenger side that has the problem. Anyone tried to take apart the light see wut happened?
__________________
q0192837465 is offline   Reply With Quote
Old 09-23-2008, 07:45 AM   #12
Alizay
Registered User
 
Join Date: Jul 2008
Location: Toronto
Posts: 42
My Ride: 2003 BMW 330i-M
Update: So the passenger side xenon died on me the other day. Luckily I know a guy in Toronto that has GREAT deals on Xenon bulbs. Dropped in a replacement bulb, ordered a new set, and i'm probably going to grab a ballast from him too.

www.absolutehid.ca if anyone else is interested
__________________


---My Ride---
2003 BMW 330i M-Package (E46)


FOR SALE:
1992 BMW 325i - 4dr, 5spd, (E36) - Asking $2500 obo
(Great for a beater or project car)
LOOKING FOR:
Smoked Tail Lights, Corners and Side Markers for my 2003 BMW 330i

BMW = Bad Man Wagon!!!
Alizay is offline   Reply With Quote
Old 11-26-2008, 04:06 AM   #13
avidan
Registered User
 
Join Date: Aug 2004
Location: Los Angeles
Posts: 88
My Ride: 02 Topaz M3 convert
same issue, no resolution

hey,
just wanted to revive this thread to see if anyone has had resolution on the issue.
i have the same issue. i took it to my local shop (non-dealer), and they replaced more than the bulb (i will double check, but pretty sure they did the whole unit).
i still have the problem of it not turning on right away (if at all).
doing the repetitive on-off once i start the car often solves the issue. and i do think it was less of a problem during the summer.
any updates?
avidan is offline   Reply With Quote
Old 11-26-2008, 09:25 AM   #14
Slick-Vic
Registered User
 
Join Date: Apr 2008
Location: MA
Posts: 1,157
My Ride: 2003 BMW M3 Tiag
I've had this problem for years and the longer I hold off on fixing it the more it happens. In my case the driver side xenon is more likely not to turn on when it is cold/raining out. As far as everyone has stated above I have the same issues sometimes if it takes a few seconds to turn on sometimes it doesn't at all. I pray that for the times it doesnt turn on if I turn the switch on and off multiple times it may turn on.

Worse case senario and I'm sure you guys have been in the same situation before. Driving just as its getting dark but hessitate to turn on your lights cus you don't wana feel cheap if one of your xenons don't turn on lol...

What have you guys done to resolve the issue I ain't gona lie I've been told to switch the bulbs or due other little tests to pin point the problem but honestly haven't tried any yet.

Seems like everyone here has the same issue just wondering what people did to fix the problem what did you replace?
__________________

CF TMS cold air intake/UUC Rasp-x section I/StopTech stage II brake kit slotted rotors, SS brake lines/3 pc. AC Schnitzer rear spoiler/CF rear diffuser/Iforged Aeros 19x8.5x10/Smoked corners/Smoked EE LED tails/Matte Black kidney grills/Matte Black gills/Painted reflectors
Slick-Vic is offline   Reply With Quote
Old 12-11-2008, 01:22 PM   #15
qjudge
Registered User
 
Join Date: Oct 2006
Location: Stillwater, MN
Posts: 4
My Ride: 2002 325xi
I have been having this same issue with my drivers side for about a year now, although it has been very intermittent. My headlight will usually fire when it is warm out (or when it is at the stealership!!!), but not always when it is cold.

I just started moving parts around, until I could follow the problem with a part move.

First, swap the bulbs. (This had no effect on mine, problem stayed on driver's side, proving bulbs are fine.)

Second, swap the ballasts. (This required removal of the headlight assemblies from the car, but it was pretty easy. This also had no effect, so ballasts are not it.)

Lastly, swap the igniters. (This is a PITA, as you need to completely disassemble the headlight assembly and put everything back together, then re-aim the headlights.) The problem followed this swap, as no my passenger headlight doesn't fire right away. I guess I will be replacing the igniter on that side, and hopefully I'll be good to go!
qjudge is offline   Reply With Quote
Old 02-25-2009, 07:46 PM   #16
peleke4
Registered User
 
Join Date: Dec 2002
Location: california
Posts: 77
My Ride: 2003 bmw 330ci
this is the EXACT issue I'm having with my 03' 330CI. I recently posted a thread about this because the passenger side xenon went completely dead for a few days. The funny thing is that it went dead during the storm here in Southern CA. But when the storm passed, that xexon is working again.

went to a shop to resolve the problem. He said that an "element socket" was needed. The part itself costs 220.00. With labor, it'll be about $300.00.

Although the xenon is working fine at the moment, this issue has been going on for the past year. It's a ***** to fix a xenon that's currently working, but I know it's bound to fail again.
peleke4 is offline   Reply With Quote
Old 06-15-2009, 09:45 PM   #17
bmwparamedic
Registered User
 
Join Date: Apr 2006
Location: Fresno, Ca / Providence, RI
Posts: 149
My Ride: E36, E46
Send a message via AIM to bmwparamedic
The ignitor was $220?
__________________
bmwparamedic is offline   Reply With Quote
Old 06-15-2009, 10:13 PM   #18
RaVeON0319
Registered User
 
Join Date: Apr 2009
Location: bay area, cali
Posts: 39
My Ride: 2003 BMW 330i
I'm having the same issue. I got a used ignitor from ebay. $40 with shipping. I'll keep you posted once I finally get time to install. till then...
RaVeON0319 is offline   Reply With Quote
Old 06-17-2009, 02:35 PM   #19
peleke4
Registered User
 
Join Date: Dec 2002
Location: california
Posts: 77
My Ride: 2003 bmw 330ci
just to give you an update, i never even got the job that the shop recommended done. Personally, i felt they were shady, because I searched and searched for resources online about "element socket" resolving the xenon issue but nothing came up anywhere.

this xenon has a mind of it's own by the way. it's been working fine since i've posted about this some time ago. based on my experiences and what others have said, it seems possible that weather conditions play a factor in this off/on xenon issue.
peleke4 is offline   Reply With Quote
Old 06-28-2009, 12:48 AM   #20
RaVeON0319
Registered User
 
Join Date: Apr 2009
Location: bay area, cali
Posts: 39
My Ride: 2003 BMW 330i
Well update on my issue. Well I got the ignitor and installed it to find out that it wasn't it. So next thing would be the ignitor. But since I meesed with it and put the stock one back on it hasn't failed. I noticed though that my automatic headlight adjuster isn't moving its full range like my other side. Sucks!
RaVeON0319 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use