E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-23-2008, 06:00 PM   #1
ou330ci
Registered User
 
Join Date: Sep 2008
Location: Oklahoma
Posts: 54
My Ride: 330ci
car is driving me crazy!

alright so about 2 months ago my car started stalling and idling rough so i took it to the dealer and they told me i had a cracked intake boot and bad cam sensor and thremostat was stuck open. so while i was replacing these i noticed my alternator was well on its way to going bad so i went ahead an replaced that also. the next day after fixing everything my starter goes out. so after all of this the car drives good for about two weeks..then the cars idle gets worse than ever and while driving it misfired so bad it would barely move. so i babied it home and had the codes pulled and it said lean bank 1 and 2 along with cam sensor and O2 sensor heater problem. but i got to looking at it and saw that my intake boot came off at the throttle body and i fixed it and cleaned MAF and replaced air filter. it drove good for a day then when driving around the city it started idling bad again and would barely move... it seems to do it more after the engine heats up. i checked the boot again and it didnt fall off again so now im stuck on what could be doing this? anyone have any ideas?
ou330ci is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-23-2008, 09:13 PM   #2
reynaldo
Registered User
 
Join Date: Sep 2006
Location: Overseas
Posts: 989
My Ride: 2001 325i Sedan
Send a message via Yahoo to reynaldo
I have the same code. Bank 2 (code E4) I believed is oxygen sensor adaptation limit Cyl 4-6. I will replace my plugs, ignition coil and boots. Will keep you posted if the Code E4 will vanish.
reynaldo is offline   Reply With Quote
Old 11-23-2008, 10:00 PM   #3
ou330ci
Registered User
 
Join Date: Sep 2008
Location: Oklahoma
Posts: 54
My Ride: 330ci
let me know if that solves the problem. i have read about people having this same code but most people just have rough idle. once my car gets hot it will barely move because its misfiring so bad so i have no clue what the problem could be
ou330ci is offline   Reply With Quote
Old 11-23-2008, 10:38 PM   #4
prznskillz
Registered User
 
Join Date: Nov 2007
Location: Los Angeles/CSUN
Posts: 439
My Ride: 2001 JetBlack 330ci
Send a message via AIM to prznskillz
i had a similar problem turned out to be my ccv/ oil seperator...01 330ci
prznskillz is offline   Reply With Quote
Old 11-24-2008, 11:17 AM   #5
ou330ci
Registered User
 
Join Date: Sep 2008
Location: Oklahoma
Posts: 54
My Ride: 330ci
bump
ou330ci is offline   Reply With Quote
Reply

Tags
boot, maf

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use