E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 02-09-2013, 03:55 PM   #21
ggirl3608
Registered User
 
Join Date: Feb 2013
Location: Dothan
Posts: 1
My Ride: 325Ci
Yeppie!

Thanks to all of you who posted on how to fix my top! I did it and am sooooo proud it now works great!!!!!
ggirl3608 is offline   Reply With Quote
Old 02-12-2013, 07:02 AM   #22
tmwtf
Registered User
 
Join Date: Jun 2012
Location: Chapin, SC
Posts: 2
My Ride: 2001 325CI
Glad you fixed your top!

Unfortunately, my problem was that the top motor in the windshield area had a broken gear and both automatic clamping devices that secure the top down were cracked. But $1800.00 later it is working well (that sucks). What a terrible design by bmw to make the clamping devices out of plastic that breaks down. The clamps were made from a different material in 2005 because of all the complaints. Good luck!!
tmwtf is offline   Reply With Quote
Old 02-12-2013, 12:36 PM   #23
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 1,620
My Ride: 2003.5 M3
I have a 2003 and mine are metal, never been fixed.
taylor192 is offline   Reply With Quote
Old 04-04-2013, 03:53 PM   #24
grubbab
Registered User
 
Join Date: Apr 2013
Location: usa
Posts: 1
My Ride: 330ci convertible
Quote:
Originally Posted by StanJR View Post
Hello to all,
I recently purchased a windscreen for my wifes 2004 325Ci. When I installed it I didnt have the tabs, that go under the rear top flap, properly alligned. When the top flap went to close, I heard a two clicking sounds and the system quit working. It met some resistance. I was receiving a flashing red light on the top "down" control button and the trunk would not open electronically.
I put the top back up manually and took the vehicle to an after market BMW mechanic, since the warranty just expired 3 months ago! The mechanic acted as though he could repair it and when I went to pick it up, he still had no idea what was wrong.
Long story short is I have diagnosed the problem as being the Top Flap Drive Unit located under the rear seat of the vehicle. If I push down on the top of this unit and operate the top, it works like a champ. This also cleared the light and allowed the trunk to operate properly.
I am told that the plastic top to this unit holds the gearing in place and when it meets resistance, the plastic breaks and the gearing pops out. Of course I have been unable to find the plastic piece and I just bought the entire drive motor from BMW (part # 51-25-8-248-308) for $261. I want to make this a DIY project but I wanted to check with the members to know if this is possible or if there is resynchronization that needs to take place, etc.
Your input is much appreciated.
Thanks.
I had the same problem after trying to open my E46 top with a carboard box on it that got jammed in the mechanism. The hydraulic motor would not run. I could move the top manually and it would latch in the up position, but I could only latch and unlatch the "flap" (the part that encloses the top when it is in the down position) with the supplied allen wrench. I could hear clicking sounds from the flap lock mechanism beneath the rear seat. I took the mechanism part way out, (see youtube for removing rear seat-very easy) and removed the motor from beneath the mechanism. The cause of the problem was a PAL nut that had come off the main drive gear, causing the gear to lift and jump past the mating gear. Took 5 minutes to reattach (using my hands and 2 sockets as a press).

To my surprise, I put the top up manually and pressed the "top up" button. Once it latched the flap properly, the top worked fine. I don't think there is a reset procedure like the E36 has. Seems more like all the sensors have to indicate that everything is its place, or the control module won't let the process continue.
Attached Thumbnails
Click image for larger version

Name:	flap drive top noted.jpg
Views:	346
Size:	224.2 KB
ID:	498778  
grubbab is offline   Reply With Quote
Old 07-09-2013, 01:45 PM   #25
comova
Registered User
 
Join Date: Apr 2007
Location: City of Angels
Posts: 213
My Ride: Silver 325Cic
Can someone up a picture, I'm trying to disgnose my top and would love to check this plastic gear issue. I closed my top with "stuff" sticking out the window and busted mine.
__________________


"The problem with the designated driver program, it's not a desirable job, but if you ever get sucked into doing it, have fun with it. At the end of the night, drop them off at the wrong house." -Jeff Foxworthy
comova is offline   Reply With Quote
Old 07-10-2013, 03:26 PM   #26
comova
Registered User
 
Join Date: Apr 2007
Location: City of Angels
Posts: 213
My Ride: Silver 325Cic
Just checked mine (took back seat out and found it under the plastic cover) and the gear is fine. Any other suggestions?
__________________


"The problem with the designated driver program, it's not a desirable job, but if you ever get sucked into doing it, have fun with it. At the end of the night, drop them off at the wrong house." -Jeff Foxworthy
comova is offline   Reply With Quote
Old 07-10-2013, 03:35 PM   #27
SuperSleeper
Registered User
 
Join Date: Jul 2006
Location: California
Posts: 417
My Ride: 2003 330CIC
do you hear it whining and spinning?
any noises at all?
__________________
SuperSleeper
SuperSleeper is offline   Reply With Quote
Old 07-10-2013, 03:48 PM   #28
comova
Registered User
 
Join Date: Apr 2007
Location: City of Angels
Posts: 213
My Ride: Silver 325Cic
I just hear clicking when I let the (down) button go. I also tried to loosen by hand the (visor) latches.
__________________


"The problem with the designated driver program, it's not a desirable job, but if you ever get sucked into doing it, have fun with it. At the end of the night, drop them off at the wrong house." -Jeff Foxworthy
comova is offline   Reply With Quote
Old 07-10-2013, 03:55 PM   #29
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 1,620
My Ride: 2003.5 M3
Quote:
Originally Posted by comova View Post
I just hear clicking when I let the (down) button go. I also tried to loosen by hand the (visor) latches.
You'll have to describe your problem in far more detail to get good help. Start your own thread, list exactly the steps you take, what the roof does during those steps, and where the noises are coming from.

Also describe how you broke the top and what it did when it broke.
__________________
taylor192 is offline   Reply With Quote
Old 07-10-2013, 04:15 PM   #30
comova
Registered User
 
Join Date: Apr 2007
Location: City of Angels
Posts: 213
My Ride: Silver 325Cic
Will do, mate. Cheers!
__________________


"The problem with the designated driver program, it's not a desirable job, but if you ever get sucked into doing it, have fun with it. At the end of the night, drop them off at the wrong house." -Jeff Foxworthy
comova is offline   Reply With Quote
Old 07-10-2013, 05:18 PM   #31
SuperSleeper
Registered User
 
Join Date: Jul 2006
Location: California
Posts: 417
My Ride: 2003 330CIC
video would be ideal.
__________________
SuperSleeper
SuperSleeper is offline   Reply With Quote
Old 07-10-2013, 06:01 PM   #32
comova
Registered User
 
Join Date: Apr 2007
Location: City of Angels
Posts: 213
My Ride: Silver 325Cic
Per Taylor's suggestion, I started a thread. No video yet.
http://forum.e46fanatics.com/showthread.php?p=15561164
__________________


"The problem with the designated driver program, it's not a desirable job, but if you ever get sucked into doing it, have fun with it. At the end of the night, drop them off at the wrong house." -Jeff Foxworthy
comova is offline   Reply With Quote
Old 08-06-2013, 08:33 AM   #33
iamydnew
Registered User
 
Join Date: Aug 2013
Location: delaware
Posts: 1
My Ride: 2001 bmw 330ic
2001 330ic
My instrument panel lights have been flashing on and off and my turn signals work but the green arrows on panel do not light up. I disconnected the battery for 2hrs. and reconnected them. Everything worked fine for 2 miles. I put my top


down and then could not get it back up. I followed directions in manual-removed center seat panel, found allen wrench and release button and tried to unlock the convertible compartment to start the manual process of pulling tip up by hand. Nothing happened. The Compartment did not open. 53 yr. old/young woman who does not accept defeat easily. Mechanic told me the codes (before l put top down) were indicating that two of the 20 computer modules showed up being faulty. Didn't know which of the two were causing the electrical pRoblems. Now the radio is coming up as disabled and top won't Come back up. HELP! ! First tHings first. Any help on manually putting top up? The car runs fine. Just whacky electrical symbols not working
iamydnew is offline   Reply With Quote
Old 08-06-2013, 10:23 AM   #34
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 1,620
My Ride: 2003.5 M3
Quote:
Originally Posted by iamydnew View Post
2001 330ic
My instrument panel lights have been flashing on and off and my turn signals work but the green arrows on panel do not light up. I disconnected the battery for 2hrs. and reconnected them. Everything worked fine for 2 miles. I put my top


down and then could not get it back up. I followed directions in manual-removed center seat panel, found allen wrench and release button and tried to unlock the convertible compartment to start the manual process of pulling tip up by hand. Nothing happened. The Compartment did not open. 53 yr. old/young woman who does not accept defeat easily. Mechanic told me the codes (before l put top down) were indicating that two of the 20 computer modules showed up being faulty. Didn't know which of the two were causing the electrical pRoblems. Now the radio is coming up as disabled and top won't Come back up. HELP! ! First tHings first. Any help on manually putting top up? The car runs fine. Just whacky electrical symbols not working
Remove the rear seat (pull!) and remove the plastic cover at the bottom of the motor to check where the cables are, they need to be in this position for the locks to release. I bet you're not turning the motor enough cause it feels like you're going to break something.



If the cables are in the correct position then maybe one of them snapped. Yet without any tension on the cables the locks should disengage as the lid is lifted.

The rest of the issues sound like you need a new battery.
__________________

Last edited by taylor192; 08-06-2013 at 10:23 AM.
taylor192 is offline   Reply With Quote
Old 08-06-2013, 10:31 PM   #35
SuperSleeper
Registered User
 
Join Date: Jul 2006
Location: California
Posts: 417
My Ride: 2003 330CIC
Quote:
Originally Posted by handypfb View Post
Wow! I'm glad I found this site (by accident). I have been on Bimmerfest since 2010 but could not get an answer for my top.
My 2004 330ci top also won't go down. But. At first the windows would go partially down when the down button is pressed (normal). Red light on steady, but nothing else happened. No sounds other than the engine in idle, but hard to hear if there were "clicking" sounds (electrical solenoids?).
I drove for about 20 min, put car in garage with trickle charge. Next day tried again. This time only the red light on steady with button depressed BUT the windows did NOT move from their full up position.
On Bimmerfest forum a suggestion that the battery may be weak (it is 4+ years), but with the engine running could that affect the top operation?
I prefer to have the engine running when I put my top down to save battery power, but for me, it doesn't matter so much since I have solar battery toppers mounted on the top cover. In other words, it doesn't hurt anything, its actually less stress on the battery.
__________________
SuperSleeper
SuperSleeper is offline   Reply With Quote
Old 08-06-2013, 11:21 PM   #36
rondo
Registered User
 
Join Date: Aug 2006
Location: St. Petersburg, FL
Posts: 87
My Ride: 2001 330cic helrot
Quote:
Originally Posted by SuperSleeper View Post
I prefer to have the engine running when I put my top down to save battery power, but for me, it doesn't matter so much since I have solar battery toppers mounted on the top cover. In other words, it doesn't hurt anything, its actually less stress on the battery.
Hi can you please post pictures of your solar panel install?
rondo is offline   Reply With Quote
Old 08-06-2013, 11:24 PM   #37
SuperSleeper
Registered User
 
Join Date: Jul 2006
Location: California
Posts: 417
My Ride: 2003 330CIC
Quote:
Originally Posted by rondo View Post
Hi can you please post pictures of your solar panel install?
Yup, I'll do it tomorrow when there's better lighting. The key is aligning the panels to get the most amount of sun while still working with the hardtop install and the wires not interfering with the mechanics.
__________________
SuperSleeper
SuperSleeper is offline   Reply With Quote
Old 08-08-2013, 12:31 AM   #38
Nickvjr
Registered User
 
Join Date: Nov 2011
Location: Prescott, AZ
Posts: 239
My Ride: 2004 330Ci Conv.
E46 Convertible Top Problems - Help

Interested in solar panel battery toppers! Sub'd!


Sent from BimmerApp mobile app
__________________
-Nickvjr
2004 BMW 330Ci Convertible
Nickvjr is offline   Reply With Quote
Old 08-08-2013, 09:28 PM   #39
SuperSleeper
Registered User
 
Join Date: Jul 2006
Location: California
Posts: 417
My Ride: 2003 330CIC
Quote:
Originally Posted by Nickvjr View Post
Interested in solar panel battery toppers! Sub'd!
Here you are:

Solar Topper DIY
__________________
SuperSleeper
SuperSleeper is offline   Reply With Quote
Old 10-11-2013, 08:22 PM   #40
swckuo
Registered User
 
Join Date: Oct 2013
Location: San Francisco
Posts: 1
My Ride: 2005 M3 Convertible
So I used the hose clamp fix and it worked for a while, but recently stopped working. The gears are popping and sound like they're stripping again. Even if I lean on the cover pretty hard, it still skips 50% of the time. I finally got it closed and I'm worried that there's something else wrong that's causing so much torque that it's popping the gear.

Is there any other maintenance that needs to be done to the mechanical parts of the convertible top?
swckuo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use