E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Thread Tools Search this Thread Rate Thread Display Modes
Old 06-30-2015, 05:05 AM   #1
Gunner 62
Registered User
Join Date: Jun 2015
Location: Ireland
Posts: 1
My Ride: 1999 318i e46
New member

Hi everyone, Just want to introduce myself to you all. I'm a complete novice when it comes to internet forums of any sort, only watched but never took part. I've looked at this site on many occasions but now that I've acquired an e46 with some, hopefully minor problems, I thought it high time to join up. So I'm a new recruit.

My main problem with this car - early 1999 318i with just over 104000 miles - is that shortly after start up it chugs a little when driving. Speed will be restricted (revs won't go beyond 2 - 2500 rpm. Shortly thereafter power is restored and she will drive pretty smoothly. However even when engine is good and warm car is prone to chug especially when looking for a little bit of power - disconcerting when attempting to pass out in traffic. Some time back I changed plugs etc. Could this be something as simple as fuel filter being clogged (I have not changed it since I got it a 94000 miles.

Any help / suggestions very welcome.

Cheerio for now
Gunner 62 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-04-2015, 04:40 AM   #2
Zero. Leaks.
Solidjake's Avatar
Join Date: May 2008
Location: NYC
Posts: 26,612
My Ride: '02 330i 6MT
Welcome! If the fuel filter has not been replaced then yes I would change it (Mahle or Kayser are the brands you must get). The problem does seem like it can be fuel related. I moved this thread into the General E46 section for more help from the guys.
Solidjake is online now   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON

All times are GMT -5. The time now is 01:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use