E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-25-2009, 08:16 AM   #21
xavi330i
Registered User
 
Join Date: Oct 2006
Location: Tampa, Florida
Posts: 2,958
My Ride: 2004 330i smg
Cool you fixed it.

I had a similar issue. A couple years ago, I noticed my brake lights would not come on until I press the brake pedal a couple inches. An adjustment was all that was needed on the brake switch.
__________________
xavi330i is offline   Reply With Quote
Old 03-25-2009, 10:56 AM   #22
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
Yeah but sucks that I had to dish out all the money just to figure out what it was. Next time I'll be smarter.

Good thing I didnt get in an accident due to my brake lights not working!
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 08-02-2009, 06:01 AM   #23
Xelo
Registered User
 
Join Date: Sep 2006
Location: Romania
Posts: 27
My Ride: '01 E46 320i
Hello,

Could you please describe the "adjustment" procedure for the switch ? From what I've seen, it's a plastic carrier for some wires and the end of it it's designed to touch a little arm coming out of the brake pedal.

The switch is now "pushed" all the way to the end (towards front of car) and I still have the brake light warning on the dash. Do I have to pull it a little to the back of the car or how do you suppose to adjust it ?

Thanks.
Attached Thumbnails
Click image for larger version

Name:	design.JPG
Views:	209
Size:	15.0 KB
ID:	325873  
Xelo is offline   Reply With Quote
Old 08-02-2009, 08:49 AM   #24
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
wait, what exactly is the warning? Does it say "BRAKE" or does it show a brake pad? Then you probably need new brake pads.
The switch is just for lighting the lights in the back, and for disabling the cruise control.
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 08-02-2009, 12:40 PM   #25
Xelo
Registered User
 
Join Date: Sep 2006
Location: Romania
Posts: 27
My Ride: '01 E46 320i
Yes, I am talking about the warning for tail lights. It's on - bulbs are fine, contacts are fine, did the double ground mode, warning's still there so it must be the switch.
Xelo is offline   Reply With Quote
Old 08-02-2009, 02:26 PM   #26
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
Are you using stock lights/bulbs, or those aftermarket LED drop-ins... because the aftermarket LED tails (some people call them eagle eyes i think) cause the "bulb is out" warning in the dash.
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 08-02-2009, 03:24 PM   #27
Xelo
Registered User
 
Join Date: Sep 2006
Location: Romania
Posts: 27
My Ride: '01 E46 320i
No... everything is stock.

There is no other cause for the warning (i've read every little bit of info on the net, tried every possible solution), I just wanna know how did you guys managed to adjust the switch, according to the posts above.
Xelo is offline   Reply With Quote
Old 08-02-2009, 04:21 PM   #28
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
kinda hard to explain..... its really easy though. you just pull/push on the blue part in your pic.
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 06-04-2011, 03:19 PM   #29
styllzs
Registered User
 
Join Date: Aug 2004
Location: new york city
Posts: 3
My Ride: 330 i
my brakes lightss dont come on at all could it be that switch?
styllzs is offline   Reply With Quote
Old 11-12-2012, 01:01 PM   #30
limpiabota809
Registered User
 
Join Date: Oct 2012
Location: NYC
Posts: 1,181
My Ride: 330 XI
just had that same problem this morning someone broke pretty hard in front of me forcing me to press the brake pedal harder than usual, I felt the switch get pushed in when i broke hard and moments later the light indicating that the switch was messed up turned on, i got to work googled this thread and just moved the switch back in the correct placeand viola we are back to normal

PS (called a couple BMW dealers near me before attempting the adjustment quoted 50$ + tax)
limpiabota809 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use