E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-22-2009, 11:06 PM   #1
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
MAF codes

I'm throwing a code now that i broke the plastic grill off by MAF and i think i may have banged up the sensor up while i was at it. now it's throwing a standard MAF code saying it's faulty. and it also says like Bank 2 is running lean?

the car runs fine, no issues. but now i've got the SES light on which is just ANNOYING. should i try to clean it up or just replace the ****ing thing?

big deal to ride around for a week or two like this?


i was an idiot and forgot to pick up the paper with the exact codes on it from my parents house, so tomorrow i'll hit my mom up and she'll read them off to me to have. my pops has a code reader so that's the only reason i KNOW it's the MAF and like i said i did beat up the MAF today
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-24-2009, 07:40 AM   #2
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
sweet guys sweet.
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 03-24-2009, 10:19 AM   #3
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
holy fuck, i just contacted the dealer they're trying to tell me that MAF is fucking $5xx.00 that is absurd.

i foudn one on pelican Parts but the thing is going to real OEM and putting in my vin it says my car was produced in 7/2003.

now that would mean i would need this MAF,
http://www.pelicanparts.com/cgi-bin/...30Xi%2C%20Each

however looking at my car it seems i have this one: based on the piece i broke off my car it looks like this one:
http://www.pelicanparts.com/cgi-bin/...-00)%2C%20Each

what in the fuck, which one should i get?

this is part of my MAF:


somebody help a brother out?

what should i do?







Edit: The MAF on the car does not have any label or part number on it?.. wtf
__________________
Yeah, YOU RIGHT

Last edited by titog; 03-24-2009 at 10:39 AM.
titog is offline   Reply With Quote
Old 03-24-2009, 12:12 PM   #4
Snik
OEM ///Member
 
Snik's Avatar
 
Join Date: Dec 2007
Location: Around SJ AFB, NC
Posts: 20,686
My Ride: IR M3 Vert.
you may need a MAF then, simple, they aint cheap, get with Colin about that local euro junkyard, otherwise, click my sig make a call.

you know what, reset it and see if it comes back.
__________________
Quote:
Originally Posted by rohde88 View Post
^^^ do you spend all your free time on two wheels?
______________________________________
The Snikster posted sexy wiminz here
Do you ride a sportbike?
Do you have a question about Jamaica? Ask?
Snik is offline   Reply With Quote
Old 03-24-2009, 12:58 PM   #5
dmcalister
Registered User
 
Join Date: Aug 2008
Location: hampton
Posts: 450
My Ride: 2003 M3 SMG
yeah i think we might make that junk run sooner then i thought.. i can make a few calls for you also. im going to dp motor works tonight and i will talk to them to see what they say and ill post my response here!
__________________
dmcalister is offline   Reply With Quote
Old 03-24-2009, 01:07 PM   #6
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
Quote:
Originally Posted by snikwad View Post
you may need a MAF then, simple, they aint cheap, get with Colin about that local euro junkyard, otherwise, click my sig make a call.

you know what, reset it and see if it comes back.
did reset it. came back. codes are below.

Quote:
Originally Posted by dmcalister View Post
yeah i think we might make that junk run sooner then i thought.. i can make a few calls for you also. im going to dp motor works tonight and i will talk to them to see what they say and ill post my response here!
sweet thanks.

got my mom to read me off the codes i had written down and left at their house:

P0 102 MAF or VAF Circuit low input
P0 174 System too lean bank 2
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 03-24-2009, 02:55 PM   #7
dmcalister
Registered User
 
Join Date: Aug 2008
Location: hampton
Posts: 450
My Ride: 2003 M3 SMG
what do you drive again btw?
__________________
dmcalister is offline   Reply With Quote
Old 03-24-2009, 09:51 PM   #8
///TRNSPRTR
Registered User
 
Join Date: May 2007
Location: KS
Posts: 801
My Ride: 07 Tundra, 02 M3
I talked to a "contact" who is very knowledgable, and he said the exact same thing Ron posted. If push comes to shove I suggest contacting Desert Motor Works as well. Also he said you may have a hole in your lower intake boot as well (very common). I have one in mine, (however not throwing a code) so check that out when you get a chance. I'm assuming it's very cheap and simple to fix, because I ordered the part for about $12 and found a nice write up.
__________________
My Olympic Weightlifting Blog.

Chalkednation.wordpress.com
https://www.facebook.com/chalkednation
///TRNSPRTR is offline   Reply With Quote
Old 03-24-2009, 10:29 PM   #9
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
Quote:
Originally Posted by dmcalister View Post
what do you drive again btw?
2003 ZHP 330i
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 03-24-2009, 10:50 PM   #10
Snik
OEM ///Member
 
Snik's Avatar
 
Join Date: Dec 2007
Location: Around SJ AFB, NC
Posts: 20,686
My Ride: IR M3 Vert.
theres a used on on ebay. atleast i think its used
__________________
Quote:
Originally Posted by rohde88 View Post
^^^ do you spend all your free time on two wheels?
______________________________________
The Snikster posted sexy wiminz here
Do you ride a sportbike?
Do you have a question about Jamaica? Ask?
Snik is offline   Reply With Quote
Old 03-24-2009, 11:05 PM   #11
330i ZHP
Registered User
 
330i ZHP's Avatar
 
Join Date: Mar 2005
Location: Washington, DC
Posts: 21,769
My Ride: have 5 doors and FI
Send a message via AIM to 330i ZHP Send a message via Yahoo to 330i ZHP
I have one I can sell you for 250
__________________
/_________\
OO=[][]=OO
330i ZHP is offline   Reply With Quote
Old 03-24-2009, 11:05 PM   #12
330i ZHP
Registered User
 
330i ZHP's Avatar
 
Join Date: Mar 2005
Location: Washington, DC
Posts: 21,769
My Ride: have 5 doors and FI
Send a message via AIM to 330i ZHP Send a message via Yahoo to 330i ZHP
although check to see if the unit is getting a good ground
__________________
/_________\
OO=[][]=OO
330i ZHP is offline   Reply With Quote
Old 03-25-2009, 02:38 PM   #13
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
ordering a new MAF today.
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 03-26-2009, 09:26 AM   #14
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
now it's only throwing p0102 no more p0174

new MAF is in the mail...
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 04-02-2009, 01:18 PM   #15
titog
Registered User
 
Join Date: Nov 2008
Location: Fist City
Posts: 287
My Ride: 03 ZHP
Update: new MAF is in. that was the issue. cleared codes- no new codes. looking at the two MAF's the "hot-film" strips were missing on my broken one
__________________
Yeah, YOU RIGHT
titog is offline   Reply With Quote
Old 04-02-2009, 02:37 PM   #16
///TRNSPRTR
Registered User
 
Join Date: May 2007
Location: KS
Posts: 801
My Ride: 07 Tundra, 02 M3
Sucks you had to fix, but glad you did on the first try.
__________________
My Olympic Weightlifting Blog.

Chalkednation.wordpress.com
https://www.facebook.com/chalkednation
///TRNSPRTR is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use