E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Xi Forum

E46 Xi Forum
The E46 XI was produced from 01-05 in sedan and touring body styles. Powered by either a 2.5L inline 6 in the 325xi or a 3.0L inline 6 330xi. Discuss all thing about BMW AWD E46 'Xi' here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-08-2015, 05:01 PM   #1
TheERacer
Registered User
 
Join Date: Feb 2015
Location: Boyertown, PA
Posts: 19
My Ride: 04 325xi
Weird Q- DSC lamp

Ok, so I believe I can be considered the king of weird issues. And yeah, I bought a BMW, so apparently, I'm a closet masochist...

Car is 2004 325xi.

On my way home, I decided to press-and-hold the DSC button. I have noticed that the DSC activates at sort-of random times, under conditions that I'd consider "normal" driving. That's an issue for later though.

So I pushed it and held. Lamp came on. After about 7-8 sec of holding, the lamp went out. I let go. I pushed it once, no light. Pushed again, no light. Pushed and held, no light. I wa to close to home to determine if the system was actually still active. Pulled in the driveway, pushed button a few more times, no lamp. Shut car off. Turned key to position 2, no lamp. Off, on again with key, no lamp. With key still on, hit button several times, no lamp.

Came in and searched the forums to find out if it was a replaceable bulb that might've burned out. Apparently, it's an LED... Read tons of info (I love this forum), no similar issues that I saw.

Went back out to the car, turned the key on to p2, light came on briefly, light it should. Hmmm. Turned off and back on, no light that time. Off and on again, no light. Turned key off and did the dash-diag-dance. DSC light lit up correctly. Turned key off. Repeated. Still good. Started car, hit DSC button, light came on as it should.

If you're still with me, here's a few questions:
Can someone tell me if they turn the key to p2, then off, then back to p2, does their DSC light come on the second (or subsequent) time?
Should I be worried?
Has anyone else experienced this?
Does anyone know what happened?

I have not tried to repeat the scenario, due in part to fear that I might actually screw something up for real. It pains me to not test it to try to repeat the condition, but I just can't do it yet...

Thanks in advance for any help.
__________________
Matt Green

2004 325xi- Love the car, hate the previous owner...

"It is my ultimate fear that someday my wife will sell all of my stuff for what I *told* her I paid for it."
TheERacer is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-08-2015, 09:13 PM   #2
My325XI
Registered User
 
Join Date: Dec 2007
Location: Charlotte, NC
Posts: 903
My Ride: 03 325XI Sprt Prem
This thread may help you...
http://forum.e46fanatics.com/showthr...&highlight=dsc
__________________

2003 325XI 5-speed ZSP ZPP
My325XI is offline   Reply With Quote
Old 05-08-2015, 10:08 PM   #3
TheERacer
Registered User
 
Join Date: Feb 2015
Location: Boyertown, PA
Posts: 19
My Ride: 04 325xi
Yep, read that one the other day. It said holding it down would do nothing, but hey, most of us would try it anyway, right?

It's the weird light-not-staying-on thing that had me spooked...
__________________
Matt Green

2004 325xi- Love the car, hate the previous owner...

"It is my ultimate fear that someday my wife will sell all of my stuff for what I *told* her I paid for it."
TheERacer is offline   Reply With Quote
Old 05-09-2015, 08:52 AM   #4
My325XI
Registered User
 
Join Date: Dec 2007
Location: Charlotte, NC
Posts: 903
My Ride: 03 325XI Sprt Prem
I dont know.. maybe it's a wheel sensor issue or something then.
__________________

2003 325XI 5-speed ZSP ZPP
My325XI is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use