E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-11-2009, 11:13 PM   #21
mhagley323
Registered User
 
Join Date: Aug 2008
Location: Charlotte, NC
Posts: 607
My Ride: 330i
Quote:
Originally Posted by Acarder View Post
Change the oil like twice in the next 3000 miles and drive like you stole it. You'll be good as gold after that (as much as it sounds like it, i'm not being sarcastic here. 6000RPM+ per journey to clean out the gunk and crap thats probably in there from the last owner).
Quote:
Originally Posted by Kingnog View Post
That doesn't sound (to me) like a very good idea. I don't see how running the engine at high RPMs will "clean" it, it just sounds like it will wear it out.
he's right. its good to push the car every now and then. Though i drive like i stole it all the time
__________________

03' 330i
Mods
|M Tech II|P46| Orion V2|Painted Rear Diffuser and Moldings|Clears|Painted Grills|Koni FSD|Eibach|M6|WeissLicht LED|

09' ///M5
Mods
|BMW Performance Gloss Grills, Gills and Reflectors|SuperSprint|RPI|WeissLicht LED|
mhagley323 is offline   Reply With Quote
Old 04-12-2009, 12:59 AM   #22
daveupshaw
Registered User
 
Join Date: Mar 2009
Location: Kelowna, BC, Canada
Posts: 47
My Ride: 2000 323i
the previous owner basically only drove it on the highway and the car had been sitting all winter when i bought it, so im still kinda breakin it it after a long sit i guess, it feels better all the time.. so i agree with you guys on pushing it hard every once in a while.

i love this car so much.. its hard not to drive it like i stole it. thanks for all your help guys
daveupshaw is offline   Reply With Quote
Old 04-12-2009, 04:32 AM   #23
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
Quote:
Originally Posted by daveupshaw View Post
Mine is not an automatic, and i just had my transmission oil checked and it is good/pretty new, all of the parts stores and the bmw dealer are closed today because of easter weekend.... so just took some duct tape and fixed the hole in the hose for a few days..i dont see any harm in doing that. as soon as i did this it does not do it anymore, plus the extremly anoying high pitch squeeling noise from the engine is now gone so i guess this hole was causing this as well. when the parts stores reopen after the weekend i will replace the part.


o and the image that didnt work was just a picture of the part from the oem bmw parts website, it was under mass air flow or somthing, and it was number 5.. thats just where my hole was, it is quite big and obvious to see...

cheers
I had the same problem. replced the intake and all seems fine. Except i had CEL for misfires
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 04-12-2009, 04:44 AM   #24
M3_GTR
Registered User
 
Join Date: Jan 2007
Location: western suburbs
Posts: 5,710
My Ride: hates driveways
I get that in my auto, once i give it all the time its unbelievably sluggish, mines an auto.
Imagine im in first, give it all the way, slowly crawl till about 5,500rpm and then it'll like go stupid, struggle and not go past 5,500rpm, until i let off abit, wtf is wrong with it?
__________________


FOR SALE!
M3_GTR is offline   Reply With Quote
Old 04-12-2009, 05:02 AM   #25
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
Quote:
Originally Posted by M3_GTR View Post
I get that in my auto, once i give it all the time its unbelievably sluggish, mines an auto.
Imagine im in first, give it all the way, slowly crawl till about 5,500rpm and then it'll like go stupid, struggle and not go past 5,500rpm, until i let off abit, wtf is wrong with it?
well how many miles?
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 04-12-2009, 06:05 AM   #26
M3_GTR
Registered User
 
Join Date: Jan 2007
Location: western suburbs
Posts: 5,710
My Ride: hates driveways
its got 150,000kms
__________________


FOR SALE!
M3_GTR is offline   Reply With Quote
Old 04-12-2009, 12:20 PM   #27
DBear
Registered User
 
Join Date: Mar 2009
Location: Santa Cruz CA
Posts: 212
My Ride: 2001 325i w/SportsPk
Quote:
Originally Posted by daveupshaw View Post
no its not the clutch, i fixed the problem, i changed the hose with the hole and its all good... im not sure when it was last changed tho i have only had the car about a month
You also might consider cleaning your ICV. It tends to get coked up with engine deposits and a good cleaning of that, the throttle body, and intake butterfly with CRC Throttle Body cleaner should also help alleviate any rough idling issues.
DBear is offline   Reply With Quote
Old 04-12-2009, 02:38 PM   #28
daveupshaw
Registered User
 
Join Date: Mar 2009
Location: Kelowna, BC, Canada
Posts: 47
My Ride: 2000 323i
havent changed the hose yet, just temporarilly fixed it.... and today my check engine light came on. would this set it off ?? is there a way to find out why my check engine light came on (sorry it this is a stupid question)
daveupshaw is offline   Reply With Quote
Old 04-12-2009, 07:18 PM   #29
daveupshaw
Registered User
 
Join Date: Mar 2009
Location: Kelowna, BC, Canada
Posts: 47
My Ride: 2000 323i
Angry

.............so now apperently my engine is deciding to shake and i have very little power, way worse than before, and its now loud and i am very pissed off and confused. then i turn off the engine and turn it back on and it stops shaking!!! what the @%^$ is going on!!?!? i

i guess i will just have to take it in and have someone look at it
daveupshaw is offline   Reply With Quote
Old 04-12-2009, 07:44 PM   #30
inlinesicks
Registered User
 
Join Date: Nov 2008
Location: Phoenix, AZ
Posts: 1,142
My Ride: E46, Jeep, Subaru
Quote:
Originally Posted by Acarder View Post
Change the oil like twice in the next 3000 miles and drive like you stole it. You'll be good as gold after that (as much as it sounds like it, i'm not being sarcastic here. 6000RPM+ per journey to clean out the gunk and crap thats probably in there from the last owner).
Its true, revving the sh*t out of the car with new clean fully warm oil is probably the best way to clean your engine, I've had alot of cars and I've always driven them very hard, full throttle all the way to redline at least a few times a day, and I have still never once had any kind of engine failure or damage and they have always stayed spotless inside, and were all running perfect when sold at 190k, 150k, 285k, 130k, and I still have my jeep at about 230k
__________________
inlinesicks is offline   Reply With Quote
Old 04-12-2009, 09:02 PM   #31
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
Quote:
Originally Posted by daveupshaw View Post
.............so now apperently my engine is deciding to shake and i have very little power, way worse than before, and its now loud and i am very pissed off and confused. then i turn off the engine and turn it back on and it stops shaking!!! what the @%^$ is going on!!?!? i

i guess i will just have to take it in and have someone look at it
Get the car scanned for free first... autozone or somewhere similar.

Quote:
Originally Posted by inlinesicks View Post
Its true, revving the sh*t out of the car with new clean fully warm oil is probably the best way to clean your engine, I've had alot of cars and I've always driven them very hard, full throttle all the way to redline at least a few times a day, and I have still never once had any kind of engine failure or damage and they have always stayed spotless inside, and were all running perfect when sold at 190k, 150k, 285k, 130k, and I still have my jeep at about 230k
key phrase here: fully warm!!
but yeah, i agree.... its good to take the car out like that once in awhile.

Quote:
Originally Posted by M3_GTR View Post
its got 150,000kms
damn man, i actually had an idea why your car might be doing that, but i forgot it... sorry. any check engine lights? have you done your VANOS? (but vanos is usually lower rpm problem)
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 04-12-2009, 10:35 PM   #32
daveupshaw
Registered User
 
Join Date: Mar 2009
Location: Kelowna, BC, Canada
Posts: 47
My Ride: 2000 323i
i live in canada so there is no autozone here, does anyone know of any place that checks codes for free in canada??
daveupshaw is offline   Reply With Quote
Old 04-13-2009, 02:49 AM   #33
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
hmm, try NAPA?
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 04-13-2009, 03:31 AM   #34
sprintman
Registered User
 
Join Date: Mar 2008
Location: Canberra, ACT, Australia
Posts: 3,926
My Ride: Ex 325CI owner
The only way to properly clean the internals is 1 1/2 bottles of Auto-Rx (fantastic U.S patented product) in oil that has no ester or PAO component) run for 3,500 miles (5,500kms) with a clean filter, follwed by an oil/filter change with a similar ester/PAO free oil. Ring seal improvement is just one of many benefites as well as seal rejuvenation, VANOS seals included. Personalky I, and many worldwide, think this is the greatest product available in the automotive industry, even more amazing when it wasn't invented for the automotive industry in the first place. PM me if interested....s
sprintman is offline   Reply With Quote
Reply

Tags
acceleration, engine light, no power, shaking engine, slow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use