E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-10-2008, 04:30 PM   #1
iDriftYou
Registered User
 
Join Date: Apr 2008
Location: UCR/SoCal
Posts: 785
My Ride: is a HighWay monster
Cleaned ICV, now car feels slughish?

Well, my 2001 325i had some recent work done, and after the work was done like:
-Spark Plugs
-Valve cover gasket
- Coolant hoses
-Oil filter housing gasket
Now the car used to stall instantly upon start up sometimes. This only happened when the engine was at operating temperature, never at cold start ups. Today, someone recommended me to clean the ICV out and see what happens, so I followed the DIY and the car started up. Went for a test drive and after I shut the engine off, restarted the car stalled while moving! Just instantly dead. I barely got home. Im really bummed now. I just spent 1k on the previous replacements and now this happens? And on the way home, the car felt really sluggish, it would take forever to hit 65 mph. Any ideas on it can be? Any help will be greatly appreciated. O btw, the car only stalls when its at operating temperature, cold starts are normal.
__________________
-Shehroz


Current: 1990 Toyota Supra
Mods: CP pistons/ Eagle rods/ HKS MHG/ 264 Cams/ Rebuilt CT26
Future: GT35r
My DIY:
DIY ZF 5HP19 Transmission Drain/ Refill : http://forum.e46fanatics.com/showthr...12#post9551712


"My life doesn't only move in a straight line, why should my car?"
iDriftYou is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-10-2008, 04:36 PM   #2
iDriftYou
Registered User
 
Join Date: Apr 2008
Location: UCR/SoCal
Posts: 785
My Ride: is a HighWay monster
anyone
__________________
-Shehroz


Current: 1990 Toyota Supra
Mods: CP pistons/ Eagle rods/ HKS MHG/ 264 Cams/ Rebuilt CT26
Future: GT35r
My DIY:
DIY ZF 5HP19 Transmission Drain/ Refill : http://forum.e46fanatics.com/showthr...12#post9551712


"My life doesn't only move in a straight line, why should my car?"
iDriftYou is offline   Reply With Quote
Old 11-10-2008, 05:30 PM   #3
iDriftYou
Registered User
 
Join Date: Apr 2008
Location: UCR/SoCal
Posts: 785
My Ride: is a HighWay monster
bump...come on guys?
__________________
-Shehroz


Current: 1990 Toyota Supra
Mods: CP pistons/ Eagle rods/ HKS MHG/ 264 Cams/ Rebuilt CT26
Future: GT35r
My DIY:
DIY ZF 5HP19 Transmission Drain/ Refill : http://forum.e46fanatics.com/showthr...12#post9551712


"My life doesn't only move in a straight line, why should my car?"
iDriftYou is offline   Reply With Quote
Old 05-28-2009, 11:45 PM   #4
-RedLine-
Registered User
 
Join Date: Nov 2007
Location: calgary
Posts: 49
My Ride: 02 bmw 325ci sport
I have the same problem i cleaned my MAF and my ICV today and the car seems really sluggish, but at idle it seems to run better.
Car is 325Ci with recently installed Dinan S1 software- which made the car feel a lot peppier and now it seems like it's not even installed.
__________________
-RedLine- is offline   Reply With Quote
Old 05-29-2009, 12:05 AM   #5
Lbert
Registered User
 
Join Date: Oct 2006
Location: Richardson, TX
Posts: 220
My Ride: 325i
Recheck your electrical connectors and see if all the clamps and bolts were properly thightened. Remove the spark plugs and see if any of the plugs are fouled up.
Lbert is offline   Reply With Quote
Old 05-29-2009, 12:26 AM   #6
Phoenix330ci
Registered User
 
Join Date: May 2009
Location: Phoenix
Posts: 542
My Ride: 04 330Ci Convertible
No codes?
Phoenix330ci is offline   Reply With Quote
Old 05-29-2009, 08:46 PM   #7
-RedLine-
Registered User
 
Join Date: Nov 2007
Location: calgary
Posts: 49
My Ride: 02 bmw 325ci sport
I got it guys. I feel kinda dumb for saying (i was really excited to hear the improvements) but the air box clamp wasn't tight all the way, lol. I tightened it up and it purrs like a kitty! I wouldn't say it was anything drastic like saying the car feels more powerful but it feels more responsive and claimer through low rpm's, and idle doesn't fluctuate anymore!! Just bought some new Bosch coils to replace the damned Bremi garbage and we're golden!.

Thanks guys.
__________________
-RedLine- is offline   Reply With Quote
Old 05-29-2009, 08:48 PM   #8
smolck
Registered User
 
Join Date: Dec 2007
Location: Birmngham, AL
Posts: 1,059
My Ride: 2004 ZHP Sedan
OP, when I cleaned my ICV I had to rev it to redline a few times while in neutral to "clean out" some accumulated solvent. It blew out a few puffs of smoke and then all was well.
smolck is offline   Reply With Quote
Old 05-29-2009, 08:50 PM   #9
//TRD power
Registered User
 
Join Date: Jun 2008
Location: Zero Maintenanceville
Posts: 2,561
My Ride: 3.0 | 200hp | 214trq
disconnect the battery too so the car adapts to driving style & then let her rip
__________________
//TRD power is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use