E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 10 votes, 4.50 average. Display Modes
Old 08-12-2013, 03:23 PM   #221
M3/805
Registered User
 
Join Date: Jul 2013
Location: Cali
Posts: 9
My Ride: 2003-M3
Quote:
Originally Posted by Moosecakes View Post
Just change your relay I threw the same code. But the car drove perfectly fine. If you get the light or drop gears then do the mod, my car will get pissed at 80* if I'm driving in town for a good while. I did my resistor mod and no issues so far!

Here's a quick pic of the mod.



Obviously shrink wrap it when you're done, I did just didn't get any pics..
wanna do that to my M3,can I buy the resistor at radio shack?
or frys???
M3/805 is offline   Reply With Quote
Old 08-14-2013, 04:12 PM   #222
M3/805
Registered User
 
Join Date: Jul 2013
Location: Cali
Posts: 9
My Ride: 2003-M3
Smg

I noticed your doing your resistor mod at the electrical harness in the engine compartment!
Other post are doing it on the bottom of the car by the smg pump!
How do I find this wire on the pic? there is a lot of white wires in there!!
M3/805 is offline   Reply With Quote
Old 08-14-2013, 09:27 PM   #223
Moosecakes
Registered User
 
Join Date: Nov 2010
Location: Oregon
Posts: 836
My Ride: 02' SMG M3
Quote:
Originally Posted by M3/805 View Post
wanna do that to my M3,can I buy the resistor at radio shack?
or frys???
If you were close yea I would for sure, and yes, or if you want i'll donate one to you. Just shoot me a PM with your address. I have like 20 of them lol.

Quote:
Originally Posted by M3/805 View Post
I noticed your doing your resistor mod at the electrical harness in the engine compartment!
Other post are doing it on the bottom of the car by the smg pump!
How do I find this wire on the pic? there is a lot of white wires in there!!
http://www.m3forum.net/m3forum/showt...372262&page=27

post #269 shows how to get to it. This is 10000000x easier to do and you dont need an insulated resistor.
__________________
Moosecakes is offline   Reply With Quote
Old 08-14-2013, 09:28 PM   #224
Moosecakes
Registered User
 
Join Date: Nov 2010
Location: Oregon
Posts: 836
My Ride: 02' SMG M3
I'll post this here too as a reference to what actually happens with this resistor should temps become seriously hot.

Quote:
Originally Posted by Moosecakes View Post
Hey guys just wanted to report back some info. I did the 680ohm mod about 2 weeks ago and have not seen or had any issues since until yesterday when I was stuck in traffic for 2 hours to go 10 miles, got out of 1st once... it was about 91*.

The car held out great right until we were literally 10 seconds from our house lol. Right as I finally got to my exit, my smg light came on, I thought great, it's seriously hot since I have the mod, I made it to the last corner before our house when the car threw me out of gear. I immediately pulled over and let the car sit for about 10 mins. Everything started right up, went into gear but threw an SES light with a cog. No fault codes stored in ECU so I figured it was in conjunction with the cog light letting me know there was a potential problem. AWESOME RIGHT! After 2 more drive cycles the SES light went away and about 30 mins after parking at our place and going back to run out again the COG was gone. Car ran perfectly and no issues.

I 100% recommend the 680ohm resistor as you can see it makes the car happy, but when it gets seriously pissed off the car takes action and saves itself. I'm very pleased that it works like this.

The original 3.3k would have let my pump torch itself inside out for sure. So if you haven't changed yours to a 680 DO IT!

Hope this adds a bit of info for everyone.
From M3F DIY thread.
__________________
Moosecakes is offline   Reply With Quote
Old 09-21-2013, 08:17 PM   #225
tonystuart
Registered User
 
Join Date: Jul 2013
Location: Colorado Springs
Posts: 1
My Ride: 04 m3 conv smg
First time on here...Bought an 04 M3 SMG with 58000 in May. Now at 70000 the pump failed while in Denver. Keeps blowing the 40 amp fuse in front of famed salmon relay. Dealer wants over 3900 to fix. Towing to B and M transmission in Colorado Springs...Any advice from anyone in the area is appreciated. tonyd351@hotmail.com
tonystuart is offline   Reply With Quote
Old 01-24-2014, 01:44 AM   #226
stylus1133
Registered User
 
Join Date: Jan 2014
Location: Marina del Rey
Posts: 1
My Ride: 2005 E46 M3
First time on here. Just bought a 2005 M3 SMG with 62,000 in December. 3 days ago, the SMG light came on in the morning shortly after I started the car. It drove/shifted fine, and I dropped it off at some indy shop near my work. The shop reset the light, drove it around, and the light did not come back on. The next morning, the light came back on shortly after I started the car again. This time, I took it to South Bay BMW, and they told me that I need the relay replaced as well as the pump replaced and quoted me $4,800. First of all, this seems much higher than some of the other dealer quotes in this thread. Has anyone gotten a quote from another SoCal BMW dealer recently for a pump replacement? Since I didn't observe any issues at all with the SMG dropping out of gear, not going into gear, etc, I asked my SA why the mechanic recommended the pump be replaced. He checked with the mechanic, and he gave some bs excuse that the relay must be receiving bad codes from the pump which caused it to burn out, so the best solution was to replace both the pump and relay. I'm sorry, but I'm not going to drop almost $5K because the pump "might" be broken. To make a long story short, I told them to just replace the relay, and I'll monitor to see if I notice any changes in the way the SMG shifts and if the light comes back on again. If it does, I'll probably bring it to a local indy shop and have them work on the car. Does anyone have any recommendations in the Venice/Culver City area? I'll update once I get the car back from the dealer.
stylus1133 is offline   Reply With Quote
Old 01-26-2014, 12:26 PM   #227
Westrace
Registered User
 
Join Date: May 2012
Location: SoCal
Posts: 178
My Ride: 06 G35, 04 M3 Coupe
Quote:
Originally Posted by stylus1133 View Post
First time on here. Just bought a 2005 M3 SMG with 62,000 in December. 3 days ago, the SMG light came on in the morning shortly after I started the car. It drove/shifted fine, and I dropped it off at some indy shop near my work. The shop reset the light, drove it around, and the light did not come back on. The next morning, the light came back on shortly after I started the car again. This time, I took it to South Bay BMW, and they told me that I need the relay replaced as well as the pump replaced and quoted me $4,800. First of all, this seems much higher than some of the other dealer quotes in this thread. Has anyone gotten a quote from another SoCal BMW dealer recently for a pump replacement? Since I didn't observe any issues at all with the SMG dropping out of gear, not going into gear, etc, I asked my SA why the mechanic recommended the pump be replaced. He checked with the mechanic, and he gave some bs excuse that the relay must be receiving bad codes from the pump which caused it to burn out, so the best solution was to replace both the pump and relay. I'm sorry, but I'm not going to drop almost $5K because the pump "might" be broken. To make a long story short, I told them to just replace the relay, and I'll monitor to see if I notice any changes in the way the SMG shifts and if the light comes back on again. If it does, I'll probably bring it to a local indy shop and have them work on the car. Does anyone have any recommendations in the Venice/Culver City area? I'll update once I get the car back from the dealer.
A brand new pump is around 2K from Tischer. An independent shop can probably do it for around 700 - 1K.
Westrace is offline   Reply With Quote
Old 02-16-2014, 06:30 AM   #228
bmw glen
Registered User
 
Join Date: Feb 2014
Location: dixon ca.
Posts: 4
My Ride: 2006 m3
almost died, SMG TRANSMISSION problems

I bought a 2006 M3 with a SMG transmission and loved the way it drove. I was on a 60 mile trip when the netural light started blinking. I shifted the car back into the auto mode and the light stoped blinking and registered in sixed gear. I was going about 70mph on the freeway and took the exit which comes up to a red light.

I was not paying attention to the car shifting down in gears when I came up to the light. I was not driving the car all that hard but was coming up to the red light expecting the car to stop. when applying the brakes the car was not stoping as expected and the high performance engine was still strongly pushing the car toward the intersection.

I was able to make a quick right turn to prevent going into the oncoming traffic. I was unable to restart the car and it remains locked in six gear. I towed the car into the dealer and they quoted me 12 thousand dollars to replace the transmission.

I live in California and was wondering if their is some sort of State safety board that reviews dangerious safety issues like this? Does BMW have some kind of recall?

After driving and having this hapen I am scared to drive this car again and glad I am still alive. Does anyone have ideas on what is the best course of action and what you would do.
bmw glen is offline   Reply With Quote
Old 02-16-2014, 06:39 AM   #229
bmw glen
Registered User
 
Join Date: Feb 2014
Location: dixon ca.
Posts: 4
My Ride: 2006 m3
almost died M3 with SMG

For the person that is wanting to buy one of these cars and asking about the mileage I have 38 thousand miles on my M3 and I think at 70 thousand the car is just about shot ready to breakdown soon. if your lucky it might be a 4 thousand dollar pump only but you might also be getting a death trap and have to replace the transmission so have it really checked out and you still never know.
bmw glen is offline   Reply With Quote
Old 02-16-2014, 09:29 PM   #230
LifterPuller
Registered User
 
Join Date: Feb 2014
Location: Los Angeles
Posts: 1
My Ride: E46 M3
If anyone is looking into fixing these pumps and finding out what goes wrong with them, shoot me a PM. I have one in my garage that I just replaced.
LifterPuller is offline   Reply With Quote
Old 03-02-2014, 06:10 PM   #231
xsxpxhx
Registered User
 
Join Date: Feb 2008
Location: Los Angeles, CA
Posts: 254
My Ride: 2002 M3
Does anyone know of any other symptoms it could be besides a pump failure. I just bought my pump and 14,000 miles alter it gives out?. I missed the 2 year part warranty by 1 month. Could it also be that it needs to be reprogrammed? This sucks man. Im starting to hate BMW
xsxpxhx is offline   Reply With Quote
Old 03-03-2014, 09:35 PM   #232
xsxpxhx
Registered User
 
Join Date: Feb 2008
Location: Los Angeles, CA
Posts: 254
My Ride: 2002 M3
i got my car back and the problem was low SMG fluid
xsxpxhx is offline   Reply With Quote
Old 03-04-2014, 04:32 PM   #233
xsxpxhx
Registered User
 
Join Date: Feb 2008
Location: Los Angeles, CA
Posts: 254
My Ride: 2002 M3
well my SES light came on again. going to get ti checked out today.
xsxpxhx is offline   Reply With Quote
Old 04-11-2014, 03:33 AM   #234
iansevilla
Registered User
 
Join Date: Mar 2014
Location: San Diego
Posts: 341
My Ride: 2004 M3 Coupe
I got mine two weeks ago. Car acted up after 4 hrs. Gear box light turned on and stuck in R. So I wiggled the salmon relay and was able to start and made it home. Replaced relay and all is good after 3 days. It's shifts to neutral while driving then gear box light comes on again. Will take it to the dealer tomorrow!


Sent from BimmerApp mobile app
iansevilla is offline   Reply With Quote
Old 04-11-2014, 10:26 PM   #235
iansevilla
Registered User
 
Join Date: Mar 2014
Location: San Diego
Posts: 341
My Ride: 2004 M3 Coupe
Dealer can't figure out problem with SMG....lol... But, scared me when he said that if it is a clutch problem. It will cost me $6,000....they are still waiting for engineers to solve problem...this is my car.Click image for larger version

Name:	ImageUploadedByBimmerApp1397273203.886778.jpg
Views:	97
Size:	155.7 KB
ID:	553620


Sent from BimmerApp mobile app
iansevilla is offline   Reply With Quote
Old 04-11-2014, 11:15 PM   #236
dcastillo809
Registered User
 
Join Date: Apr 2014
Posts: 6
Check your gear positioning sensor did it on mine now im good


Sent from BimmerApp mobile app
dcastillo809 is offline   Reply With Quote
Old 04-12-2014, 05:33 AM   #237
turbo_f22_pilot
Registered User
 
Join Date: Dec 2009
Location: Mid-Atlantic Region
Posts: 1,193
My Ride: 2 pedals - 2 paddles
Quote:
Originally Posted by iansevilla View Post
Dealer can't figure out problem with SMG....lol... But, scared me when he said that if it is a clutch problem. It will cost me $6,000....they are still waiting for engineers to solve problem...this is my car.Attachment 553620


Sent from BimmerApp mobile app
What is the problem? What are the codes?
__________________
In order to finish FIRST, you MUST first FINISH !

Joy is future proof
Get your "M" on . . .
Reading is FundaM3ntal




CAR:
2003 TIAG Coupe / Blk Interior / SMG / HK Premium
MODS:
EU-CSL Coded / Macht Schnell intake / OEM CSL Wheels / OEM CSL Diffuser / Dinan Exhaust
Full LED Conversion / HID fog / Aurora AE / RE RTAB FCAB

BMWCCA NCC
turbo_f22_pilot is offline   Reply With Quote
Old 04-24-2014, 10:51 PM   #238
M KASL
Registered User
 
Join Date: Apr 2014
Location: Tallahassee FL
Posts: 1
My Ride: 2004 M3 Coupe
Quote:
Originally Posted by stylus1133 View Post
First time on here. Just bought a 2005 M3 SMG with 62,000 in December. 3 days ago, the SMG light came on in the morning shortly after I started the car. It drove/shifted fine, and I dropped it off at some indy shop near my work. The shop reset the light, drove it around, and the light did not come back on. The next morning, the light came back on shortly after I started the car again. This time, I took it to South Bay BMW, and they told me that I need the relay replaced as well as the pump replaced and quoted me $4,800. First of all, this seems much higher than some of the other dealer quotes in this thread. Has anyone gotten a quote from another SoCal BMW dealer recently for a pump replacement? Since I didn't observe any issues at all with the SMG dropping out of gear, not going into gear, etc, I asked my SA why the mechanic recommended the pump be replaced. He checked with the mechanic, and he gave some bs excuse that the relay must be receiving bad codes from the pump which caused it to burn out, so the best solution was to replace both the pump and relay. I'm sorry, but I'm not going to drop almost $5K because the pump "might" be broken. To make a long story short, I told them to just replace the relay, and I'll monitor to see if I notice any changes in the way the SMG shifts and if the light comes back on again. If it does, I'll probably bring it to a local indy shop and have them work on the car. Does anyone have any recommendations in the Venice/Culver City area? I'll update once I get the car back from the dealer.

I have had my 04 M3 Coupe for just over a year now and put 20000 miles on it i am currently at 88000 miles and my pump has worked completely fine except for one little issue that has existed for all 20000 miles that I put on it. When ever I turn on the engine and let the car sit with the engine running for any longer then about 5 min without driving it the yellow cog will come on and stay on even if i put the car in gear and drive it. If I cut the engine wait a second and then light the engine back up its gone and the car is completely back to normal. I have driven long distances after the cog turned on and felt nothing different and seen no issues. I took the car to enthusiast auto in cincy and had them look into it, they did all the the preemptive measures changed out the relay and then tested it and could not get the cog to come on when letting the car sit. I figured it was all good and about a thousand miles later if i let the car sit after turning over the engine it would show me the cog again. I have put about 14 thousand miles on the car since the cog started showing up, when left in idle, again. In that time I have had zero issues, the car feels no different then it always has and still occasionally bothers me with the cog light, but nothing has changed with the car and it still runs great. I don't know if this is similar to the issue you have but if its just the light then I think we are in the same boat.
M KASL is offline   Reply With Quote
Old 04-25-2014, 02:36 AM   #239
iansevilla
Registered User
 
Join Date: Mar 2014
Location: San Diego
Posts: 341
My Ride: 2004 M3 Coupe
I got quoted by the dealer to replace smg pump that will cost me $6,200 and $3,100 to replace the compression springs...I hear bullshit...lol this was 1 1/2 week ago. So I took my car to the the place of purchase to be fixed. It's been one week and still waiting...shop said tech is out sick till Friday. But chief mech. Said he will get it fix. :-) I hope soon?


Sent from BimmerApp mobile app
iansevilla is offline   Reply With Quote
Old 05-01-2014, 05:28 PM   #240
iansevilla
Registered User
 
Join Date: Mar 2014
Location: San Diego
Posts: 341
My Ride: 2004 M3 Coupe
Can't wait to swap from SMG to Manual....


Sent from BimmerApp mobile app
iansevilla is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use