E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-04-2013, 01:51 AM   #1
e30to36to46
Registered User
 
Join Date: Aug 2006
Location: san diego
Posts: 19
My Ride: e46 touring e36m3
parking brake and dsc do not light up on cluster

This seems to be the opposite of what everyone else is experiencing. My ebrake and dsc lights do not illuminate at all, not upon start up or pressing the dsc button nothing....car is a 200 323 touring manual tranny.

So far I have checked the switch under the ebrake boot and looks ok. Checked fuses related to dsc, seemed ok. Checked wiring in back of the DSC button looked intact.

Any other suggestions?
e30to36to46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-04-2013, 04:02 AM   #2
paraklas
Registered User
 
Join Date: Jan 2006
Location: Cyprus
Posts: 5,925
My Ride: ESS TS2 320ci
do cluster check function, see if they light or not
__________________
http://www.argyrides.eu/makeyourownsig.jpg

Last edited by paraklas; 12-04-2013 at 04:02 AM.
paraklas is offline   Reply With Quote
Old 12-11-2013, 01:22 AM   #3
sh00th00ps
Registered User
 
Join Date: Sep 2009
Location: Nor-Cal
Posts: 215
My Ride: 2005 BMW 330i
previous owner could have taped over it behind the cluster? maybe try this to test
__________________
sh00th00ps is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use