E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-13-2009, 09:46 PM   #1
tmb 02
Registered User
 
Join Date: Jun 2006
Location: rockford, il
Posts: 27
My Ride: 02 330i, 06 gto
steering wheel volume control not working

just picked up a 04 325xi with factory nav... and for some reason the volume doesn't work on the steering wheel, but the the station control does!?

any ideas?

is this something that can be re programmed?

im gonna pull it apart and see if a wire got split or cut.. but wasnt sure if i could save some time and have someone here know exactly whats wrong..

thanks in advance
tmb 02 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-14-2009, 11:19 AM   #2
tmb 02
Registered User
 
Join Date: Jun 2006
Location: rockford, il
Posts: 27
My Ride: 02 330i, 06 gto
anybody with ideas?
tmb 02 is offline   Reply With Quote
Old 10-14-2009, 12:01 PM   #3
E46330iguy
Registered User
 
Join Date: Sep 2009
Location: Canada,SK
Posts: 2,411
My Ride: Supercharged 330i
This Means Your Car is at the end of its line sell and get a new one
__________________
Winter Authority When Hell freezes over,we'll play Hockey there too



you've Met a terrible fate haven't you ?


KONI /Michelin/Stoptec/Borla/ Bimmerbrake / MTechII/AA Stage one (for now) Automatic--->5 speed swap/ UUC High performance clutch kit

Questions about Header wrap? clickHere
Supercharger build thread click Here
E46330iguy is offline   Reply With Quote
Old 10-14-2009, 08:30 PM   #4
tmb 02
Registered User
 
Join Date: Jun 2006
Location: rockford, il
Posts: 27
My Ride: 02 330i, 06 gto
not the advice i was looking for, but ill think about it..
tmb 02 is offline   Reply With Quote
Old 09-06-2013, 08:33 PM   #5
330Xeye
Registered User
 
Join Date: Jul 2013
Location: Northeast U.S.
Posts: 36
My Ride: 2004 330Ci
Pardon me for bumping a thread from back in 2009, but out of all the posts that I found using the search feature this is the only post that pertains to exactly what I'm dealing with. Since the OP never got an answer I figured that the topic is still open for discussion.

I bought my '04 330Ci from a BMW dealership a few weeks ago. The PO had replaced the factory stereo with a very annoying, ill-fitting Alpine unit that had an inoperable CD player and obnoxious blue lights all over it. Part of our sales agreement included replacing the Alpine stereo with a factory unit. Today was the day that the dealership followed through and tightened up some loose ends including the stereo swap. Prior to removing the Alpine, the volume control on the steering wheel worked just fine. Now that the factory unit is in place, the volume control on the steering wheel is no longer functioning. I'd like to think that the service tech checked to make sure it functioned properly and that maybe there's a simple solution to this problem. I'm really hoping to not have to bring the car back to the dealership. So, I'm open to all suggestions as long as they're not smart A$$ remarks similar to E46330iguy's. Thanks in advance!
__________________
2004 330Ci with 6-speed, Premium, Sport and Cold Weather packages, Shark Injector software, Racing Dynamics front and rear strut braces, basic K&N drop-in air filter, aFe Dynamic Air Scoop, and a ZHP leather and aluminum shift knob
330Xeye is offline   Reply With Quote
Old 09-06-2013, 10:11 PM   #6
Cazz
Registered User
 
Join Date: Apr 2008
Location: Denver, CO
Posts: 486
My Ride: 2005 BMW M3
Quote:
Originally Posted by 330Xeye View Post

Prior to removing the Alpine, the volume control on the steering wheel worked just fine. Now that the factory unit is in place, the volume control on the steering wheel is no longer functioning. I'd like to think that the service tech checked to make sure it functioned properly and that maybe there's a simple solution to this problem. I'm really hoping to not have to bring the car back to the dealership.
You are probably going to take it back.

The things I can think of are:

- When the new radio was installed the ibus connector wasn't hooked up.
- When the alpine radio was put in an adapter box was put in and it is intercepting the radio commands

Last edited by Cazz; 09-06-2013 at 10:27 PM.
Cazz is offline   Reply With Quote
Old 09-06-2013, 10:21 PM   #7
330Xeye
Registered User
 
Join Date: Jul 2013
Location: Northeast U.S.
Posts: 36
My Ride: 2004 330Ci
Thank you, Cazz. I will be bringing it back to let them deal with it.
__________________
2004 330Ci with 6-speed, Premium, Sport and Cold Weather packages, Shark Injector software, Racing Dynamics front and rear strut braces, basic K&N drop-in air filter, aFe Dynamic Air Scoop, and a ZHP leather and aluminum shift knob
330Xeye is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use