E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-26-2009, 11:38 AM   #1
zoidberg
Registered User
 
Join Date: Aug 2007
Location: Michigan.
Posts: 95
My Ride: 02 325ci.
Unhappy Urgent. EML/BRAKE (yellow) faults.

Ok so on the way to my buddies house two lights in the gauge cluster appear. EML and BRAKE (yellow). Immediately i lose power and car drives rough. I pull over and check the brakes for excessive heat and look under the hood for anything noticable. Nothing. So i turn the car off and turn it back on. The lights go away and normal car function is returned.

The on the way back from my buddies it happens agian. I turn the car off and on agian. Then right before i get to my house it happens one more time.

I was reading a bunch of threads with eml problems and everyone says its either a bad throttle body or ICV needs to be clean or some kind of computer error.

I cleaned my ICV about a year ago, but never my throttle body. And if that is the case why does a BRAKE (yellow) light appear.

Can anyone enlightnen me because I have a meeting tommorrow and I need to fix it tonight.
zoidberg is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-26-2009, 02:13 PM   #2
zoidberg
Registered User
 
Join Date: Aug 2007
Location: Michigan.
Posts: 95
My Ride: 02 325ci.
I also forgot to mention that on the third time it happened my CHECK ENGINE LIGHT came on and stays on even if i turn the car on and off.
zoidberg is offline   Reply With Quote
Old 10-27-2009, 09:20 PM   #3
zoidberg
Registered User
 
Join Date: Aug 2007
Location: Michigan.
Posts: 95
My Ride: 02 325ci.
Talking

Well, I sprayed my MAF sensor with some CRC MAF cleaner. Everything works fine now.

Funny how a mass air sensor can indicate a brake failure.

Only in a BMW
zoidberg is offline   Reply With Quote
Old 10-28-2009, 02:38 AM   #4
gsbmw
Registered User
 
Join Date: May 2006
Location: Los Angeles
Posts: 117
My Ride: 2000 323i
Thanks for updating us. I may have a related problem, which I posted about 8-9 hrs ago (thread title starts with "SES EML ABS..."). I'll probably try cleaning the MAF sensor to see if it prevents a repeat of the EML/ABS/lost power symptoms (I don't want to lose so much power in traffic again!), although I didn't get a MAF sensor fault code. Please chime in on my thread if you think our problems are related (or even if you don't).
gsbmw is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use