E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-29-2009, 07:43 PM   #1
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
Bought a replacement MKIV on ebay... It's in Italian

Thankfully, I actually I know how to fix this... But if I didn't I'd have been pissed...

Took some pics, since I found this amusing...

The part # label had been removed from the drive, so I wasn't exactly sure what I was going to get... Popped the drive into my car, and it booted up. first in Italian, then temporarily moved to English. Showing version 4-1/30, Released 03/2004 according to this:
http://www.xoutpost.com/articles/all...ystem-faq.html



Flipped on the Map... Thinks I'm in Rome, ha!





Took out the map DVD. 2004-1 High. Europe.



Decided to update the OS before fixing the language problem. Put my v.32 OS Update CD in and let it run (part # 01590141891). Looks like Italian, Dutch and UK English were installed:



Still in Italian. haaa



But its running the latest MKIV OS at least. 4-1/00.




Breaking out NavCoder, my Reslers serial port-ibus interface, and ancient Win XP laptop to fix the issue:

NavCoder: http://www.siegenthaler.co.nz/NavCoder/index.htm
Reslers: http://www.reslers.de/IBUS/index.html



Adding French and USA English (female):





Voila! Latest version / USA mode.
sna77 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-29-2009, 07:49 PM   #2
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
Worth mentioning...

Even though the Nav unit was in USA mode, the car thought it was in Europe mode... Ways to tell this:

- No "Accept" screen at system boot up
- yards instead of feet
- No "Emergency" option which shows up on the main screen. A nice feature since it shows your GPS coordinates and exact location.

In order to get the car into USA mode, you need to open NavCoder, click "Read System Parameters" (you get a warning to only do this on your own car).

Change the Region to US, and click "Code Nav"

Attached Thumbnails
Click image for larger version

Name:	Capture.JPG
Views:	23342
Size:	86.9 KB
ID:	342871  
sna77 is offline   Reply With Quote
Old 12-29-2009, 07:59 PM   #3
ATF
Registered User
 
Join Date: Mar 2008
Location: Boston, MA
Posts: 436
My Ride: plows snow.
That's pretty slick, nice fix! What else have you tweaked using your IBus connection? I'm a part of the Yahoo group but I never did get around to doing anything with the IBus.
__________________

Nick | BMWCCA 403399 | flickr
ATF is offline   Reply With Quote
Old 12-29-2009, 08:11 PM   #4
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
Quote:
Originally Posted by ATF View Post
That's pretty slick, nice fix! What else have you tweaked using your IBus connection? I'm a part of the Yahoo group but I never did get around to doing anything with the IBus.
I'm part of the ibus group too, but don't have the balls to actually try anything with it.
sna77 is offline   Reply With Quote
Old 12-29-2009, 08:14 PM   #5
Anub!s
Registered User
 
Join Date: Oct 2006
Location: Los Angeles
Posts: 3,804
My Ride: e92M, e46 330ci
Send a message via AIM to Anub!s Send a message via MSN to Anub!s Send a message via Yahoo to Anub!s
this thread is so sexy
__________________
Anub!s is offline   Reply With Quote
Old 12-29-2009, 08:33 PM   #6
sna77
OEM ///Member
 
sna77's Avatar
 
Join Date: Jan 2005
Location: MA
Posts: 7,704
My Ride: BMW
USA-only feature. "Emergency" which shows your exact location.





Haven't figured out how to program this to dial automatically using my Bluetooth ULF. If you have an Assist / BT combo unit, my guess is all this stuff is pre-populated

sna77 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use