E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-01-2010, 06:53 PM   #1
sally325i
Registered User
 
Join Date: Aug 2008
Location: around
Posts: 41
My Ride: 330
overheating all the wayy across the williamsburg bridge...

i was coming from work and my 03 325ci needle was on red started overheating smoking... car shuts off on the bridge.. i open hood my bleedscrew on upper radiator hose had cracked and melted... nd steam was shooting out... i had to get it off the bridge so i started it again nd it started sounding like it was knocking.. kept turning off.. nd smoking then when i got it off bridge i parked it nd it wont start... sucks man day before xmas eve this happened.. my battery is drained to 8volts.. and i towed the car back to my house and even with a jump it cant seem to start. anyone can relate to these problems or heard of this before. because im hoping i dont need to buy a new cylinder head.. i checked my oil its not mixed with coolant . and i dont and didnt have any smoke out the tailpipe. just smell of burnt coolant. if anyone can shed some light on the subject that would be nice
sally325i is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-02-2010, 02:14 AM   #2
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,468
My Ride: A car
Send a message via MSN to bigjae1976
Yup, called expansion tank failure followed by engine failure.

So basically, your needle was on the red and you kept driving with the car running? Should have shut it off and coasted to the side. You probably f'd your block so its time for a brand spanking new $10k BMW engine.
bigjae1976 is offline   Reply With Quote
Old 01-02-2010, 08:35 PM   #3
mrshelley
Registered User
 
Join Date: May 2004
Location: Bethlehem, PA
Posts: 914
My Ride: 2004 330i
Start looking for a salvage yard motor. If it won't start, it's too damaged to repair it vs. getting a salvage motor.
__________________
mrshelley is offline   Reply With Quote
Old 01-02-2010, 10:30 PM   #4
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,468
My Ride: A car
Send a message via MSN to bigjae1976
Quote:
Originally Posted by mrshelley View Post
Start looking for a salvage yard motor. If it won't start, it's too damaged to repair it vs. getting a salvage motor.
would his VANOS unit be good? I could use an extra one.

OP needs to part that engine out.
bigjae1976 is offline   Reply With Quote
Old 01-04-2010, 04:20 AM   #5
chrisnetcom
Registered User
 
Join Date: Aug 2008
Location: USA
Posts: 55
My Ride: 05 330Ci
That engine is GONE GONE GONE. Start looking for a replacement engine or a new car. How many miles? Had you ever done a cooling system overhaul?

Last edited by chrisnetcom; 01-04-2010 at 04:27 AM.
chrisnetcom is offline   Reply With Quote
Old 01-04-2010, 08:35 AM   #6
bigjae1976
Registered User
 
bigjae1976's Avatar
 
Join Date: Dec 2003
Location: Earth
Posts: 11,468
My Ride: A car
Send a message via MSN to bigjae1976
Quote:
Originally Posted by chrisnetcom View Post
That engine is GONE GONE GONE. Start looking for a replacement engine or a new car. How many miles? Had you ever done a cooling system overhaul?
Prob not.
bigjae1976 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 01:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use