E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 01-15-2010, 12:02 AM   #1
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Engines stalls/dies while driving and idle

I really need some help guys and I've searched already only to find many possible solutions, but I don't want to throw parts at it and waste money buying unnecessary parts.

Heres my problem:

while driving my car kinda jerks and a few seconds later the engine dies. Red oil and battery light comes on.

it also dies randomly when idle.

Since the car has 157,000 miles on the original alternator, I decided to replace the alternator but it still have the same problem.

I tested the alternator by disconnecting the battery while the car is running and the engine continues to run normally. That rules out the alternator right?

There's no Check Engine light and no codes on the ODB scanner.

What else can cause the engine to stall and dies while driving?

Camshaft sensors?

Any help is appreciated.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-15-2010, 12:03 AM   #2
biggs325
Registered User
 
Join Date: Feb 2009
Location: cumberland, md, usa
Posts: 417
My Ride: 2004 325ci
sensors
__________________
biggs325 is offline   Reply With Quote
Old 01-15-2010, 09:30 AM   #3
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Quote:
Originally Posted by biggs325 View Post
sensors
any specific sensors I should look into?
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 01-16-2010, 12:59 PM   #4
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
anyone have any ideas? this is my only car, really need to have it running good again.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 01-16-2010, 01:11 PM   #5
Levim9
Registered User
 
Join Date: Sep 2006
Location: Central PA
Posts: 2,030
My Ride: S54 325i
Hmm I have the same problem and I'm at 161,xxx miles. Sometimes at a stop, the rpms jump up and down then it stalls. I usually push in the clutch and rev just a little to keep it from stalling. I want to try seafoam soon, maybe that will smooth the idle

I've been told about the camshaft sensor but I'm not getting any codes from my scanner

*Edit Never stalled while driving, just when I come to a stop (idling)
__________________

Last edited by Levim9; 01-16-2010 at 01:14 PM.
Levim9 is offline   Reply With Quote
Old 03-29-2010, 04:48 PM   #6
Hornswoggler
Registered User
 
Join Date: Apr 2009
Location: Washington, IL
Posts: 112
My Ride: 01 330i, 97 M3
Did you ever find a solution?

I see a whole lot of threads with similar problem, but they are all shooting in the dark. People are trying everything from MAF, coils, ICV, DISA, O2 sensors, etc. but hard to pinpoint exact cause and effect. Keep us posted if you solve!
Hornswoggler is offline   Reply With Quote
Old 03-29-2010, 04:57 PM   #7
Cobra2001
Registered User
 
Join Date: Mar 2010
Location: SoCal
Posts: 16
My Ride: 2003 BMW 325i
Yeah, this may be the same problem I'm having. I decided to post in this thread since it more accurately described my issue and I ended up finding that thread first...

http://forum.e46fanatics.com/showthread.php?t=744465
Cobra2001 is offline   Reply With Quote
Old 03-29-2010, 05:18 PM   #8
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Quote:
Originally Posted by Hornswoggler View Post
Did you ever find a solution?

I see a whole lot of threads with similar problem, but they are all shooting in the dark. People are trying everything from MAF, coils, ICV, DISA, O2 sensors, etc. but hard to pinpoint exact cause and effect. Keep us posted if you solve!
well, for me it was some bad electrical problems. Some of the electrical wires were almost cut in half and barely making contact. One of them was the alarm wires. After my mechanic found and repaired all the bad wires, the car's been driving great. Check the relay box next to the brake reservoir.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 03-29-2010, 05:20 PM   #9
rmower13
Registered User
 
Join Date: Mar 2010
Location: pheonix
Posts: 17
My Ride: 2002 330i
when it dies does the lights, radio and any other elect accesories shut down also?
rmower13 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use