E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-22-2010, 03:49 PM   #1
evileyeray
Registered User
 
Join Date: Apr 2009
Location: SAN JOSE, CA.
Posts: 9
My Ride: 1999 328i
Send a message via Yahoo to evileyeray
Transmission question !!

i have a 1999 328i sedan (e46)

now in the morning when its cold, i warm it up and leave, as im coming to a stop and the transmission is down shifting, it makes a "bang" at every down shift. When it gets to warm up (aprox 2 miles) it doesnt (bang) shift as hard.
any suggestions on what it might be? i have a feeling its my transmission but im hoping its not.....ya know what i mean!!
evileyeray is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-23-2010, 08:22 PM   #2
e46crooser
Registered User
 
Join Date: Jul 2009
Location: Brentwood, CA
Posts: 63
My Ride: 99 328 5spd
If the CEL is not on, then I would check to see if you have any transmission leaks. If you have leaks it would be logical that your low on fluid. How many miles on the car? If you have over 100k miles, I would have the transmission serviced. HTH Phil
e46crooser is offline   Reply With Quote
Old 01-23-2010, 11:16 PM   #3
evileyeray
Registered User
 
Join Date: Apr 2009
Location: SAN JOSE, CA.
Posts: 9
My Ride: 1999 328i
Send a message via Yahoo to evileyeray
I have 160k. I just had the trani fluid changed 6 mo ago. I did have an oil pan leak which I just had fixed. I will wait and see if anything changes
evileyeray is offline   Reply With Quote
Old 01-26-2010, 02:24 AM   #4
Bimmerbaz
Registered User
 
Join Date: Jan 2010
Location: New Zealand
Posts: 17
My Ride: E46 328i
Might want to check what type of trans is in there. Some of them had a problem with the software and oil type can make a difference.
Bimmerbaz is offline   Reply With Quote
Old 01-26-2010, 04:03 AM   #5
ASSAIL
Registered User
 
Join Date: Jul 2007
Location: Melb, Australia
Posts: 1,941
My Ride: E46 328, Jza80 Supra
sounds like a valve body problem bud.
__________________
ASSAIL is offline   Reply With Quote
Old 01-29-2010, 01:15 PM   #6
evileyeray
Registered User
 
Join Date: Apr 2009
Location: SAN JOSE, CA.
Posts: 9
My Ride: 1999 328i
Send a message via Yahoo to evileyeray
thanks ASSAIL, i had a feeling it was gonna be that... no way around this !
evileyeray is offline   Reply With Quote
Old 06-29-2010, 02:38 AM   #7
maxi
Registered User
 
Join Date: Apr 2006
Location: Qatif -Awamiah
Posts: 362
My Ride: BMW E46 328I, 1999
if not softwear, it's valve body.
__________________
http://forum.e46fanatics.com/signaturepics/sigpic64570_1.gif
maxi is offline   Reply With Quote
Old 06-29-2010, 03:29 AM   #8
evileyeray
Registered User
 
Join Date: Apr 2009
Location: SAN JOSE, CA.
Posts: 9
My Ride: 1999 328i
Send a message via Yahoo to evileyeray
Quote:
Originally Posted by maxi View Post
if not softwear, it's valve body.
Would you happen to know what it would cost me if it is the valve body??
evileyeray is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 05:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use