E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-27-2010, 06:42 PM   #1
spyder
Registered User
 
Join Date: Oct 2003
Location: NYC
Posts: 1,163
My Ride: S54 Sedan, IB 328i
Send a message via AIM to spyder
DSC Module failure? Help please!

Few months ago I got a flat tire passenger side front and now my DSC light is always on. I thought I might have messed up the speed sensor so i was waiting for warmer weather so i can change it myself. After struggling to get my car in and out of parking during all the snow storms we had now my ABS light is always on. I took the car to my indy shop to find out the cause and was told i need to replace the DSC Module unit and it cost around 800 dollars.

I'm hoping they are wrong, I would hate to replace this only to have the same problem. My question is if the module did fail shouldn't the BRAKE light be always on as well? I would appreciate any input on this issue. My car is a 328i with 75k miles on it, Thanks.
spyder is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-27-2010, 07:50 PM   #2
canaryM
Registered User
 
Join Date: Jan 2007
Location: NY, NY
Posts: 676
My Ride: is strong like bull
Doesn't sound right to me. Have you searched around to see if anyone else experienced something similar?
__________________

///Sport Package | Nav | Park Distance Control | LED tails
///M3 Lip spoiler | Adaptive Xenons | 62 LED Angel Eyes
canaryM is offline   Reply With Quote
Old 03-27-2010, 08:00 PM   #3
spyder
Registered User
 
Join Date: Oct 2003
Location: NYC
Posts: 1,163
My Ride: S54 Sedan, IB 328i
Send a message via AIM to spyder
Quote:
Originally Posted by canaryM View Post
Doesn't sound right to me. Have you searched around to see if anyone else experienced something similar?
Yeah i looked around, it seems people with DSC module failure also have the BRAKE light also on and some experience problems with their speedometer.
spyder is offline   Reply With Quote
Old 03-27-2010, 09:49 PM   #4
Andy2108
Registered User
 
Join Date: Nov 2009
Location: U.S.A.
Posts: 8,039
My Ride: E46 M3, '67 Cobra
Did you check and see if it was throwing any codes?
__________________


De gustibus non est disputandum.
Andy2108 is offline   Reply With Quote
Old 03-27-2010, 10:00 PM   #5
DBLAZE
Registered User
 
Join Date: Mar 2007
Location: North & South Jersey!
Posts: 2,357
My Ride: is Fern Green!
Send a message via AIM to DBLAZE
My DSC light was on one time after getting a flat in one of my rear tires. Took it to the dealer and it ended up being the Steering wheel angle sensor. Replaced for approximately $400 total...
__________________

BMW E63 (Jet Black w/Chateau Red Interior, Sport Pkg, Cold Pkg, Nav, Logic 7)
-20" Status 931 Staggered Wheels (Black Lip)
-Continental ExtremeContact DWS XL Tires
-AC Schnitzer Pedals/Footrest
-Lumma Roof Spoiler (Painted)
-50% Smoke Window Tint
-5W Kaibird LED Angel Eyes
-Black Vinyl Corner Overlays
-K&N Air Filter
Fern Green 323ci - SOLD
DBLAZE is offline   Reply With Quote
Old 03-27-2010, 10:07 PM   #6
jorg323
Registered User
 
Join Date: Feb 2008
Location: NOVA/Washington D.C.
Posts: 881
My Ride: 1999 323i
Man, this problem seems to be showing up a lot lately. Short answer is, it could be one or a combination of MANY things. The most recent post I've come across with good info is this:

http://forum.e46fanatics.com/showthr...976&highlight=

but do some searching and you'll probably get your answer. If your module is busted (one of the worst-case scenarios), there are some services that can try and repair it for you for much less than buying a new one from the dealer (Module Masters, BBA-Reman, AutoECU)
__________________


18" Black ASA AR1 Rims | Yokohama Advan S4 Tires | Bilstein Sport Shocks | Eibach Pro-Kit Springs | Brembo Slotted Rotors | 6000k Xenons | 6000k P. Chrom. Angel Eyes | Eagle Eye LED Tail Lights | K&N FIPK CAI | M-Tech II Front Bumper | 35% Tint | Clear Corners | Matte Black Grille
jorg323 is offline   Reply With Quote
Old 03-28-2010, 03:20 PM   #7
spyder
Registered User
 
Join Date: Oct 2003
Location: NYC
Posts: 1,163
My Ride: S54 Sedan, IB 328i
Send a message via AIM to spyder
Quote:
Originally Posted by DBLAZE View Post
My DSC light was on one time after getting a flat in one of my rear tires. Took it to the dealer and it ended up being the Steering wheel angle sensor. Replaced for approximately $400 total...
Yeah, i replaced my angle sensor last year so I can rule that out.

Quote:
Originally Posted by jorg323 View Post
Man, this problem seems to be showing up a lot lately. Short answer is, it could be one or a combination of MANY things. The most recent post I've come across with good info is this:

http://forum.e46fanatics.com/showthr...976&highlight=

but do some searching and you'll probably get your answer. If your module is busted (one of the worst-case scenarios), there are some services that can try and repair it for you for much less than buying a new one from the dealer (Module Masters, BBA-Reman, AutoECU)
Thanks for the link, i guess I will try to clean the sensors. Maybe all that skidding in and out of ice/snowy parking spots could have messed up my alignment as well.
spyder is offline   Reply With Quote
Old 03-28-2010, 05:05 PM   #8
jorg323
Registered User
 
Join Date: Feb 2008
Location: NOVA/Washington D.C.
Posts: 881
My Ride: 1999 323i
Quote:
Originally Posted by spyder View Post
Yeah, i replaced my angle sensor last year so I can rule that out.



Thanks for the link, i guess I will try to clean the sensors. Maybe all that skidding in and out of ice/snowy parking spots could have messed up my alignment as well.
Well, some people say that the sensors being dirty shouldn't effect them, but you may as well clean them off when you're down there testing them w/a multimeter anyway.
__________________


18" Black ASA AR1 Rims | Yokohama Advan S4 Tires | Bilstein Sport Shocks | Eibach Pro-Kit Springs | Brembo Slotted Rotors | 6000k Xenons | 6000k P. Chrom. Angel Eyes | Eagle Eye LED Tail Lights | K&N FIPK CAI | M-Tech II Front Bumper | 35% Tint | Clear Corners | Matte Black Grille
jorg323 is offline   Reply With Quote
Old 03-28-2010, 06:04 PM   #9
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,339
My Ride: not an E46
try to pull the codes and see what they tell u
__________________
mujjuman

2003 325xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 06-21-2010, 09:36 AM   #10
bronsky
Registered User
 
Join Date: Feb 2007
Location: South Jersey
Posts: 61
My Ride: 323ci 2000
Sorry to ressurect an old thread but I'm having this same problem and hoping I don't need to reaplace the whole module. Any result on this one?
bronsky is offline   Reply With Quote
Old 06-29-2010, 02:25 AM   #11
CokMinusTheS54
Registered User
 
Join Date: Nov 2009
Location: Jayhawk Central
Posts: 523
My Ride: '01 TiAg 325Ci 5mt
Does anyone even know how to replace the DSC module? I found one for cheap and was wondering if there was any possible chance I can DIY.

My dsc doesn't work, dsc and yellow brake light are on. My abs also quit working and the abs light came on too. Very rarely the dsc will some how work though. Maybe it's my sensors? But the dealer said my module was goingbad...
__________________
CokMinusTheS54 is online now   Reply With Quote
Old 06-29-2010, 02:29 AM   #12
woopaul5
Registered User
 
Join Date: May 2009
Location: Sahuarita, AZ/Victorville, CA
Posts: 317
My Ride: 2005 M3
Send a message via AIM to woopaul5
Get a second opinion. Check what codes are being thrown. Go to autozone or or a store like it and have them check it. If it says P0500 it will be a speed sensor most likely.
woopaul5 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use