E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > California

California
Have you seen another BMW while driving around in your area? Maybe you can find their car in the E46Fanatics Garage!
Northern California Southern California

If you don't have your garage setup, sign up today HERE

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 07-04-2010, 02:04 PM   #101
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
I have tested one fotoresistor with my multimeter and i was driving with it do make trend of resistances in direct sunlight and in shade and dark.

so what do YOu think?

during day needles OFF or more shiny?
__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays
profor is offline   Reply With Quote
Old 07-04-2010, 02:39 PM   #102
manzrik
Registered User
 
Join Date: Jan 2007
Location: italy
Posts: 104
My Ride: e46 320d
whith more light the display is more visible,the neeldes isn't the same,for me is visible with more light too
__________________
manzrik is offline   Reply With Quote
Old 07-04-2010, 09:24 PM   #103
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
ordered a bunch of leds from digikey and did mine yesterday:



the purple gauges show pretty acurately in the picture, but the blue and green of the car logo are WAY brighter in the pic than irl. irl the blue (car) matches your average blue led, and the green (door/trunk warnings etc) matches the green of the blinkers. i like it.

now i wanna do the LED needles too

gotta get rid of the amber LCD now. not sure what i want to do with that, though.
carsos is offline   Reply With Quote
Old 07-06-2010, 11:28 AM   #104
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
... alright, I changed all the leds behind the lcd to match my gauges. i peeled the orange film off, replaced it with a piece of coffee filter, put the lcd back in and... the screen displayed a bunch of garbage i panicked and put the orange film back in, and it works fine again...

could i have accidentally removed something important along with the orange filter? or maybe i just replaced it incorrectly? i'm afraid of breaking this thing since i doubt i could buy a replacement lcd alone without paying for the whole cluster


also, i replaced the led under the MPG gauge with a different color, and that seems to only affect the MPG needle. the gauge still matches the purple i used on the tach.

Last edited by carsos; 07-06-2010 at 11:36 AM.
carsos is offline   Reply With Quote
Old 07-06-2010, 11:43 AM   #105
manzrik
Registered User
 
Join Date: Jan 2007
Location: italy
Posts: 104
My Ride: e46 320d
probabily you have put the display in the wrong side
...
__________________
manzrik is offline   Reply With Quote
Old 07-06-2010, 12:07 PM   #106
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
As i understand it right, after placing back the orange filter it was moreless visible, the characters and numbers were okay?
It could happen that, as manzrik said, the display was in wrong direction.

Now try to remove the orange foil, and remember how the display was, in which direction.

Btw, the display seems to me really hard to destroy if You are careful.
__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays
profor is offline   Reply With Quote
Old 07-06-2010, 03:26 PM   #107
manzrik
Registered User
 
Join Date: Jan 2007
Location: italy
Posts: 104
My Ride: e46 320d
the display have a little point raised on one short side,the point must be on the right of tacho
__________________
manzrik is offline   Reply With Quote
Old 07-06-2010, 04:17 PM   #108
Rickna
Registered User
 
Join Date: Nov 2008
Location: West Haven, CT, USA
Posts: 1,979
My Ride: '02 330xi AT
Send a message via ICQ to Rickna Send a message via AIM to Rickna Send a message via MSN to Rickna Send a message via Yahoo to Rickna
Quote:
Originally Posted by manzrik View Post
the display have a little point raised on one short side,the point must be on the right of tacho
I found that out when I had it in upside-down...
__________________

238 years of democracy has died, and with thunderous applause

My_Mods_&_Stuff
Rickna is offline   Reply With Quote
Old 07-06-2010, 06:07 PM   #109
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
So tonight i finished light sensitive switch which uses one OP amp and foto resistor. i did wiring to instrument cluster and placed it in car.

tomorrow i will do picture of my testing board

I decided that during day needles will be OFF
__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays
profor is offline   Reply With Quote
Old 07-06-2010, 06:38 PM   #110
jinxie
Registered User
 
Join Date: Mar 2008
Location: STL - PHX
Posts: 136
My Ride: 2000 BMW 323ci
Quote:
Originally Posted by Rickna View Post
I found that out when I had it in upside-down...
i'll have to remember that!

going to do mine soon, just waiting for LEDs to arrive.

i will later do the LCD but waiting on wheel, hvac, etc because i want an m3 wheel & replacement a/c control.

Quote:
Originally Posted by profor View Post
So tonight i finished light sensitive switch which uses one OP amp and foto resistor. i did wiring to instrument cluster and placed it in car.

tomorrow i will do picture of my testing board

I decided that during day needles will be OFF
cool, can't wait to see the results!
jinxie is offline   Reply With Quote
Old 07-06-2010, 06:40 PM   #111
sillieidiot
Registered User
 
Join Date: Sep 2004
Location: the OC
Posts: 44,061
My Ride: '06 AW 330ci
Send a message via AIM to sillieidiot
profor, you should work on getting the LCD to show up as white lol
__________________
I like to reply to threads with 0 posts




Have a lighting problem? Read this first:
Lighting-related Troubleshooting Guide
sillieidiot is offline   Reply With Quote
Old 07-06-2010, 07:11 PM   #112
jinxie
Registered User
 
Join Date: Mar 2008
Location: STL - PHX
Posts: 136
My Ride: 2000 BMW 323ci
Quote:
Originally Posted by sillieidiot View Post
profor, you should work on getting the LCD to show up as white lol
i'm planning to do white gauges and white LCD; i think i know how to make it work. i'll post pics of the result
jinxie is offline   Reply With Quote
Old 07-06-2010, 08:12 PM   #113
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
Quote:
Originally Posted by profor View Post
As i understand it right, after placing back the orange filter it was moreless visible, the characters and numbers were okay?
It could happen that, as manzrik said, the display was in wrong direction.

Now try to remove the orange foil, and remember how the display was, in which direction.

Btw, the display seems to me really hard to destroy if You are careful.
hmm, i dunno. i took it out again, replaced the orange film with a purple piece of plastic cut from a folder, and made sure i put it in right-side up.

aside from it coming out blue, it looks right-side up to me... just messed up. i can clearly see that it's trying to display 6 digits on the left for the odometer, then the word "miles", then the trip odometer next to that i have no idea why mine only seems to work right with the damn orange filter in there.
Attached Thumbnails
Click image for larger version

Name:	bad_lcd.jpg
Views:	352
Size:	64.1 KB
ID:	366407  
carsos is offline   Reply With Quote
Old 07-06-2010, 08:19 PM   #114
jinxie
Registered User
 
Join Date: Mar 2008
Location: STL - PHX
Posts: 136
My Ride: 2000 BMW 323ci
Quote:
Originally Posted by carsos View Post
hmm, i dunno. i took it out again, replaced the orange film with a purple piece of plastic cut from a folder, and made sure i put it in right-side up.

aside from it coming out blue, it looks right-side up to me... just messed up. i can clearly see that it's trying to display 6 digits on the left for the odometer, then the word "miles", then the trip odometer next to that i have no idea why mine only seems to work right with the damn orange filter in there.
maybe there's something interfering with the contact points?

What color LEDS are backlighting it?

Last edited by jinxie; 07-06-2010 at 08:21 PM. Reason: wasn't finished
jinxie is offline   Reply With Quote
Old 07-06-2010, 08:55 PM   #115
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
Quote:
Originally Posted by jinxie View Post
maybe there's something interfering with the contact points?

What color LEDS are backlighting it?
yeah, that was the problem. i took it out again and the foam thingies were not really in place. it works correctly now.

it's backlit with the same color leds as the gauges. i colored the purple plastic piece with a red sharpie and came up with this. closer, but still needs work.
Attached Thumbnails
Click image for larger version

Name:	IMG00256.jpg
Views:	345
Size:	88.1 KB
ID:	366409   Click image for larger version

Name:	IMG00257.jpg
Views:	268
Size:	36.4 KB
ID:	366410  
carsos is offline   Reply With Quote
Old 07-06-2010, 09:33 PM   #116
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
Quote:
Originally Posted by sillieidiot View Post
profor, you should work on getting the LCD to show up as white lol
backlight with white leds and try diffusing with a couple sheets of wax paper?
carsos is offline   Reply With Quote
Old 07-06-2010, 10:00 PM   #117
jinxie
Registered User
 
Join Date: Mar 2008
Location: STL - PHX
Posts: 136
My Ride: 2000 BMW 323ci
Quote:
Originally Posted by carsos View Post
yeah, that was the problem. i took it out again and the foam thingies were not really in place. it works correctly now.

it's backlit with the same color leds as the gauges. i colored the purple plastic piece with a red sharpie and came up with this. closer, but still needs work.
good ya got it working, and it doesn't look half bad... could maybe be a teeny bit lighter, but purple looks cool
jinxie is offline   Reply With Quote
Old 07-07-2010, 01:08 AM   #118
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
I will not mess with display anymore because i know it will not be as sharp as it is now when it is red!!! i dont want anything else since i tried.

the display is just good for red or orange but not for white, blue....
__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays
profor is offline   Reply With Quote
Old 07-07-2010, 02:46 AM   #119
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
Light sensor

Today tried to drive with "sensor electronic" shich turns off needles when enough light is applied to sensor.

Sensor LDR is installed in one of chambers for LEDs on lower left part of instrument cluster


Electronics on test field and some wires

Free Image Hosting at www.ImageShack.us


And wires goes into instrument cluster

Free Image Hosting at www.ImageShack.us

I will try to make videos
__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays

Last edited by profor; 07-07-2010 at 03:18 AM.
profor is offline   Reply With Quote
Old 07-07-2010, 08:51 AM   #120
profor
Registered User
 
Join Date: Jun 2010
Location: Slovakia
Posts: 105
My Ride: E46 320d 2003
I took video of how the sensor works with LEDs under needles

first part is undergrounf garage, second is way under building

__________________
E46 320d Touring 2003 - Autounlock after key is turned off, seat heating from Skoda OII, Instrument Cluster mods by Scott87, Trippling on turn signal lights, some repairs on GM with broken CL relays
profor is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use