E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-24-2017, 12:59 AM   #1
weedkiller
Registered User
 
Join Date: Aug 2016
Location: carshalton surrey
Posts: 4
My Ride: E46 320 2.2 M Sport
Headlamp leveling stopped working after fitting angel eyes

Is there something I'm missing?
I removed my 06 facelift headlights to install angel eyes, the power on is connected to the aux live in the ecu box as suggested in all the installation how to's, I first noticed the nearside leveler wasn't working and the offside was OK, later the same day the offside had stopped.
Now I can hear the motors trying to work when they do their check and when I use the switch on the dash (in uk) but the lights do not move.
I've had them apart again and no wires are snagged or causing them to jam. I tried with no lens covers on and they do not move.
I am at a loss to what's causing it.
Has anyone any ideas?

Last edited by weedkiller; 05-24-2017 at 02:47 AM.
weedkiller is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old Yesterday, 12:25 AM   #2
Greg330CI
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 166
My Ride: E46 330CIc
Logic would suggest that it is something to do with the fitment of the AE's. Which ones did you fit? I fitted Umnitza Orion 2 on my 2004 (UK Spec) facelift 330Cic about 4 years ago. They work fine and I also used the power trigger from the aux live in the ECU box. make sure that the AE cables inside the light unit are not fouling anything up, especially as it sounds as though they are "trying" to operate.

If all else fails, remove the AE's and see if the levelers start working again.
Greg330CI is offline   Reply With Quote
Old Today, 12:26 AM   #3
weedkiller
Registered User
 
Join Date: Aug 2016
Location: carshalton surrey
Posts: 4
My Ride: E46 320 2.2 M Sport
Thx for your reply, I have checked that there are no cables fouling the mechanism, the lights I used are led rings from a supplier here in the UK and work great, I have had the lights installed with the front lens cover woth the rings removed and it's the same,
I'm not 100% on how the full system works, I know they are not the adaptive lights that move when you turn corners but am wondering if their is a way of resetting the light control unit as there may be a glitch in the system as such.
I have had it where stuff doesn't work correctly after removing the battery like the windows until you clear the errors generated because of the battery removal.
I have scanned for errors for the lights and found none.
Only thing left to try is to swap some lights with another car and see what happens but everyone I know have pre facelift.
weedkiller is offline   Reply With Quote
Old Today, 12:41 AM   #4
Greg330CI
Registered User
 
Join Date: Nov 2010
Location: Australia
Posts: 166
My Ride: E46 330CIc
The only other thing I can think of is that the bi-xenon self levelling sensor has moved or become disconnected somehow. I have not had problem with that on my car so cannot be specific. However, try searching this or google it and you may be able to see where it is located and then see if it has become disconnected or dislodged somehow when you removed your headlights. Clearly there is a connection between it and the light units. Good luck!
Greg330CI is offline   Reply With Quote
Old Today, 05:30 AM   #5
weedkiller
Registered User
 
Join Date: Aug 2016
Location: carshalton surrey
Posts: 4
My Ride: E46 320 2.2 M Sport
Sorry, thought I said they were halogen, mine done have the auto leveling system. I've Googled Google to death lol... the wiring seems fine and I can hear the motors.
The facelift motors don't connect the same way as the pre facelift and cannot be removed like the pre facelift.
Thanks for you suggestions though as it's your and others help that I am seeking as google isn't giving any definitive answers.
weedkiller is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use