E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-30-2010, 03:32 PM   #1
Gillymore
Registered User
 
Join Date: Apr 2010
Location: Denver
Posts: 28
My Ride: 2004 330i
Have some problems intake and electical

The car is throwing p1632 Throttle valve adaption not met and engine light is on. The car seems to cut off at 1500 rpm i don't know if this is limp mode or direct effect from the throttle body.

Some of the problems i have found are the following:

The #3 harness from the ECU was very corroded pin #45 was broken in the harness.

Torn Intake boot.

The Vanos or manifold adjuster valve seems to be broken as well.


I have temporarily fixed the ECU pin and am not so sure on whether another bad connection could be the reason i'm still getting the code. I did clean the harness pretty well. I also replaced the intake boot.
Now i am wondering whether to order a throttle body while my new ECU comes ? or does the wire harness need to be replaced ? Can the Vanos valve failure be bad enough so throw code and would it be 1632 ?

Just wondering if anyone has had any similar problems? Thanks guys
Gillymore is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-30-2010, 03:39 PM   #2
Gillymore
Registered User
 
Join Date: Apr 2010
Location: Denver
Posts: 28
My Ride: 2004 330i
Its a 2003 330i
Gillymore is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use