E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-11-2008, 04:23 PM   #1
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Is this the wheel speed sensor in this pic?

Is it Number 5 in this picture? Been getting DSC, ABS, and Brake combo.

__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-11-2008, 04:35 PM   #2
EurosportAMG
Registered User
 
Join Date: Sep 2004
Location: around the world
Posts: 244
My Ride: bm mb
yes #5
EurosportAMG is offline   Reply With Quote
Old 04-11-2008, 07:10 PM   #3
grafiksguy
Registered User
 
Join Date: Mar 2007
Location: Maplewood, New Jersey
Posts: 1,176
My Ride: 2010 328xi
That's it. Good luck getting it out of the wheel housing. I wrestled with mine with a big adjustable pliers and finally gave up after getting it part way out and tapped it back in. I was afraid I'd just chew it up. If you come up with a good way to remove it, I'd love to hear it.
__________________
grafiksguy is offline   Reply With Quote
Old 04-11-2008, 07:31 PM   #4
DiceyOne
Registered User
 
Join Date: Jul 2004
Location: PA
Posts: 530
My Ride: 1999 328i
Send a message via AIM to DiceyOne
what is that part number? what main group and sub group is that under? i am also getting those warnings intermittently. thanks
DiceyOne is offline   Reply With Quote
Old 04-12-2008, 01:33 AM   #5
EurosportAMG
Registered User
 
Join Date: Sep 2004
Location: around the world
Posts: 244
My Ride: bm mb
Quote:
Originally Posted by DiceyOne View Post
what is that part number? what main group and sub group is that under? i am also getting those warnings intermittently. thanks
front axle->front axle suspension->front spring/strut shock absorber
EurosportAMG is offline   Reply With Quote
Old 04-12-2008, 02:06 AM   #6
justdjames
Registered User
 
Join Date: Mar 2008
Location: Cali Bay
Posts: 138
My Ride: 3
mine came out pretty easy..I too get all those lights sometimes, anyone know why it comes on....when I turn car off and start it again , lights are gone ...3 weeks pass...then it starts again
Image Hosted by ImageShack.us
__________________
[IMG]Image Hosted by ImageShack.us[/IMG]

Last edited by justdjames; 04-12-2008 at 02:11 AM.
justdjames is offline   Reply With Quote
Old 04-12-2008, 09:58 AM   #7
DiceyOne
Registered User
 
Join Date: Jul 2004
Location: PA
Posts: 530
My Ride: 1999 328i
Send a message via AIM to DiceyOne
Quote:
Originally Posted by justdjames View Post
mine came out pretty easy..I too get all those lights sometimes, anyone know why it comes on....when I turn car off and start it again , lights are gone ...3 weeks pass...then it starts again
I'm sort of in the same boat except that mine is the rear passenger sensor. my warning lights (break,abs,asc) come and go but they used to be less frequent. my peake tool doesn't show a code when the lights are off but i can't say that i have run a scan when those lights are on.

when those lights are on does that mean that the ASC (DSC) and ABS are inactive? i don't drive very hard but i haven't noticed my wheels spinning out of control or that my breaking is worse.

from what I've read all this does is count a magnet that goes by... not much to go wrong so i wonder what the specific failure is; especially when it seems that most cases it is intermittent.
DiceyOne is offline   Reply With Quote
Old 06-30-2008, 09:33 AM   #8
Glory22
Registered User
 
Join Date: Mar 2004
Location: New Jersey
Posts: 222
My Ride: 323ci
How many of these sensors are there? I have the ABS+DSC+Brake combo as well. Would like to know how to determine front/rear which sensor is at fault.

Also, how much is this part?
Glory22 is offline   Reply With Quote
Old 06-30-2008, 01:15 PM   #9
gwburke
Registered User
 
Join Date: Feb 2008
Location: Nashua, NH 03060
Posts: 162
My Ride: 1999 BMW 328i
There are 4 sensors, one on each wheel. They are something like $140 each to replace. I can't get mine out to check/clean them, so I'm living with the occassional lights.
gwburke is offline   Reply With Quote
Old 06-30-2008, 01:37 PM   #10
gwburke
Registered User
 
Join Date: Feb 2008
Location: Nashua, NH 03060
Posts: 162
My Ride: 1999 BMW 328i
Quote:
Originally Posted by DiceyOne View Post
I'm sort of in the same boat except that mine is the rear passenger sensor. my warning lights (break,abs,asc) come and go but they used to be less frequent. my peake tool doesn't show a code when the lights are off but i can't say that i have run a scan when those lights are on.

when those lights are on does that mean that the ASC (DSC) and ABS are inactive? i don't drive very hard but i haven't noticed my wheels spinning out of control or that my breaking is worse.

from what I've read all this does is count a magnet that goes by... not much to go wrong so i wonder what the specific failure is; especially when it seems that most cases it is intermittent.
How do you know which specific sensor is faulty? Does the Peake tool tell you? Why would you be getting a "brake" light? That light should only come on when your brake pads are below the minimum and set off the brake wear sensor.

When the ABS/ASC lights are on you do not have either ABS or traction control. I've been dealing with this for some time now. ON...OFF...ON...OFF...360' on the highway...
gwburke is offline   Reply With Quote
Old 06-30-2008, 02:08 PM   #11
EVLEUROe46
Registered User
 
Join Date: May 2006
Location: Northern Virginia
Posts: 83
My Ride: 2002 330ci
Quote:
Originally Posted by gwburke View Post
How do you know which specific sensor is faulty? Does the Peake tool tell you? Why would you be getting a "brake" light? That light should only come on when your brake pads are below the minimum and set off the brake wear sensor.

When the ABS/ASC lights are on you do not have either ABS or traction control. I've been dealing with this for some time now. ON...OFF...ON...OFF...360' on the highway...

I have the same problem its really annoying.

I do notice that when the lights come on the car goes into some backup mode where you hardly have any power. Its harder to shift and the traction control is disabled. I got some wheel spin one night when it was raining and these lights came on. They come on so regularly that im getting pretty good at turning the car off and back on while im still rolling.

Im gonna get the codes scanned tommorow when the lights are actually on in my dash and see what codes come up. Hopefully it will say which sensor is defective if thats even the problem at all.
EVLEUROe46 is offline   Reply With Quote
Old 06-30-2008, 03:28 PM   #12
gwburke
Registered User
 
Join Date: Feb 2008
Location: Nashua, NH 03060
Posts: 162
My Ride: 1999 BMW 328i
Quote:
Originally Posted by EVLEUROe46 View Post
I have the same problem its really annoying.

I do notice that when the lights come on the car goes into some backup mode where you hardly have any power. Its harder to shift and the traction control is disabled. I got some wheel spin one night when it was raining and these lights came on. They come on so regularly that im getting pretty good at turning the car off and back on while im still rolling.

Im gonna get the codes scanned tommorow when the lights are actually on in my dash and see what codes come up. Hopefully it will say which sensor is defective if thats even the problem at all.
Please let me know if it tells you which sensor (if that's the problem) is faulty. I only get the ABS/ASC lights, some people seem to get the "brake" light (not the "brake wear sensor" light I mentioned above) as well. I would love to fix this annoyance. I tried to take my sensors out to check/clean them, but it was futile. I think the only way they're coming out is in pieces, and if that's the case I only intend to take the faulty one out.
gwburke is offline   Reply With Quote
Old 03-11-2009, 12:09 AM   #13
YOnpds
Registered User
 
Join Date: Jan 2006
Location: California
Posts: 553
My Ride: E46
I know its an old thread, but were you able to fix the problem?
YOnpds is offline   Reply With Quote
Old 03-11-2009, 12:46 PM   #14
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Quote:
Originally Posted by YOnpds View Post
I know its an old thread, but were you able to fix the problem?
I just left it and live with the problems. It goes on and off randomly. It doesn't affect anything major and the car drives fine. I didn't want to spend the money on buying new sensors. They're too expensive.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 03-11-2009, 12:53 PM   #15
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Have you had the codes read there are alot more components to the ABS than just the speed sensors
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 03-11-2009, 01:04 PM   #16
kyle808
Registered User
 
Join Date: Jun 2003
Location: Houston,TX
Posts: 936
My Ride: 00 328CI
Quote:
Originally Posted by jbeurotech View Post
Have you had the codes read there are alot more components to the ABS than just the speed sensors
Do you need to have the codes read while the lights are on? It goes on and off at random, especially after I shut off the engine.
__________________

"I'm gonna die! Jesus, Allah, Buddha - I love you all!
-Homer Simpson
kyle808 is offline   Reply With Quote
Old 03-11-2009, 01:11 PM   #17
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
No codes are stored in non volatile memory and will be in the computer when they read them
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 03-11-2009, 01:21 PM   #18
vitiokas95
Registered User
 
Join Date: Aug 2008
Location: Chicago, IL
Posts: 36
My Ride: '01 M5 and '05 325Ci
I got all these lights on couple days ago, plus this morning speedometer stopped working.
vitiokas95 is offline   Reply With Quote
Old 04-20-2010, 08:40 PM   #19
03E40sick
Registered User
 
Join Date: Feb 2009
Location: Metairie, La
Posts: 228
My Ride: 2003 bmw 325ci
Send a message via Yahoo to 03E40sick Send a message via Skype™ to 03E40sick
if the speedometer stopped working then its a bigeer problem than you think ...you need to change your abs module...which is really pricey ...i have changed mine before but on a e39 model and it was $750 and it was refirbushed part...look it up on ebay...bc the dealer wont fix it they will only sell you a new you
__________________
bimmers is the way to go........
03E40sick is offline   Reply With Quote
Old 04-20-2010, 08:55 PM   #20
Aaron90
Registered User
 
Join Date: Jul 2009
Location: Arlington, Va
Posts: 273
My Ride: 328i
Quote:
Originally Posted by 03E40sick View Post
if the speedometer stopped working then its a bigeer problem than you think ...you need to change your abs module...which is really pricey ...i have changed mine before but on a e39 model and it was $750 and it was refirbushed part...look it up on ebay...bc the dealer wont fix it they will only sell you a new you
well even though this thread is over a year old, i totally disagree with this advice. I swapped 330i rear trailing arms into my 328i and had to drive around without the right rear sensor for a few days and my speedometer didn't work. Speedometer not working certainly doesn't mean it has to be a failed abs module.
Aaron90 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use