E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 209 votes, 4.72 average.
Old 10-14-2010, 01:56 PM   #1061
spngr311
Registered User
 
Join Date: Jun 2010
Location: Satellite Beach, FL
Posts: 272
My Ride: 2001 M5
At least it didn't cut open a radiator hose like it did to me once.
__________________
spngr311 is offline   Reply With Quote
Old 10-14-2010, 02:00 PM   #1062
theinfamousdrew
Registered User
 
Join Date: Apr 2010
Location: Charlotte
Posts: 845
My Ride: 911 Turbo / E70
You just made me check to make sure there was no puddle under the car...lol

The temp gauge light up for like 30 second before I was able to shut it down....think I'm good? I don't know how fragile these are
__________________
theinfamousdrew is offline   Reply With Quote
Old 10-14-2010, 02:03 PM   #1063
theinfamousdrew
Registered User
 
Join Date: Apr 2010
Location: Charlotte
Posts: 845
My Ride: 911 Turbo / E70
Lit up* damn phone
__________________
theinfamousdrew is offline   Reply With Quote
Old 10-14-2010, 02:29 PM   #1064
spngr311
Registered User
 
Join Date: Jun 2010
Location: Satellite Beach, FL
Posts: 272
My Ride: 2001 M5
I would definitely look at the hoses. My alternator belt frayed and split down one of the grooves and cut a slash in the hose. Thankfully, I had ordered a cooling system rebuild the week before and planned to change that stuff over the weekend.
__________________
spngr311 is offline   Reply With Quote
Old 10-14-2010, 04:10 PM   #1065
zwei e46
Registered User
 
Join Date: Jul 2009
Location: New Hampshire
Posts: 238
My Ride: '99 323i & '05 325xi
put new clutch hose and slave cylinder in my 323. Bleed it the "proper way", thanks to searching here. Take-offs MUCH smoother. Now I have to psych myself up for the clutch master cylinder... doesn't look fun!
zwei e46 is offline   Reply With Quote
Old 10-15-2010, 05:24 PM   #1066
theinfamousdrew
Registered User
 
Join Date: Apr 2010
Location: Charlotte
Posts: 845
My Ride: 911 Turbo / E70
today...replaced my serpentine belts

new rear brake pads (stoptech)

new air filter (streamline)
__________________
theinfamousdrew is offline   Reply With Quote
Old 10-15-2010, 09:46 PM   #1067
himefrankie
Registered User
 
Join Date: Apr 2010
Location: NJ
Posts: 210
My Ride: 03 330xi
Yesterday, I installed alcantara shift and e-brake boots!
__________________
go big or go home.

--
himefrankie is offline   Reply With Quote
Old 10-16-2010, 02:25 AM   #1068
djack12
Registered User
 
Join Date: Mar 2010
Location: Grass Valley, California
Posts: 257
My Ride: 2001 330i
Lets see. Yesterday I did the following:

New lower radiator hose
New temp sensor
New cooling fan (along with a complete rewire front he fuse panel (dead 12v to the fan)
New water return hose
New radiator drain plug
New ATF (power steering) and hose clamps on reservoir
New expansion tank
New secondary air pump mounting bolts

This all came when I found out my fan was wired with an aftermarket temp sensor and would not turn on with the AC, and would also cause my fan to only fun at high speeds. Also found a leak in the lower radiator hose fixed with a black tar substance, zip tie and tape. The water return hose was eaten away from ATF that was leaking from the reservoir, and my expansion tank had a hole in it.

__________________

2001 330i

Great Service, Great Prices
Ryan Gangemi Motorworks
http://www.ryangmw.com

djack12 is offline   Reply With Quote
Old 10-16-2010, 10:41 AM   #1069
tb330
Registered User
 
Join Date: Aug 2009
Location: Elmira, NY
Posts: 615
My Ride: 2006 Acura TL
BMW Performance Intake
__________________
tb330 is offline   Reply With Quote
Old 10-16-2010, 11:50 AM   #1070
chris98891
Registered User
 
Join Date: Mar 2007
Location: greenville, sc
Posts: 1,718
My Ride: '01 325i
Send a message via AIM to chris98891
Oil/filter change
Replace valve cover gasket
replace spark plugs
replace cabin filter
replace intake filter
replace fuel filter
seafoam
__________________
-Chris




chris98891 is offline   Reply With Quote
Old 10-16-2010, 09:39 PM   #1071
RGO325CiC
Registered User
 
Join Date: Feb 2009
Location: Huntsville AL
Posts: 84
My Ride: '01 325Ci 'Vert
Windshield. OEM glass cost me $635 and a 2-week wait.
__________________
'01 325CiC

- Steel Grey Met; Tanin Red leather; Myrtle trim; etc.
RGO325CiC is offline   Reply With Quote
Old 10-17-2010, 06:56 PM   #1072
Manny330
Registered User
 
Join Date: Aug 2002
Location: NJ
Posts: 938
My Ride: 02 330i
Send a message via AIM to Manny330
washed and waxed it
__________________
Stock
Manny330 is offline   Reply With Quote
Old 10-17-2010, 07:01 PM   #1073
franz
Registered User
 
Join Date: Aug 2006
Location: RDU, NC
Posts: 2,881
My Ride: 03 330i
BMW Performance Composite front rotors, Carbotech XP10 pads.
__________________
franz is online now   Reply With Quote
Old 10-17-2010, 07:06 PM   #1074
Gheybe
Registered User
 
Gheybe's Avatar
 
Join Date: Aug 2009
Location: San Diego/Santa Barbara
Posts: 10,189
My Ride: C6 Z06
Akebono brake pads all around.
Coolant top off.
Cleaned interior including all my alcantara parts.
will be washing my car tomorrow.
Gheybe is offline   Reply With Quote
Old 10-17-2010, 07:45 PM   #1075
theinfamousdrew
Registered User
 
Join Date: Apr 2010
Location: Charlotte
Posts: 845
My Ride: 911 Turbo / E70
Quote:
Originally Posted by spngr311 View Post
At least it didn't cut open a radiator hose like it did to me once.
you jinxed me....i think it did...or cracked the thermostat housing...i have a slight drip coming off of the bottom of the motor
it looks like its coming from the lower rad hose near the thermostat or from the housing it self
__________________
theinfamousdrew is offline   Reply With Quote
Old 10-17-2010, 07:56 PM   #1076
jessief29812
Registered User
 
Join Date: Sep 2008
Location: CA
Posts: 1,456
My Ride: 2002 bmw 330xi
filled up gas
__________________
jessief29812 is offline   Reply With Quote
Old 10-17-2010, 08:13 PM   #1077
Sansho
OEM ///Member
 
Sansho's Avatar
 
Join Date: Jun 2010
Location: CT
Posts: 1,812
My Ride: 2001 325i
Replaced CCV.
__________________
.
Sansho is offline   Reply With Quote
Old 10-17-2010, 08:43 PM   #1078
Marcus-SanDiego
Registered User
 
Join Date: Dec 1969
Location: San Diego, CA
Posts: 515
My Ride: 2008 X5
Quote:
Originally Posted by Gheybe View Post
Akebono brake pads all around.
Coolant top off.
Cleaned interior including all my alcantara parts.
will be washing my car tomorrow.
Unless it's raining again.
Marcus-SanDiego is offline   Reply With Quote
Old 10-17-2010, 08:48 PM   #1079
tcphoto
Registered User
 
Join Date: Sep 2009
Location: Atlanta, GA
Posts: 968
My Ride: '01 325Cic TiAg
I have only owned my E46 for ten months and the only problems I have experienced is a dead windshield washer pump and front brakes. Friday, I went out to head to work and the dashboard lights went crazy and it would not start. After reading the posts regarding the subject, I called Autozone and had them hold their last 94R-DLG. It comes with an eight year warranty, three year free replacement for $145. I brought it home, installed it and it fired up on the first attempt. I won't even guess how much my local stealership wants for the same part but I am confident that it would be at least twice what I paid. Just as a prank, perhaps I will call tomorrow and ask.
__________________
tcphoto is offline   Reply With Quote
Old 10-17-2010, 08:54 PM   #1080
xFalleNx330Ci
Registered User
 
Join Date: Aug 2008
Location: South Jersey
Posts: 708
My Ride: '01 330Ci
Decided to post it for sale

Sent from my DROIDX using BimmerApp
__________________

Quote:
Originally Posted by beingdevious View Post
OT is like a bunch of rabid horny monkeys that run around and rape other forums, any new monkeys, and then throw **** at eachother, take pics, and demand nudes.
xFalleNx330Ci is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use