E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1998 votes, 4.91 average.
Old 01-24-2013, 01:42 PM   #15261
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by WDE46 View Post
damn. how long did that thermostat last? that's unfortunate.
28k its a wahler thermostat.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 01:58 PM   #15262
WDE46
Registered User
 
Join Date: Sep 2012
Location: Old Greg's Cavern
Posts: 12,646
My Ride: '13 128i, '04 330Ci
Quote:
Originally Posted by E46Enthusiast20 View Post
28k its a wahler thermostat.
i was hoping you'd say something else. have u posted in JFOJ's thermostat thread. we're compiling a bunch of info. let him know if the new Tstat fixes it.
WDE46 is offline   Reply With Quote
Old 01-24-2013, 02:34 PM   #15263
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by WDE46 View Post
i was hoping you'd say something else. have u posted in JFOJ's thermostat thread. we're compiling a bunch of info. let him know if the new Tstat fixes it.
The new parts come in tomorrow night so till then.

If everything else is fine I strongly think its the thermostat. The thermostat I currently have was from Napa. But its still a wahler. I ordered a behr replacement from bav auto.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 02:48 PM   #15264
E46Moonlight
Registered User
 
Join Date: Oct 2008
Location: Bronx, NY
Posts: 2,597
My Ride: 2000 323i
Quote:
Originally Posted by E46Enthusiast20 View Post
The new parts come in tomorrow night so till then.

If everything else is fine I strongly think its the thermostat. The thermostat I currently have was from Napa. But its still a wahler. I ordered a behr replacement from bav auto.
The problem you have is a temp sensor that goes in the bottom of the lower radiator hose on the passenger side. Simple fix.
E46Moonlight is offline   Reply With Quote
Old 01-24-2013, 02:57 PM   #15265
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by E46Moonlight View Post
The problem you have is a temp sensor that goes in the bottom of the lower radiator hose on the passenger side. Simple fix.
Explain.. please.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 02:59 PM   #15266
E46Moonlight
Registered User
 
Join Date: Oct 2008
Location: Bronx, NY
Posts: 2,597
My Ride: 2000 323i
Same thing happen to me not to long ago, I made a thread about it, I replaced my entire cooling system not to long ago and had the same issue u posted. But either way you should replace the sensor
E46Moonlight is offline   Reply With Quote
Old 01-24-2013, 03:05 PM   #15267
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by E46Moonlight View Post
Same thing happen to me not to long ago, I made a thread about it, I replaced my entire cooling system not to long ago and had the same issue u posted. But either way you should replace the sensor
I just ordered the parts from bavauto. I'll have to call in to have them add the sensor.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 03:22 PM   #15268
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by E46Moonlight View Post
Same thing happen to me not to long ago, I made a thread about it, I replaced my entire cooling system not to long ago and had the same issue u posted. But either way you should replace the sensor
I had no heat whatsoever. It was blowing cold. Needle all the way to red then back when on the pedal.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 03:25 PM   #15269
WDE46
Registered User
 
Join Date: Sep 2012
Location: Old Greg's Cavern
Posts: 12,646
My Ride: '13 128i, '04 330Ci
Quote:
Originally Posted by E46Enthusiast20 View Post
I had no heat whatsoever. It was blowing cold. Needle all the way to red then back when on the pedal.
You try rebleeding?
WDE46 is offline   Reply With Quote
Old 01-24-2013, 03:30 PM   #15270
E46Moonlight
Registered User
 
Join Date: Oct 2008
Location: Bronx, NY
Posts: 2,597
My Ride: 2000 323i
Yep! GL on fixing it
E46Moonlight is offline   Reply With Quote
Old 01-24-2013, 03:30 PM   #15271
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by WDE46 View Post
You try rebleeding?
Yeah I did no air. I posted in jfoj's thread btw. Don't wanna hijack this one.
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 03:30 PM   #15272
limpiabota809
Registered User
 
Join Date: Oct 2012
Location: NYC
Posts: 1,221
My Ride: 330 XI
Ordered 6 NGK(BKR6EQUP) and Mann air filter for 57$ shipped to me
__________________
Instagram - @Limpiabota_e46
limpiabota809 is offline   Reply With Quote
Old 01-24-2013, 03:34 PM   #15273
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 31,058
My Ride: '02 330i 6MT
Quote:
Originally Posted by E46Enthusiast20 View Post
The new parts come in tomorrow night so till then.

If everything else is fine I strongly think its the thermostat. The thermostat I currently have was from Napa. But its still a wahler. I ordered a behr replacement from bav auto.
I'm doing the opposite. Ditching my Behr tstat for Wahler.
__________________
Solidjake is online now   Reply With Quote
Old 01-24-2013, 03:41 PM   #15274
E46Enthusiast20
Registered User
 
Join Date: Dec 2009
Location: New England
Posts: 694
My Ride: 2016 F80 M3 Sedan
Quote:
Originally Posted by Solidjake View Post
I'm doing the opposite. Ditching my Behr tstat for Wahler.
haha I just want this fixed. Wasn't expecting this...
E46Enthusiast20 is offline   Reply With Quote
Old 01-24-2013, 03:55 PM   #15275
Ceaze176
Registered User
 
Join Date: Nov 2012
Location: Reading
Posts: 21
My Ride: 2000 323ci convertib
My Penelope ...

Just gave her a wash ... Inside and out .... Dropped her top and parked her right in front and now I'm just admiring her ...... It's funny cause its 11 degrees here where I am .. Jajaja everyone that passes still gives her a nice look ... Tell you what ... Going from dark wood trim to brushed aluminum all the way around gave her an outstanding look ... Had a couple of people stop and look inside ... Nice ... And she is just coming alive ... I imagine if she was hooked up like the ones I see here ... Probably see some cameras coming out of the bags jijijijijiji. ... Someday Penelope ... Someday I will get you there baby ...
Ceaze176 is offline   Reply With Quote
Old 01-24-2013, 04:06 PM   #15276
Blueandwhite85
Registered User
 
Join Date: Aug 2011
Location: Texas
Posts: 1,344
My Ride: E46
Quote:
Originally Posted by Ceaze176 View Post
Just gave her a wash ... Inside and out .... Dropped her top and parked her right in front and now I'm just admiring her ...... It's funny cause its 11 degrees here where I am .. Jajaja everyone that passes still gives her a nice look ... Tell you what ... Going from dark wood trim to brushed aluminum all the way around gave her an outstanding look ... Had a couple of people stop and look inside ... Nice ... And she is just coming alive ... I imagine if she was hooked up like the ones I see here ... Probably see some cameras coming out of the bags jijijijijiji. ... Someday Penelope ... Someday I will get you there baby ...
Use less '...' in the future. Trust me.
Blueandwhite85 is offline   Reply With Quote
Old 01-24-2013, 04:17 PM   #15277
WDE46
Registered User
 
Join Date: Sep 2012
Location: Old Greg's Cavern
Posts: 12,646
My Ride: '13 128i, '04 330Ci
Quote:
Originally Posted by Blueandwhite85 View Post
Use less '...' in the future. Trust me.
less coffee maybe?
WDE46 is offline   Reply With Quote
Old 01-24-2013, 05:52 PM   #15278
jcoleman
Registered User
 
Join Date: Jan 2007
Location: California
Posts: 3
My Ride: 2004 BMW 330Ci
Took the top end off, including the head... :-(
jcoleman is offline   Reply With Quote
Old 01-24-2013, 06:08 PM   #15279
honkifyoubonk
Registered User
 
Join Date: Jul 2010
Location: right there
Posts: 190
My Ride: E 6666
Got rid of my front plate
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1359068897.441673.jpg
Views:	78
Size:	77.1 KB
ID:	487612  
__________________
honkifyoubonk is offline   Reply With Quote
Old 01-24-2013, 06:11 PM   #15280
Blueandwhite85
Registered User
 
Join Date: Aug 2011
Location: Texas
Posts: 1,344
My Ride: E46
Quote:
Originally Posted by honkifyoubonk View Post
Got rid of my front plate
Next up: do something about that bumper! Unless of course you prefer it.
Blueandwhite85 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use