E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > BMW Regional Forums > Regional Forums > South Africa

South Africa

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-03-2010, 09:33 AM   #1
mahoerie
Registered User
 
Join Date: Dec 2009
Location: South Africa
Posts: 1
My Ride: E46 330i individual
On board Computer Keeps on running

Hi
Can anyone that had the same problem maybe help,my on board computer keeps on calculating fuel consumption and average speed when i stop at a robot,stop sign or just start the car, i also noticed that the instant consumption needle doesn't respond on revving the engine when just starting, it only becomes active at approx 30km/h,also when i slow down to stop the instant consumption needle spikes towards 10l/100km just before i stop,it is only recently started doing it,all the mechanics ive asked says i must have either the throttle potentiometer or the throttle position sensor replaced,or should i rather go for a diagnostics test first.....please i dont want to spend uneccisary money.......
mahoerie is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-22-2010, 06:29 AM   #2
pravir
Registered User
 
Join Date: Apr 2010
Location: cape town
Posts: 3
My Ride: 330ci 2001
check your speed sensors, however a diagnostic test will be the best, i do the diagnostics but in cpt! mail pravir28@gmail.com
pravir is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use