E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-29-2010, 12:19 PM   #1
mozm3
Registered User
 
Join Date: Mar 2009
Location: Depends on the day
Posts: 90
My Ride: LSB E46 M3
Need Help with SMG

Hello Everyone.

I have a problem with my SMG. A few months ago, the transmission malfunction light came on, and went away after i turned the car off, and i had no problems shifting.

No problems ever since until 3 days ago, the transmission light came back on, along with the check engine light with a code 1717, which is transmission malfunction. It kicked itself out of gears a couple of times, but it shifted fine, without any problems when it was in gear. I searched the forum and Yesterday, i replaced the Salmon colored relay, and it ran fine all morning, until now when the transmission light and the check engine light came back on, and started kicking itself out of gear more often, but when it is ingear, it shift fine without any hesitation or anything. I searched and read different threads, and i'm not sure what my next step is. The pump primes fine when the car is opened with the keyless. is there a way to test the pump? what should i do now? Any help would be appreciated

EDIT: When its kicked out of gear, it gets back into gear within 5 or 6 seconds.

Thanks
__________________

Last edited by mozm3; 06-29-2010 at 02:08 PM.
mozm3 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use