E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking

Suspension & Braking
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-09-2010, 09:21 AM   #1
kayzrx8
Registered User
 
Join Date: Jul 2010
Location: gainesville florida
Posts: 3
My Ride: 2003 325 sedan
Exclamation Help front brake locks up then releases while driving.

Hey guys im new to the forum. Ive been having an issue with my brakes. Im not sure whats going on. I took my 03 325 sedan to a mechanic to fix the rear diff bushing. all was fine till one day as i was driving then the front passenger brake applied itself momentarilly. locking up the wheel for a few m/s then releasing. that was 3 month ago. now eveytime i drive the car within the first mile of driving the same issue witht he front passenger brake will happen and the yellow "brake" light and the light with the triangle and circle in the middle of the dashboard will light up. What could be going on? Someone suggested a wheel speed sensor going bad. Any suggestions would help im planning on taking the car to get codes pulled. Thanks

Last edited by kayzrx8; 07-09-2010 at 09:26 AM.
kayzrx8 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-09-2010, 03:01 PM   #2
BimmerBrakes
The Brake Newbie!
 
Join Date: Feb 2010
Location: DFW, Tx
Posts: 1,146
My Ride: 2005 ZHP BMW
Send a message via AIM to BimmerBrakes
For the front brake issues. You got a sticky caliper. You will need to clean the guide bushings and the pins. I would lightly grease the pin before reassemble to help the caliper move to it's original spot. If the bushing are in terrible condition you will have to rebuild the caliper.

For the triangle light problem. That would he the wheel speed sensor. I would check and clean the speed sensor and then go from there.

Keep us posted on what happen

Anthony@BimmerBrakes

Last edited by BimmerBrakes; 07-09-2010 at 03:04 PM.
BimmerBrakes is offline   Reply With Quote
Old 07-11-2010, 12:46 AM   #3
kayzrx8
Registered User
 
Join Date: Jul 2010
Location: gainesville florida
Posts: 3
My Ride: 2003 325 sedan
Hey thanks for the response man. Im pretty sure the caliper isnt sticking cause the front end on my cars practically new. I just put new calipers, rotors, brakes, and suspension arms. The abs unit , dsc or something is applying the front passenger brake. i can hear the unit make a noise to apply the brake when t happens. it does it like after 5 mins of driving and only for a quick second then releases. After it releases the lights will come on. I will look at the wheel speed sensor. Do you think it just needs cleaning or need to be replaces? Is this a common problem that happens when the wheel speed sensors fail?
kayzrx8 is offline   Reply With Quote
Old 11-14-2010, 07:08 PM   #4
tiloulou330i
Registered User
 
Join Date: Mar 2006
Location: Dumont,NJ
Posts: 730
My Ride: 02 330i zsp
Send a message via AIM to tiloulou330i Send a message via MSN to tiloulou330i Send a message via Yahoo to tiloulou330i
I'm having the same issue with the front brakes.For less than a second the front applies braking on its own.This started right after I got a shop to flush the lines for me.It does it @ any speed.
__________________
Filbert


Originally Posted by nawmean?
I know I sound naive, but some of the advice I've taken from this board has helped my life quite a bit
tiloulou330i is offline   Reply With Quote
Old 11-15-2010, 12:50 PM   #5
kayzrx8
Registered User
 
Join Date: Jul 2010
Location: gainesville florida
Posts: 3
My Ride: 2003 325 sedan
Exclamation Bad Wheel Speed Sensor

I managed to fix the problem it turned out to be that wheels speed sensor. Try cleaning it. If that does not work replace it. That thing almost got me into a wreck. It locked the front wheel for a second while i was doing a turn on an exit ramp.
kayzrx8 is offline   Reply With Quote
Reply

Tags
abs, brake, brakes, lock, releasing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use