E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 07-21-2010, 12:38 PM   #1
TheDream
Registered User
 
Join Date: Sep 2006
Location: Fredericksburg, VA
Posts: 197
My Ride: 2003 330ci
Unhappy Two separate codes, two times into limp mode, one giant unsolved headache..

I'll keep this short and sweet, and I'm hoping someone can help me out. I have a step 330Ci.

Day 1 of the issues: Car goes into limp mode while stopped at a red light. Code readout was P1732 which has something to do with gear ratio. Turning off and on did not clear the limp mode. I had them clear the code and drove around fine for a few days.

Day 4: Car goes into limp mode AGAIN while stopped at a red light. This time I was only a mile from my mechanic so I drove straight there. Turned the car off and on, and limp mode was no longer there. A code was pulled though, P0721, which is the speed sensor.

Day 6: After a "few hours" at the shop turned into a day and 6 hours, my mechanic said that my tranny fluid and the driving test turned up nothing, and as it is sitting in the shop it's 100% fine. This is obviously not the case.

So I ask you, e46fanatics, don't let this be my last post here! Help a brother out, and hopefully I won't be selling this car.. although I do have my eye on an 02 M5..
__________________
"The only thing that comes to a sleeping man is dreams"

TheDream is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-21-2010, 06:06 PM   #2
TheDream
Registered User
 
Join Date: Sep 2006
Location: Fredericksburg, VA
Posts: 197
My Ride: 2003 330ci
bump
__________________
"The only thing that comes to a sleeping man is dreams"

TheDream is offline   Reply With Quote
Old 07-21-2010, 08:32 PM   #3
shanneba
Registered User
 
Join Date: May 2008
Location: Indiana
Posts: 2,094
My Ride: 2003 330Ci
I found a few links when I searched yahoo with BMW P1721 and BMW P0721.

One indicated the fluid level could be low. It could also be a wiring problem to the transmission output speed sensor.
Another indicated the battery voltage could be too low.
__________________
Join BMWCCA
Discounts on new and CPO cars.
Most Dealers offer a parts discount, BMP Design 10% off

Last edited by shanneba; 07-21-2010 at 08:33 PM.
shanneba is offline   Reply With Quote
Old 07-21-2010, 11:51 PM   #4
TheDream
Registered User
 
Join Date: Sep 2006
Location: Fredericksburg, VA
Posts: 197
My Ride: 2003 330ci
My mechanic double checked the fluid level and battery voltage, they both checked out fine. If it is the wiring to the speed sensor, is that an easy fix?
__________________
"The only thing that comes to a sleeping man is dreams"

TheDream is offline   Reply With Quote
Old 07-22-2010, 09:09 AM   #5
TheDream
Registered User
 
Join Date: Sep 2006
Location: Fredericksburg, VA
Posts: 197
My Ride: 2003 330ci
morning bump..
__________________
"The only thing that comes to a sleeping man is dreams"

TheDream is offline   Reply With Quote
Old 07-23-2010, 06:06 AM   #6
TheDream
Registered User
 
Join Date: Sep 2006
Location: Fredericksburg, VA
Posts: 197
My Ride: 2003 330ci
one last bump I guess
__________________
"The only thing that comes to a sleeping man is dreams"

TheDream is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use