E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 09-07-2010, 11:58 AM   #1
barclays001
Registered User
 
Join Date: Jul 2010
Location: ---
Posts: 15
My Ride: ---
My Worst Fear! Warning Light on M3 SMG (Sequential M gearbox with Drivelogic)

Drove to work today as normal, perhaps a little bit spirited in my driving, and stuck in heavy traffic for over an hour too. Just as I pulled up into work I noticed the ! with the yellow circle around it (with little rivets all around)

Looking at the book, its the sequential M gearbox with drivelogic indicator lamp.

The other indicator that is on is the SERVICE ENGINE SOON INDICATOR

What do I do, whats the problem. Is it safe to drive?
barclays001 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-07-2010, 12:09 PM   #2
barclays001
Registered User
 
Join Date: Jul 2010
Location: ---
Posts: 15
My Ride: ---
Image and video hosting by TinyPic


Image and video hosting by TinyPic
barclays001 is offline   Reply With Quote
Old 09-07-2010, 12:40 PM   #3
cntrvrsy
Registered User
 
Join Date: Feb 2006
Location: NY
Posts: 439
My Ride: ///M3
A lot of us SMG owners have been experiencing the (!) light this hot summer. It could be a number of things so the best thing to do is get the codes read and go from there. On a very hot day, I was getting my a/c recharged and the car sat at idle while this was being done... the SMG light came on and the car would drop into neutral several times as I drove it. After the car cooled off, it was fine again. I was out joy riding a few days ago and the light came on again but the car shifted just fine. I haven't had the chance to go get the codes read but I do plan to. Anything beyond that would be guessing.
__________________
cntrvrsy is offline   Reply With Quote
Old 09-07-2010, 01:25 PM   #4
delmarco
Registered User
 
Join Date: Nov 2008
Location: Westchester, NY
Posts: 6,287
My Ride: 2001 330i
Send a message via ICQ to delmarco Send a message via Yahoo to delmarco
it could also be an early sign of battery/alternator failure. With the hot summer and AC systems blasting with summertime music it tends to wear the battery more than other seasons.
__________________




VISIT MY GARAGE TO SEE ALL MY MODS:

http://directory.e46fanatics.com/use...rMod&UcId=7917
delmarco is offline   Reply With Quote
Old 09-07-2010, 01:30 PM   #5
Boostin FD
Registered User
 
Join Date: May 2008
Location: STL
Posts: 24
My Ride: M3
it's probably the relay failing slowly... get one as a spare just in case... it happend to me recently.
__________________
2009 BMW M3 Coupe<~~Current
DCT
Tech and Premium Package
Jerez Black on Fox Red
Stock... for now :)
2009 Audi S5 Phantom Black<~~Sold
Magnaflow Exhaust
AWE Downpipes
H&R Spacers
2002 E46 M3 SMG <~~Gone
Dinan Muffler
Dinan CAI
Dinan High Flow Throttle Bodies
Dinan Stage 4 Software
Dinan Strut Brace
Dinan Stage 1 Suspension
BBS replica Rims
2007 RS4 Dolphin Gray<~~SOLD
3M clear bra
Tinted windows
Boostin FD is offline   Reply With Quote
Old 09-08-2010, 08:17 PM   #6
M3ANMACHINE
Registered User
 
Join Date: May 2008
Location: Mission Viejo, CA
Posts: 292
My Ride: 2004 E46 ///M3
Replace the relay.
What was the outdoor temp. when you were driving?
__________________

E90 ///M3 - AW - 6MT - Volk - Akrapovic - Dinan
2004 E46 M3 : SOLD
M3ANMACHINE is offline   Reply With Quote
Old 09-13-2010, 09:27 PM   #7
djoutofsight
Registered User
 
Join Date: Feb 2007
Location: Yonkers, NY
Posts: 829
My Ride: E46 M3 Smg Mystic
Can you all post a PN along with a place to get this. I have yet to have an issue but i would like to have one on standby..Also are we talking about the Salmon colored relay??
__________________

Car: Not an //M
TEAM EUROWERKZ NY DIRECTOR
djoutofsight is offline   Reply With Quote
Old 09-13-2010, 10:56 PM   #8
NorthJersey 3er
Registered User
 
NorthJersey 3er's Avatar
 
Join Date: Oct 2004
Location: NJ
Posts: 20,241
My Ride: '03 M3 / '72 2002tii
^^yeah the salmon relay search for it on M3F...I picked it up at the dealer for $15 and keep it in my tool kit just in case Ill try that first thanks to all of the experiences Ive read about over the years w smg's
__________________
Matt

co-founder of
euro techniks

NorthJersey 3er is offline   Reply With Quote
Old 09-13-2010, 11:35 PM   #9
crai6m4ck
Registered User
 
Join Date: May 2007
Location: Glens Falls, NY
Posts: 13
My Ride: 2002 E46 M3 Vert
I have that light come on ONLY when I really get on the gas and it happens regardless of weather. I can get it to go off if I restart the car. I replaced the salmon colored relay but it didn't fix it. Any other thoughts?
crai6m4ck is offline   Reply With Quote
Old 11-09-2010, 01:53 AM   #10
bimmernator
Registered User
 
Join Date: Feb 2008
Location: los Angeles, CA
Posts: 6
My Ride: 2004 M3 JB SMGII
Quote:
Originally Posted by barclays001 View Post
Drove to work today as normal, perhaps a little bit spirited in my driving, and stuck in heavy traffic for over an hour too. Just as I pulled up into work I noticed the ! with the yellow circle around it (with little rivets all around)

Looking at the book, its the sequential M gearbox with drivelogic indicator lamp.

The other indicator that is on is the SERVICE ENGINE SOON INDICATOR

What do I do, whats the problem. Is it safe to drive?
Sorry for reviving old thread, but have you resolved this problem yet?
bimmernator is offline   Reply With Quote
Old 11-09-2010, 07:58 AM   #11
grkm3
Registered User
 
Join Date: Mar 2006
Location: Long Island
Posts: 1,903
My Ride: Money Pit
Send a message via AIM to grkm3
I've had the cog light on since last night. Haven't had time to scan for errors but the car drives perfectly fine and the SMG reservoir is full.
__________________
03 Steel Gray M3 - Imola Red Interior - SMGII - Premium - HK Sound
Mods: VFE SC Stage 2, SS Ceramic Coated Stepped Headers, S-Pipe, X-Pipe, TMS Subframe Reinforcement, KWV2 Coilovers, TMS Camber Plates, Powerflex RTAB's, Rogue RSM's, ZCP F/R brakes

Coming Soon: Open to suggestions

grkm3 is offline   Reply With Quote
Old 11-09-2010, 05:45 PM   #12
bimmernator
Registered User
 
Join Date: Feb 2008
Location: los Angeles, CA
Posts: 6
My Ride: 2004 M3 JB SMGII
Quote:
Originally Posted by grkm3 View Post
I've had the cog light on since last night. Haven't had time to scan for errors but the car drives perfectly fine and the SMG reservoir is full.
Please repost when you solve this issue as I'm experiencing this right now. Thanks!
bimmernator is offline   Reply With Quote
Old 11-09-2010, 07:28 PM   #13
grkm3
Registered User
 
Join Date: Mar 2006
Location: Long Island
Posts: 1,903
My Ride: Money Pit
Send a message via AIM to grkm3
My SMG cog light was related to the adaptation program I ran via INPA. I cleared the error a few hours ago and the light hasn't returned. I'll keep my fingers crossed. More than likely due to not having a battery charger connected to the car while performing the teach in. The error listed battery voltage as 11.7.
__________________
03 Steel Gray M3 - Imola Red Interior - SMGII - Premium - HK Sound
Mods: VFE SC Stage 2, SS Ceramic Coated Stepped Headers, S-Pipe, X-Pipe, TMS Subframe Reinforcement, KWV2 Coilovers, TMS Camber Plates, Powerflex RTAB's, Rogue RSM's, ZCP F/R brakes

Coming Soon: Open to suggestions


Last edited by grkm3; 11-09-2010 at 07:32 PM.
grkm3 is offline   Reply With Quote
Old 11-11-2010, 06:10 PM   #14
capio7
Registered User
 
Join Date: Nov 2010
Location: NC
Posts: 32
My Ride: 2004 M3
Had the this light come on tonight on start up after driving home from work. I just picked the car up a week ago and it has 68k on it. I have a warranty till 125k so im not worried cause after I got home the light went away. Ill pull codes tomorrow and keep an up to date too. Ill ake it to the dealer since its under warranty. Im sure they will say something crazy but maybe not. I did get on it alot and shifted really hard but hey it was fun. Not as fast as the stage 3 S4 I have but 2 diff cars.
capio7 is offline   Reply With Quote
Old 11-12-2010, 04:16 PM   #15
raydenz
Registered User
 
Join Date: Feb 2008
Location: Baton Rouge, LA
Posts: 1
My Ride: 2004 M3 SMG
>> "its the sequential M gearbox with drivelogic indicator lamp. The other indicator that is on is the SERVICE ENGINE SOON INDICATOR"

This happened to me and my heart dropped to my stomach, I had only 1 week till my 6 year extended warranty was up!

It was a Saturday morning and I was getting on the Interstate when the SMG and ENGINE lights come on and the engine cuts off, I immediately pull to the shoulder and turn off the key. I waited about 1 minute and I was able to crank it up, but the lights were still on. I turned around and made it back home without any problems, babying it. I didn't drive on Sunday knowing I need to wait till Monday and at least be able to make it to the dealership. Monday morning comes around.. I crank the car and no ENGINE light anymore but the SMG light is still on.. So I'm heading to the dealership (only 6 miles away).. getting on the interstate on-ramp the engine light come on and the car dies.. now I'm in panic! (GREAT, morning traffic everywhere!) .. I cut the power and did the lock/unlock to reset and cranked up.... Ramped up some speed.. 2nd Gear.... 3rd Gear..... 4th Gear..... then it auto down shifts to 3rd gear!!!.. AHHHHH.. So I shift it over to manual and keep it i 3rd Gear.. I thankfully made it to the dealership...

All this panic and it was just the Relay and they replaced it for free.

Oh? You though this was it? Happy ending??.. Nope.. So 2 weeks later (no more warranty). It happens again!! ENGINE, SMG light and engine shuts off!! Almost the same spot on the interstate. I went ahead and made it to work. That afternoon I cranked it up.. hrmm.. NO ENGINE and SMG LIGHTS???.. and.. haven't seen them since.. Is my car now self healing??

OK.. so the story did turn out good after all



-kZ - Detector Out!

Last edited by raydenz; 12-08-2010 at 06:52 PM. Reason: This event occured Jun/2010; Still running like a champ..
raydenz is offline   Reply With Quote
Old 11-12-2010, 06:01 PM   #16
capio7
Registered User
 
Join Date: Nov 2010
Location: NC
Posts: 32
My Ride: 2004 M3
Thats really weird. Mine came on after I got all over it and high rev shifted. I pulled codes and nothing. Hasent come back on yet. Ima go get that relay tmr and keep in the car. and some smg fluid and make sure its topped off. FUn car man since Ive had it. I really luv it. Im a huge audi fan but damn the fun factor in the m3 is way superior not to mention the handling at stock level. Thanks for the update man. Good to hear it turned out ok.
capio7 is offline   Reply With Quote
Old 11-29-2010, 08:42 AM   #17
love2puck14
Registered User
 
Join Date: Sep 2009
Location: West palm beach fl
Posts: 56
My Ride: 02 M3 Tiag vert smg
happened to me this morning. Got the service engine soon indicator friday. drove it all weekend. no problems. This morning backing into my parking spot the car went out of gear and into neutral on its own (with the shifter still in reverse). then the infamous light came on. after reading yours and others posts it seems it will be the relay. i hope so.
__________________


2002 Titanium Silver Metallic M3 convertible SMG
-Matte Black fender grills and kidney grills -Dark smoked out side markers and smoked corners -Smoked LED Tails
-oem 18's with Sumitomo HTR Z II
love2puck14 is offline   Reply With Quote
Old 11-29-2010, 09:22 AM   #18
capio7
Registered User
 
Join Date: Nov 2010
Location: NC
Posts: 32
My Ride: 2004 M3
keep us posted dude.
capio7 is offline   Reply With Quote
Old 11-30-2010, 09:51 AM   #19
love2puck14
Registered User
 
Join Date: Sep 2009
Location: West palm beach fl
Posts: 56
My Ride: 02 M3 Tiag vert smg
after work yesterday. the light was still on but the car drove fine. my commute is less than a mile though. this morning when i started her up... the smg light was off. CEL is still on though. car seemed fine though
__________________


2002 Titanium Silver Metallic M3 convertible SMG
-Matte Black fender grills and kidney grills -Dark smoked out side markers and smoked corners -Smoked LED Tails
-oem 18's with Sumitomo HTR Z II
love2puck14 is offline   Reply With Quote
Old 12-09-2010, 09:36 AM   #20
love2puck14
Registered User
 
Join Date: Sep 2009
Location: West palm beach fl
Posts: 56
My Ride: 02 M3 Tiag vert smg
stayed off for a week or so. came back on. then went off the next day... starting to sound like its the relay RIGHT??
__________________


2002 Titanium Silver Metallic M3 convertible SMG
-Matte Black fender grills and kidney grills -Dark smoked out side markers and smoked corners -Smoked LED Tails
-oem 18's with Sumitomo HTR Z II
love2puck14 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use