E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-15-2010, 11:22 AM   #1
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
Helppp My car's milage is completely wrong!!!! 621,372 Miles ?????

Yesterday, i got into my 2000 328ci and started her up and went on my way only to realize that the mileage on the dash was completely off!!! My car has about 75k on it last i remember and now is it saying that it has 621,372 miles on it... The only problem besides that is that it is not changing with me driving.. So far i have reset my trip, unplugged my battery for a half hour, and i have tried tinkering around with the menu on the dash in the mileage and trip screen and have cleared my OBD as well.. I have come here on my last resort because I am looking to sell my car soon to upgrade to an M3 but i dont think that anyone wants a car with 600k on it... I was wondering if this is a common issue and what you guys think it could be because i have tried searching for any related issues and i can't seem to find anything on it.... The coolant light and oil light have been coming up lately as well when i first start up my car in the morning. I have checked both fluid levels and they are both filled to where they are recommended to be... Could it be the colder mornings that are starting to come around or maybe some faulty sensors??

BTW i didnt know if this belonged in the Electronics thread or general info thread so mods feel free to move....

Thanks in advance for any help.. Everyone on this forum has been so helpful in the past to me and i just hope that someone will be able once again...

Thanks
John
Attached Thumbnails
Click image for larger version

Name:	mail.jpg
Views:	200
Size:	147.2 KB
ID:	375788  
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1


Last edited by y try; 09-15-2010 at 11:25 AM.
y try is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-15-2010, 11:25 AM   #2
alwaysbored786
Registered User
 
Join Date: Apr 2009
Location: Fairfax, Va
Posts: 5,786
My Ride: Noble|M3|XJ
oh my god. That is awesome.

Good thing the mileage is stored in a few other spots besides the dash. Sorry for my useless reply, i dont know wtf is wrong. Not a common issue at all.
__________________

*NO F-BOMBS IN SIGS*
How to refinish rims
Quote:
Originally Posted by Coldintake View Post
I am proposing opening up a Paypal fund for OP. The funds will directly be used in purchasing a farm so that OP can grow some balls.
alwaysbored786 is offline   Reply With Quote
Old 09-15-2010, 11:35 AM   #3
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
lol i know its like the craziest thing ive seen and i havent been able to find anything yet so hopefully someone will turn up with some insight on this issue... Its funny becuase i now tell my friends i have 600k on my car and they dont believe me and when i show them their like WTF lol but I would not stay in bed all day crying if this issue was to go away...
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1

y try is offline   Reply With Quote
Old 09-15-2010, 11:36 AM   #4
alwaysbored786
Registered User
 
Join Date: Apr 2009
Location: Fairfax, Va
Posts: 5,786
My Ride: Noble|M3|XJ
honestly, try calling up bmwna and be like wtf.
__________________

*NO F-BOMBS IN SIGS*
How to refinish rims
Quote:
Originally Posted by Coldintake View Post
I am proposing opening up a Paypal fund for OP. The funds will directly be used in purchasing a farm so that OP can grow some balls.
alwaysbored786 is offline   Reply With Quote
Old 09-15-2010, 11:40 AM   #5
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
im gonna have to try that tonight... Wouldn't it be nice if they like like "oh our bad... Heres a brand new M3!! Have Fun!!" loll
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1

y try is offline   Reply With Quote
Old 09-15-2010, 11:43 AM   #6
Rif Raf
Registered User
 
Join Date: Aug 2008
Location: utah
Posts: 332
My Ride: 2001 330i w/ Sport
I keep getting the mental image of the car lot attendents from Ferris Bueller out joy riding your car while you weren't looking.
Rif Raf is offline   Reply With Quote
Old 09-15-2010, 11:44 AM   #7
ChasCan
Registered User
 
Join Date: Jan 2010
Location: Connecticut
Posts: 1,066
My Ride: 2001 330xi
I have heard of the odo's & the other displays going haywire, but that is weird. Anyway I think that your ignition key might hold the correct mileage. The dealer has a key reader for the cars info including the mileage. Chas
ChasCan is offline   Reply With Quote
Old 09-15-2010, 12:27 PM   #8
mrshelley
Registered User
 
Join Date: May 2004
Location: Bethlehem, PA
Posts: 916
My Ride: 2004 330i
You might be out of luck. Depending on where you live, some areas have state inspections. Every time there is a state inspection, the inspector logs the mileage. This info is kept on file with the state and I think it will come through on a Carfax. So, obviously, your mileage did not increase over 500k in one year (unless you strapped your car to the space shuttle).

Your mileage is logged in the headlight switch (in addition to the instrument cluster). I don't think the mileage is logged in the ECU but it can be read by dealer because the instrument cluster and ECU communicate back and forth with the CAN.

Maybe the dealer can scan your car and come up with the correct mileage or maybe it might come up with the 621K. At this point, I'd take it to the dealer and see what happens. If they can't help. then you better start looking for an instrument cluster and matching headlight switch.

FYI: The mileage is not logged in the key.
__________________
mrshelley is offline   Reply With Quote
Old 09-15-2010, 12:31 PM   #9
xFalleNx330Ci
Registered User
 
Join Date: Aug 2008
Location: South Jersey
Posts: 708
My Ride: '01 330Ci
I know this has happened to someone else on the forum before.


Here you go, found the thread:
http://forum.e46fanatics.com/showthr...003&highlight=
__________________

Quote:
Originally Posted by beingdevious View Post
OT is like a bunch of rabid horny monkeys that run around and rape other forums, any new monkeys, and then throw **** at eachother, take pics, and demand nudes.
xFalleNx330Ci is offline   Reply With Quote
Old 09-15-2010, 12:35 PM   #10
alwaysbored786
Registered User
 
Join Date: Apr 2009
Location: Fairfax, Va
Posts: 5,786
My Ride: Noble|M3|XJ
^ woah good find. weird that it went to the same exact mileage.
__________________

*NO F-BOMBS IN SIGS*
How to refinish rims
Quote:
Originally Posted by Coldintake View Post
I am proposing opening up a Paypal fund for OP. The funds will directly be used in purchasing a farm so that OP can grow some balls.
alwaysbored786 is offline   Reply With Quote
Old 09-15-2010, 12:36 PM   #11
ChasCan
Registered User
 
Join Date: Jan 2010
Location: Connecticut
Posts: 1,066
My Ride: 2001 330xi
FYI: The mileage is not logged in the key.[/QUOTE]

I don't know about that. Today when I went for my subframe inspection, the dealer had my exact mileage just by reading my key in the key reader. Chas
ChasCan is offline   Reply With Quote
Old 09-15-2010, 12:38 PM   #12
xFalleNx330Ci
Registered User
 
Join Date: Aug 2008
Location: South Jersey
Posts: 708
My Ride: '01 330Ci
Quote:
Originally Posted by alwaysbored786 View Post
^ woah good find. weird that it went to the same exact mileage.
Yea that's really weird. I would definitely give a call to BMWNA.
__________________

Quote:
Originally Posted by beingdevious View Post
OT is like a bunch of rabid horny monkeys that run around and rape other forums, any new monkeys, and then throw **** at eachother, take pics, and demand nudes.
xFalleNx330Ci is offline   Reply With Quote
Old 09-15-2010, 12:51 PM   #13
ben_00_328ci
Registered User
 
Join Date: Aug 2009
Location: Orange County
Posts: 20
My Ride: 2000 328ci
In the link to that post that Fallenx330ci linked to, OP said it was his HID fogs that caused it. Noticed in your sig that you have HID fogs too, that might be it. But it's still really weird.
ben_00_328ci is offline   Reply With Quote
Old 09-15-2010, 03:33 PM   #14
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
First of all thank you all for the quick replies. Everyone on this forums always been good with that..

Quote:
xFalleNx330Ci : I know this has happened to someone else on the forum
Here you go, found the thread:
http://forum.e46fanatics.com/showthr...003&highlight=
Awesome find and i think im definitely going have to try to reset my ecu again by disconnecting my battery... If all else fails, either the dealer or i gotta call BMWNA.

Quote:
ben_00_328ci In the link to that post that Fallenx330ci linked to, OP said it was his HID fogs that caused it. Noticed in your sig that you have HID fogs too, that might be it. But it's still really weird.
Ive had these fogs for about two years now but if thats the issue, Im definitely willing to take them out... Its just odd that it decided to happen now..

Quote:
mrshelley : You might be out of luck. Depending on where you live, some areas have state inspections. Every time there is a state inspection, the inspector logs the mileage. This info is kept on file with the state and I think it will come through on a Carfax. So, obviously, your mileage did not increase over 500k in one year (unless you strapped your car to the space shuttle).

Your mileage is logged in the headlight switch (in addition to the instrument cluster). I don't think the mileage is logged in the ECU but it can be read by dealer because the instrument cluster and ECU communicate back and forth with the CAN.

Maybe the dealer can scan your car and come up with the correct mileage or maybe it might come up with the 621K. At this point, I'd take it to the dealer and see what happens. If they can't help. then you better start looking for an instrument cluster and matching headlight switch.

FYI: The mileage is not logged in the key.
Im hoping that your right because everywhere i read about totally different things on where the mileage is stored.. Hopefully the dealer can pull it up out of something if that turns to be my option...
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1

y try is offline   Reply With Quote
Old 09-15-2010, 09:34 PM   #15
TerraPhantm
Registered User
 
Join Date: Feb 2008
Location: Mountain Top
Posts: 5,942
My Ride: 2005 M3 Coupe
Quote:
Originally Posted by mrshelley View Post
You might be out of luck. Depending on where you live, some areas have state inspections. Every time there is a state inspection, the inspector logs the mileage. This info is kept on file with the state and I think it will come through on a Carfax. So, obviously, your mileage did not increase over 500k in one year (unless you strapped your car to the space shuttle).

Your mileage is logged in the headlight switch (in addition to the instrument cluster). I don't think the mileage is logged in the ECU but it can be read by dealer because the instrument cluster and ECU communicate back and forth with the CAN.

Maybe the dealer can scan your car and come up with the correct mileage or maybe it might come up with the 621K. At this point, I'd take it to the dealer and see what happens. If they can't help. then you better start looking for an instrument cluster and matching headlight switch.

FYI: The mileage is not logged in the key.
Yes it is. It's not the primary mileage logging unit, but the keys definitely do store mileage. The car updates it once every 100 miles or so.

The mileage is definitely stored in at least the instrument cluster and LSZ, and I think it might be stored in the EWS and DME as well. A tamper light isn't necessarily thrown if the mileage doesn't match - the light is thrown when the VINs don't match. If it's just the instrument cluster that got screwed up, theoretically he can buy a new cluster and that will get updated with the proper mileage stored in the LSZ. But the if the LSZ also got updated to 600k miles, he might be SOL.

Last edited by TerraPhantm; 09-15-2010 at 09:36 PM.
TerraPhantm is offline   Reply With Quote
Old 09-17-2010, 07:52 AM   #16
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
forst of all i wanna thank everyone for all of the insight on this issue and for all of the help that i get from this great forum...

I have an update and i dont know if this is a good thing or a bad thing.. I tried unplugging the battery and leaving it disconnected for about an hour and a half and this have changed my situation a little bit. The odometer s now reading 3,576 miles.. I guess this makes my car in a little better shape lol but the difference is that it is actually moving and the mileage is finally going up now as to prior to this the 600k wasn't moving at all when i drove. I am going to try to disconnect it again for a little longer today if i get a chance... I have also began using my spare key as well hoping that this will correct the issue... If all else fails, i will remove my HID fogs to see if that has any effect. I feel that it may have something to do with my issue because it is apparently what fixed the issue that someone else on the forum had in the thread located above even though my situation is a little different but it wont hurt to try. I also had failed my inspection in august because of faulty o2 sensors and i have corrected this issue and want to try to get this mileage issue fixed because i dont wanna drive around with the failed inspection sticker because massachusetts have been cracking down on expired stickers and i have already been pulled over for "investigating" the date on mine and was given a ticket for no front plate, tints, hanging things from my rearview mirror and my exhaust being too loud even though it is legal... Uhhhhhhh i wish this would all go away so i could move foreward into buying a new car hopefully without these kinds of issues because apparently they are not even rare but it seems that i always get the ones that no one else get loll

Btw alwaysbored786 i have read your DIY for refinishing rims and i am planning on doing this soon because yours came out sickkk!! Thanks for the DIY

Thanks again and sorry for blabbering on...
John
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1


Last edited by y try; 09-17-2010 at 07:54 AM.
y try is offline   Reply With Quote
Old 09-18-2010, 09:36 PM   #17
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
Bump!!
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1

y try is offline   Reply With Quote
Old 09-22-2010, 01:16 AM   #18
JaYaRe
Registered User
 
Join Date: Jun 2009
Location: L.A Baby
Posts: 600
My Ride: goes, Brroom Brooom
holy sh1t lol go to bmw and be like wtf
__________________
100_0903-1
JaYaRe is offline   Reply With Quote
Old 09-22-2010, 05:59 PM   #19
Marcus-SanDiego
Registered User
 
Join Date: Dec 1969
Location: San Diego, CA
Posts: 515
My Ride: 2008 X5
Quote:
Originally Posted by y try View Post
i have already been pulled over for "investigating" the date on mine and was given a ticket for no front plate, tints, hanging things from my rearview mirror and my exhaust being too loud even though it is legal...
Note to self: do not move to Belmont, Mass.

That is all.
Marcus-SanDiego is offline   Reply With Quote
Old 09-22-2010, 07:50 PM   #20
y try
Registered User
 
Join Date: Aug 2008
Location: Belmont, Ma
Posts: 58
My Ride: Black 5spd 328CI
Quote:
Originally Posted by Marcus-SanDiego View Post
Note to self: do not move to Belmont, Mass.

That is all.
Quote:
Originally Posted by JaYaRe View Post
holy sh1t lol go to bmw and be like wtf

I actually got pulled over in Watertown, Mass. lol Btw i went to the BMW dealership near me (Herb Chambers) and they claimed that no one has ever heard of this issue, just the dead pixel problem... Even the master technician had never heard of this... Anyone got any ideas???
__________________
Mods: Rare OEM Aero Package, Sport and Premium Package, Navigation OEM Clears, Eagle Eye LED tailights, HID fogs, Invisilight Bulbs all around, Remus exhaust, Res deletes, Dinan Flash, Blacked Out Grills, K&N cold air intake, 15% tints, 12 inch JL sub, V1

y try is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use