E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 4.00 average. Display Modes
Old 09-19-2010, 12:08 PM   #1
LoopyCootiebrain
Registered User
 
Join Date: Sep 2010
Location: Los Angeles
Posts: 3
My Ride: BMW 325
my BMW front LED lights flicker everytime i brake. Everytime.

So i have a bmw 325xi
and its front LED lights seem to go off every single time i apply the brakes.
This ofcourse, only occurs when the front LED lights are switched on.

I went to Pepboys, and they do not have the machinery to work on the car.

I could upload a video if it is needed.

Last edited by LoopyCootiebrain; 09-19-2010 at 12:09 PM.
LoopyCootiebrain is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-19-2010, 01:16 PM   #2
Mango
Over 15,000 visitors
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,559
My Ride: M54B30
lol wat

i didnt know e46s came with front leds
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 09-19-2010, 01:37 PM   #3
deadpass
Registered User
 
Join Date: Jun 2008
Location: phoenix, az
Posts: 1,650
My Ride: 01 330i
I think a video is definitely in order.
__________________
deadpass is offline   Reply With Quote
Old 09-19-2010, 01:41 PM   #4
rpl
Registered User
 
Join Date: Aug 2009
Location: NOVA
Posts: 672
My Ride: 2002 330ci
lol wat

i didnt know e46s came with front leds
__________________
rpl is offline   Reply With Quote
Old 09-19-2010, 02:29 PM   #5
Lusticles
Registered User
 
Join Date: Aug 2010
Location: Annapolis
Posts: 2,803
My Ride: 325Ci
HIDs. im pretty sure you guys know what he meant. Unless of course he wanted to make his BMW like an Audi R8.
__________________
number one Audi Fan
Lusticles is offline   Reply With Quote
Old 09-19-2010, 04:05 PM   #6
Mango
Over 15,000 visitors
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 22,559
My Ride: M54B30
No. You're wrong. I did not know what he meant. And I still don't.
__________________
A lifetime free of problems if you follow my guides
Cooling | Maintenance | Suspension | Vacuum | Supreme Reliability | Details

OVER A MILLION VIEWS
Mango is offline   Reply With Quote
Old 09-19-2010, 04:19 PM   #7
E46DrEaMeR
Registered User
 
Join Date: Jul 2010
Location: UK
Posts: 276
My Ride: 2002 320Cic
maybe by "LED`s" he meant his halos/angel eyes
E46DrEaMeR is offline   Reply With Quote
Old 09-19-2010, 04:43 PM   #8
mack89
Registered User
 
Join Date: Jan 2009
Location: Texas
Posts: 2,334
My Ride: '02 TIAG 330i 5spd
Could be LCI style LED corners? Video is definitely needed
__________________
mack89 is offline   Reply With Quote
Old 09-19-2010, 07:56 PM   #9
JK1150
Registered User
 
Join Date: Dec 2007
Location: NJ, USA
Posts: 1,022
My Ride: 2004 325CI
He may have front LED turn signals?
JK1150 is offline   Reply With Quote
Old 09-19-2010, 08:01 PM   #10
Chris-TK
Registered User
 
Join Date: Jun 2007
Location: Sacramento
Posts: 16,309
My Ride: Mk VI GTI
LED corners? If so those things are pieces of junk.
__________________
K.
Chris-TK is offline   Reply With Quote
Old 09-19-2010, 08:10 PM   #11
iansanderson
Registered User
 
Join Date: Feb 2009
Location: Northeast Ohio
Posts: 2,778
My Ride: 2001 330CiC
No E46 came with any LED's on the front of the vehicle.

Are you referring to your Xenon headlamps? List every electrical aftermarket item installed on your car please.
__________________



Cheat Sheet:

GT1/ISIS/MoDiC = Factory authorized diagnostic system used by BMW dealerships across the world.

NCS Expert = BMW Factory R&D programming tool available on the internet (not intended for the public and not available to the dealership network)

OEM = Genuine BMW part only available from a franchised BMW dealership.

DME = Engine Management Computer
iansanderson is offline   Reply With Quote
Old 09-19-2010, 08:23 PM   #12
smoke96
Registered User
 
Join Date: Jun 2009
Location: jersey city nj
Posts: 649
My Ride: 2004 325ci
hes probably referring to HID's. in that case i know it had something to do with a bad ground in the tail lights which in turn resets the light control module which causes your flickering problem. it would be great if someone could link a DIY for it cause i just tried finding one and came out with nothing. i have the same issue.
__________________



[QUOTE=Back2Basics;11538236]So you're gonna have your food delivered to you while you sit at your computer screen on the 112th floor responding to questions about dildo's and sex lube's while strangers fill your bank account to acquire the tools needed for their sick, guilty pleasures?
That's pretty ****ing legit man.
smoke96 is offline   Reply With Quote
Old 09-19-2010, 08:50 PM   #13
LoopyCootiebrain
Registered User
 
Join Date: Sep 2010
Location: Los Angeles
Posts: 3
My Ride: BMW 325
YEAH,
my bad i did not mean LED lights.
I am not guna lie, my car terminology is extremely poor.

I am talking about the stock Xenon headlights.

its not at all a problem during the daytime ofcourse, but i need to get it fixed using my own money cause i am a student

Any help would be appreciated
LoopyCootiebrain is offline   Reply With Quote
Old 09-19-2010, 09:14 PM   #14
Chris-TK
Registered User
 
Join Date: Jun 2007
Location: Sacramento
Posts: 16,309
My Ride: Mk VI GTI
Quote:
Originally Posted by LoopyCootiebrain View Post
YEAH,
my bad i did not mean LED lights.
I am not guna lie, my car terminology is extremely poor.

I am talking about the stock Xenon headlights.

its not at all a problem during the daytime ofcourse, but i need to get it fixed using my own money cause i am a student

Any help would be appreciated
orly?
__________________
K.
Chris-TK is offline   Reply With Quote
Old 09-19-2010, 09:18 PM   #15
smoke96
Registered User
 
Join Date: Jun 2009
Location: jersey city nj
Posts: 649
My Ride: 2004 325ci
i didnt get that either.
__________________



[QUOTE=Back2Basics;11538236]So you're gonna have your food delivered to you while you sit at your computer screen on the 112th floor responding to questions about dildo's and sex lube's while strangers fill your bank account to acquire the tools needed for their sick, guilty pleasures?
That's pretty ****ing legit man.
smoke96 is offline   Reply With Quote
Old 09-23-2010, 12:50 PM   #16
LoopyCootiebrain
Registered User
 
Join Date: Sep 2010
Location: Los Angeles
Posts: 3
My Ride: BMW 325
I got it fixed.
Apparently there was a circuit error, and it was fixed by a local german auto shop for $150.
LoopyCootiebrain is offline   Reply With Quote
Old 09-23-2010, 01:02 PM   #17
Alex323Ci
Registered User
 
Join Date: Jan 2005
Location: Huntington Beach -Surf City USA
Posts: 16,882
My Ride: M3 & 323Ci (sold)
wow, i sorry members didn't try and help you fix the issue better. especially since you are so new and asked for help.
i didn't see your post until now.
there are a few thing that could have been asked to help diagnose the issue and possible fixes you could have done.

also in the future there is a Lighting Forum section on this site.
http://forum.E46Fanatics.com/forumdisplay.php?f=88

Welcome to the site, you should find better help in the future
__________________
OE CSL WHEELS - OE CSL BRAKES - OE AUTOFLD MIRRORS - CSL TRUNK - CSL DIFFUSER - AA TUNE - AA PULLEYS - AS 40% SSK - BILSTEIN PSS9s
CF CSL LIP - NAVI - BMWPERF CF STRUT BAR - BMW GROUP N MNTS - GRUPPE M CF INTAKE - SUPERSPRINT - UUC BRKLINES, TRANS, RTABs - H&R SWAYS - 4.10 M-SPORT DIFF
Alex323Ci is offline   Reply With Quote
Old 09-23-2010, 01:05 PM   #18
DangerousMind
Registered User
 
Join Date: Nov 2005
Location: SF Bay area
Posts: 991
My Ride: Sierra 1500 SLT
He got it fixed. On the other paw, my cold air exhaust has a leak. How do I fix it?
__________________
DangerousMind is offline   Reply With Quote
Old 09-23-2010, 02:10 PM   #19
carsos
Registered User
 
Join Date: Jan 2009
Location: Dallas
Posts: 410
My Ride: '03 325Ci
Quote:
Originally Posted by smoke96 View Post
hes probably referring to HID's. in that case i know it had something to do with a bad ground in the tail lights which in turn resets the light control module which causes your flickering problem. it would be great if someone could link a DIY for it cause i just tried finding one and came out with nothing. i have the same issue.
http://forum.e46fanatics.com/showthread.php?t=512469

scroll down a bit for pictures
carsos is offline   Reply With Quote
Old 06-07-2013, 10:48 AM   #20
iWeldonJ
Registered User
 
Join Date: Mar 2013
Location: Pasadena
Posts: 213
My Ride: 325Ci
Sorry to bring this back from the dead, but it's a problem that does come up often. And since no one here seemed to get the problem. Here's a video of the issue. The fix is... "its the number three wire right rear tail light !!!!!! the brown wire is grounding out!!!"

__________________

Last edited by iWeldonJ; 06-07-2013 at 10:49 AM.
iWeldonJ is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use